Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Responsable 2D/3D/Jeux


    Avatar de LittleWhite
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mai 2008
    Messages
    23 706
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 23 706
    Points : 171 393
    Points
    171 393
    Billets dans le blog
    35

    Par défaut Raspberry Pi 3 - Découverte et mise en route

    Bonjour à tous,

    Je viens d'écrire un nouveau tutoriel sur le Raspberry Pi 3. Le but de mon article est de présenter ce qu'est le Raspberry Pi 3, ce que vous allez recevoir si vous en commandez un et toutes les petites choses qu'il faut savoir. Aussi, ce sera l'occasion de faire nos premiers pas sur le nano-ordinateurs (démarrage du système de base, configuration de base).

    Bonne lecture
    Vous souhaitez participer à la rubrique 2D/3D/Jeux ? Contactez-moi

    Ma page sur DVP
    Mon Portfolio

    Qui connaît l'erreur, connaît la solution.

  2. #2
    Expert éminent
    Avatar de Auteur
    Profil pro
    Inscrit en
    avril 2004
    Messages
    6 964
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 6 964
    Points : 9 599
    Points
    9 599

    Par défaut

    Bonjour,

    ayant acquis une Raspberry très récemment je me suis trouvé rapidement face à un petit souci. Quand on arrête le système, comment le redémarre-t-on ? En effet, sur cette carte il n'y a aucun bouton "start" : on branche l'alimentation et ça démarre.

    Deux questions se posent :
    1. Il y a 2 pins nommés "Run" sur la carte, peut-on les utiliser pour démarrer le système en soudant sur la carte un bouton poussoir ? Les réponses trouvées sur le net ne me satisfont pas : il est dit que ce connecteur est un "reset", mais je n'ai pas d'indication me disant que je peux effectivement l'utiliser pour démarrer (pas redémarrer) le système.
    2. Faut-il débrancher puis rebrancher l'alimentation (ou couper le câble et y insérer un bouton poussoir également) ?

    Quelle donc la meilleure solution ?

  3. #3
    Responsable 2D/3D/Jeux


    Avatar de LittleWhite
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mai 2008
    Messages
    23 706
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 23 706
    Points : 171 393
    Points
    171 393
    Billets dans le blog
    35

    Par défaut

    Bonjour,

    Je n'ai pas encore regarder en détail les GPIO. Du coup, je ne peux pas encore répondre précisément.
    Pour redémarrer, il y a la solution logicielle : redémarrage par l'OS. Sinon, ce que je fais jusqu'à présent : arrêt du système, puis débranchement/branchement de l'alimentation.
    Vous souhaitez participer à la rubrique 2D/3D/Jeux ? Contactez-moi

    Ma page sur DVP
    Mon Portfolio

    Qui connaît l'erreur, connaît la solution.

  4. #4
    Expert éminent
    Avatar de Auteur
    Profil pro
    Inscrit en
    avril 2004
    Messages
    6 964
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 6 964
    Points : 9 599
    Points
    9 599

    Par défaut

    Citation Envoyé par LittleWhite Voir le message
    arrêt du système, puis débranchement/branchement de l'alimentation.
    mouai A la longue, le port usb peut se détériorer. Donc je pense insérer dans le câble d'alimentation un bouton poussoir pour démarrer le système.

  5. #5
    Responsable 2D/3D/Jeux


    Avatar de LittleWhite
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mai 2008
    Messages
    23 706
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 23 706
    Points : 171 393
    Points
    171 393
    Billets dans le blog
    35

    Par défaut

    Pour ce cas, je pense que l'on peut fournir l'alimentation à travers le GPIO, non ?
    Sinon, on peut brancher/débrancher côté prise électrique .
    Vous souhaitez participer à la rubrique 2D/3D/Jeux ? Contactez-moi

    Ma page sur DVP
    Mon Portfolio

    Qui connaît l'erreur, connaît la solution.

  6. #6
    Rédacteur


    Homme Profil pro
    Instituteur retraité
    Inscrit en
    novembre 2015
    Messages
    686
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Instituteur retraité
    Secteur : Enseignement

    Informations forums :
    Inscription : novembre 2015
    Messages : 686
    Points : 3 124
    Points
    3 124
    Billets dans le blog
    1

    Par défaut

    Citation Envoyé par LittleWhite Voir le message
    Sinon, on peut brancher/débrancher côté prise électrique .
    Ou tout simplement, comme je fais chez moi pour la Raspberry qui me sert de serveur multimédia sur ma télé: une multiprise avec interrupteur !
    Plus on apprend, plus on découvre que ce que l'on sait est insignifiant face à tout ce que l'on ne sait pas.
    Retrouvez la liste de mes articles et tutoriels sur la sauvegarde-restauration, les distributions éducatives, le système Linux et la Raspberry pi en cliquant sur ce lien.

  7. #7
    Expert éminent
    Avatar de Auteur
    Profil pro
    Inscrit en
    avril 2004
    Messages
    6 964
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 6 964
    Points : 9 599
    Points
    9 599

    Par défaut

    Je vais creuser l'idée du GPIO, et l'utilisation des pins "run" pour un démarrage sans toucher à l'alimentation.

  8. #8
    Modérateur

    Avatar de Vincent PETIT
    Homme Profil pro
    Ancien développeur matériel électronique (Hard/Soft)
    Inscrit en
    avril 2002
    Messages
    2 130
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Ancien développeur matériel électronique (Hard/Soft)
    Secteur : Service public

    Informations forums :
    Inscription : avril 2002
    Messages : 2 130
    Points : 6 836
    Points
    6 836

    Par défaut

    Bonjour à tout le groupe,
    J'ai récemment acquis un Raspberry PI version 3 alors merci pour ce tuto !

    Citation Envoyé par Auteur Voir le message
    [...]Quand on arrête le système, comment le redémarre-t-on ? En effet, sur cette carte il n'y a aucun bouton "start" : on branche l'alimentation et ça démarre.
    Je pense que comme pour une Box Internet ou un smartphone, le Raspberry n'est pas destiné a être souvent arrêté. Ce qui peut expliquer l'absence d'interrupteur marche/arrêt.

    Citation Envoyé par Auteur Voir le message
    mouai A la longue, le port usb peut se détériorer. Donc je pense insérer dans le câble d'alimentation un bouton poussoir pour démarrer le système.
    C'est une bonne idée. Faire comme pour un PC, avoir un bouton poussoir pour allumer le Raspberry ou l'éteindre ou le mettre en veille automatiquement mais ceci implique de mettre en place un peu d'électronique constamment alimenté.

    Citation Envoyé par LittleWhite Voir le message
    Pour ce cas, je pense que l'on peut fournir l'alimentation à travers le GPIO, non ?
    Sinon, on peut brancher/débrancher côté prise électrique .
    Ça par contre j'y avais déjà regardé sur le Raspberry B+.
    Oui on peut mais comme je l'explique ici, je ne le conseil pas http://www.developpez.net/forums/d12...i/#post8363684

    Il y a des protections (F1 est un fusible 2A, diode anti-inversion composée de l'astuce dans le cadre noir et une diode transil notée D5 qui a pour rôle d'écrêter tous les perturbations dépassant les 5V)



    Si on alimente par autre part, ça fonctionnera mais on perd toute les protections
    La science ne nous apprend rien : c'est l'expérience qui nous apprend quelque chose.
    Richard Feynman

  9. #9
    Modérateur

    Avatar de Vincent PETIT
    Homme Profil pro
    Ancien développeur matériel électronique (Hard/Soft)
    Inscrit en
    avril 2002
    Messages
    2 130
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Ancien développeur matériel électronique (Hard/Soft)
    Secteur : Service public

    Informations forums :
    Inscription : avril 2002
    Messages : 2 130
    Points : 6 836
    Points
    6 836

    Par défaut

    Citation Envoyé par Auteur Voir le message
    Je vais creuser l'idée du GPIO, et l'utilisation des pins "run" pour un démarrage sans toucher à l'alimentation.
    Je n'arrive pas a trouver le schéma complet pour voir ces pins "run" ???
    Est ce que quelqu'un a le lien ?

    Merci.
    La science ne nous apprend rien : c'est l'expérience qui nous apprend quelque chose.
    Richard Feynman

  10. #10
    Expert éminent
    Avatar de Auteur
    Profil pro
    Inscrit en
    avril 2004
    Messages
    6 964
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 6 964
    Points : 9 599
    Points
    9 599

    Par défaut

    J'ai trouvé ceci : https://www.raspberrypi.org/documentation/hardware/
    Après avoir vu les schémas proposés :
    Raspberry Pi > schematics
    Compute module > datasheet

    Le port RUN est sur le pin 177 du composant mais je n'ai pas l'impression qu'il y ait un lien avec le port GPIO de la carte. Il faut que l'entrée soit à l'état bas pour que la carte reboote.


    Pour le Pi 2 j'ai trouvé ce sujet http://raspberrypi.stackexchange.com...raspberry-pi-2 mais j'ignore si cela s'applique au Pi 3.

  11. #11
    Membre expert
    Avatar de ideefixe
    Homme Profil pro
    reconditionnement d'ordinateurs
    Inscrit en
    mai 2014
    Messages
    367
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Cher (Centre)

    Informations professionnelles :
    Activité : reconditionnement d'ordinateurs

    Informations forums :
    Inscription : mai 2014
    Messages : 367
    Points : 3 201
    Points
    3 201
    Billets dans le blog
    13

    Par défaut Installation sur carte SD

    Bonjour,
    à l'étape de l'installation sur la carte SD, vous proposez d'utiliser la commande "dd" sous Linux, Win32manager sous Windows et un autre logiciel sous Mac OS.

    Voulez-vous essayer Etcher, multi-plateforme, qui grave des fichiers img sur carte SD ?
    Apprendre à utiliser rapidement les distributions Linux pour enfants, débutants, associations humanitaires.

    Rédiger une actualité sur Developpez.com

  12. #12
    Nouveau membre du Club Avatar de ftp-search
    Homme Profil pro
    chômeur
    Inscrit en
    avril 2018
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : chômeur
    Secteur : Transports

    Informations forums :
    Inscription : avril 2018
    Messages : 13
    Points : 35
    Points
    35

    Par défaut installation sur le disque dur usb externe format 3.5 ide wd 80gb

    Bonjour,

    tout d'abord un GRAND MERCI à l'auteur, j'ai suivi scrupuleusement tout le tuto pour l'installation de raspbian via berryboot sur un disque dur ide wd 80gb dans un boitier externe interface usb... tout c'est déroulé sans encombre... mais au redémarrage final (raspberry éteint, j'enlève la carte et je rallume) et RIEN...

    je ne sais plus quoi faire j'ai essayé dans tous les sens quelque chose m'échappe ! quelqu'un aurais une idée ?

    ps: j'ai aussi "penser à un souci de jumper" sur mon dd ... mais rien, les partitions sont crées etc ... tout à l'air en ordre...

  13. #13
    Responsable 2D/3D/Jeux


    Avatar de LittleWhite
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mai 2008
    Messages
    23 706
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 23 706
    Points : 171 393
    Points
    171 393
    Billets dans le blog
    35

    Par défaut

    De mémoire, le RPi ne peut pas booter sur un disque dur externe. On le voit dans la première note : https://alexandre-laurent.developpez...n-systeme/#LIV (la carte SD reste nécessaire )
    Vous souhaitez participer à la rubrique 2D/3D/Jeux ? Contactez-moi

    Ma page sur DVP
    Mon Portfolio

    Qui connaît l'erreur, connaît la solution.

  14. #14
    Nouveau membre du Club Avatar de ftp-search
    Homme Profil pro
    chômeur
    Inscrit en
    avril 2018
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : chômeur
    Secteur : Transports

    Informations forums :
    Inscription : avril 2018
    Messages : 13
    Points : 35
    Points
    35

    Par défaut

    Bonjour, merci pour votre réponse, mais je ne comprends pas...

    Citation Envoyé par LittleWhite Voir le message
    De mémoire, le RPi ne peut pas booter sur un disque dur externe. On le voit dans la première note : https://alexandre-laurent.developpez...n-systeme/#LIV (la carte SD reste nécessaire )
    car sur la notre il est stipulé:

    I. Introduction▲
    Le Raspberry Pi charge son système d'exploitation à partir du lecteur de carte micro SD. Le Raspberry Pi 3 a aussi la possibilité de charger le système à partir d'une clé USB ou du réseau sans avoir recours à la carte SD. Il est donc nécessaire de préparer le système de manière appropriée pour que le nano ordinateur puisse démarrer.

    c'est fait ... puis

    IV. Installation sur un périphérique de stockage USB▲
    À partir du Raspberry Pi 3, il est possible de lire le système à partir d'un périphérique de stockage connecté en USB, sans carte SD.

    Cette fonctionnalité est expérimentale. De plus, il est nécessaire d'avoir une carte SD pour activer et mettre en place le démarrage du Raspberry Pi sur le périphérique de stockage USB. (pour l'installation d'accord)

    donc il me semble avoir compris qu'il fallait installer le système sur la carte sd, puis recopier celui ci via diverses manipulations sur le dd

    ce qui donne

    IV-D. Préparation du périphérique de stockage USB▲
    L'idée générale est que nous allons dupliquer sur le périphérique de stockage USB le système installé sur la carte SD. Pour des raisons de simplicité, on travaille à partir du Raspberry Pi démarré avec Raspbian.

    et

    IV-D-4. Configuration du démarrage par USB, création de partition etc ....

    enfin

    IV-D-5. Finalisation▲
    Le périphérique est prêt. Démontez-le et arrêtez le système : ...

    Sélectionnez
    cd ~
    sudo umount /mnt/target/boot
    sudo umount /mnt/target
    sudo poweroff
    Débranchez votre Raspberry Pi, enlevez la carte SD et rebranchez l'alimentation. Le système démarrera sur le périphérique USB.


    tout cela me semble ultra cohérent ... mais cela ne fonctionne pas (chez moi ...)

    ou périphérique de stockage USB = clef usb seulement ? cela me semble réducteur ? parce que dans la suite on peut booter via la reseau sans carte (apres installation évidemment)

    une autre idée ?

  15. #15
    Expert éminent
    Avatar de Auteur
    Profil pro
    Inscrit en
    avril 2004
    Messages
    6 964
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 6 964
    Points : 9 599
    Points
    9 599

    Par défaut

    bonjour,


    il semblerait qu'il soit possble de booter sur un disque dur en manipulant certains fichiers systèmes notamment ceux qui gèrent le démarrage (cmdline.txt entre autres) :
    https://www.maketecheasier.com/boot-...nal-hard-disk/

  16. #16
    Nouveau membre du Club Avatar de ftp-search
    Homme Profil pro
    chômeur
    Inscrit en
    avril 2018
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : chômeur
    Secteur : Transports

    Informations forums :
    Inscription : avril 2018
    Messages : 13
    Points : 35
    Points
    35

    Par défaut

    Merci pour la réponse,

    j'essaye donc ce tuto ... et reviens vers vous vite

    cependant j'ai déjà essayé ceux là sans succès .... ( moins d'avoir loupé une marche ...

    https://soozx.fr/raspberry-pi-deplac...isque-cle-usb/

    https://www.framboise314.fr/boot-sim...y-pi-1-2-et-3/

    http://jc.mascarelli.pagesperso-oran...boot_d_dur.htm

    https://www.imnotgeek.com/15-11-2016...-cle-usb-28534

  17. #17
    Responsable 2D/3D/Jeux


    Avatar de LittleWhite
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mai 2008
    Messages
    23 706
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 23 706
    Points : 171 393
    Points
    171 393
    Billets dans le blog
    35

    Par défaut

    Je suis confus.
    Avez-vous bien un RPi modèle 3 ?
    Avez-vous bien mis à jour le noyau et le micro logiciel ?
    Avez-vous bien vérifier que le boot USB est actif ?
    Le disque dur s'allume t-il ?
    Quelque chose s'affiche t-il sur la sortie HDMI ?
    Vous souhaitez participer à la rubrique 2D/3D/Jeux ? Contactez-moi

    Ma page sur DVP
    Mon Portfolio

    Qui connaît l'erreur, connaît la solution.

  18. #18
    Nouveau membre du Club Avatar de ftp-search
    Homme Profil pro
    chômeur
    Inscrit en
    avril 2018
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : chômeur
    Secteur : Transports

    Informations forums :
    Inscription : avril 2018
    Messages : 13
    Points : 35
    Points
    35

    Par défaut la suite ! installation sur le disque dur usb externe format 3.5 ide wd 80gb

    pas de soucis merci de vous intéresser,
    ci joint les réponses à vos questions Little White

    Citation Envoyé par LittleWhite Voir le message
    Je suis confus.
    Avez-vous bien un RPi modèle 3 ? oui avec alimentation akuru 3A... etc ...
    Avez-vous bien mis à jour le noyau et le micro logiciel ? tout a fait suivant le tuto avec rpi .... j'ai bien vu l'installation et la progression
    Avez-vous bien vérifier que le boot USB est actif ? tout a fait la réponse est correcte
    Le disque dur s'allume t-il ? il s'allume bien, on dirait qu'il va démarrer mais rien ... pourtant après de multiples essais il fonctionne bien en disque secondaire sur un pc "normal" sous linux Lubuntu 16.04
    Quelque chose s'affiche t-il sur la sortie HDMI ? rien du tout...
    c'est pour cela que je me dis que j'ai du louper une marche (mais laquelle ???) car les tutos sont clairs ! je suis en train d'essayer celui cité au dessus...




    Suite à d'autres essais j'ai ceci : je fais toujours référence à ce tuto d'installation

    jusqu'à cette étape tout fonctionne à merveille et après ... C'EST LA SURPRISE !


    IV-D-4. Configuration du démarrage par USB▲
    Le Raspberry Pi est configuré pour démarrer sur le périphérique USB. Toutefois, comme nous avons copié un système prévu pour démarrer sur la carte SD, il est nécessaire de modifier deux fichiers référençant la carte SD et non le périphérique de stockage USB :

    le fichier de démarrage /boot/cmdline.txt :

    Sélectionnez
    sudo sed -i "s,root=/dev/mmcblk0p2,root=/dev/sda2," /mnt/target/boot/cmdline.txt


    voici mon fichier de démarrage /boot/cmdline.txt d'origine

    /dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=d42fc461-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
    PARTUUID=d42fc461-02 correspondant à la seconde partition de ma carte SD en ext4


    voici mon fichier de démarrage /boot/cmdline.txt modifié par mes soins 1 ère version

    /dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/sda2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
    /dev/sda2 correspondant à la seconde partition de mon disque dur


    voici mon fichier de démarrage /boot/cmdline.txt modifié par mes soins 2 ème version

    /dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=fa86b5d4-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
    PARTUUID=fa86b5d4-02 correspondant à la partion ext4 de mon disque dur


    le fichier système énumérant les partitions à utiliser /etc/fstab :
    Sélectionnez
    sudo sed -i "s,/dev/mmcblk0p,/dev/sda," /mnt/target/etc/fstab

    voici mon fichier /etc/fstab d'origine

    les "PARTUUID=d42fc461-01 et PARTUUID=d42fc461-02 correspondant aux partitions de ma carte sd donc vfat et ext4

    proc /proc proc defaults 0 0
    PARTUUID=d42fc461-01 /boot vfat defaults 0 2
    PARTUUID=d42fc461-02 / ext4 defaults,noatime 0 1

    PARTUUID=fa86b5d4-01 PARTUUID=fa86b5d4-02 étant les deux partitions de mon disque dur 3.5" maxtor 80 GB IDE correspondant à sda1 et sda2
    voici mon fichier /etc/fstab modifié par mes soins 1 ère version

    proc /proc proc defaults 0 0
    /dev/sda1 /boot vfat defaults 0 2
    /dev/sda2 ext4 defaults,noatime 0 1
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that
    voici mon fichier /etc/fstab modifié par mes soins 2 ème version

    proc /proc proc defaults 0 0
    PARTUUID=fa86b5d4-01 /boot vfat defaults 0 2
    PARTUUID=fa86b5d4-02 ext4 defaults,noatime 0 1
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that

    PARTUUID=fa86b5d4-01 PARTUUID=fa86b5d4-02 étant les deux partitions de mon disque dur 3.5" maxtor 80 GB IDE correspondant à sda1 et sda2

    pour IV-C. Activation du mode▲
    Éditez le fichier /boot/config.txt pour ajouter la ligne :

    Sélectionnez
    program_usb_boot_mode=1


    voici mon fichier /boot/config.txt

    # For more options and information see
    # http://rpf.io/configtxt
    # Some settings may impact device functionality. See link above for details

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1

    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1

    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16

    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720

    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1

    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4

    # uncomment for composite PAL
    #sdtv_mode=2

    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800

    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on

    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi

    # Additional overlays and parameters are documented /boot/overlays/README

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    program_usb_boot_mode=1
    tout ceci fait avec la dernière version de raspbian dispo 2018-04-18-raspbian-stretch.img

    après tout cela cela ne démarre pas ... pour le moment je ne sais plus quoi faire .... auriez vous une idée ??? qu'ais je fait de si mal ????

  19. #19
    Nouveau membre du Club Avatar de ftp-search
    Homme Profil pro
    chômeur
    Inscrit en
    avril 2018
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : chômeur
    Secteur : Transports

    Informations forums :
    Inscription : avril 2018
    Messages : 13
    Points : 35
    Points
    35

    Par défaut suites des recherches pour booter en usb sur RPI3

    j'essaye actuellement ce tuto et me base sur les nombreux commentaires à suivre...

  20. #20
    Nouveau membre du Club Avatar de ftp-search
    Homme Profil pro
    chômeur
    Inscrit en
    avril 2018
    Messages
    13
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : chômeur
    Secteur : Transports

    Informations forums :
    Inscription : avril 2018
    Messages : 13
    Points : 35
    Points
    35

    Par défaut booter sur rpi3 en usb (disque ide 80 gb) avec ubuntu mate 16.04 version raspberry

    suite au précédent post toujours le même souci le disque ne démarre pas

    DONC une autre idée: changement d'os j'ai installé ubuntu mate 16.04 version raspberry suivant le tuto (on ne peut mieux) de little white (dans son intégralité) tout fonctionne mais rien ne boot ...

    le ficher config.txt est correct ainsi que le deux autres (ci joint la copie)

    cmdline.txt

    dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/sda2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
    fstab

    proc /proc proc defaults 0 0
    /dev/sda2 / ext4 defaults,noatime 0 1
    /dev/sda1 /boot/ vfat defaults 0 2
    pour moi tout me semble correct ... mais le dique dur usb ide wd 80gb ne boot pas ! UNE IDEE ?

    prochaine initiative changer de disque ... ?

    ps: la carte sd fonctionne à merveille !

Discussions similaires

  1. Mise en route Servlet, JSP avec Struts
    Par sir_gcc dans le forum Struts 1
    Réponses: 1
    Dernier message: 24/03/2007, 18h50
  2. Problème dans la mise en route
    Par tilou dans le forum WebDev
    Réponses: 3
    Dernier message: 29/12/2006, 18h11
  3. [Tomcat 5.5] mise en route
    Par pilou007 dans le forum Tomcat et TomEE
    Réponses: 4
    Dernier message: 11/04/2006, 14h31

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo