IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Apache Discussion :

Redémarrage serveur après modification de scripts


Sujet :

Apache

  1. #1
    Candidat au Club
    Inscrit en
    décembre 2008
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : décembre 2008
    Messages : 11
    Points : 2
    Points
    2
    Par défaut Redémarrage serveur après modification de scripts
    Bonjour,

    J'ai installé un serveur apache, et à chaque fois que je modifie un script d'une page php, je suis obligé de redémarrer mon serveur pour que la modification soit prise en compte.
    J'ai essayé de vider l'historique internet mais rien à faire. Tant que je ne redémarre pas mon serveur apache, la modification n'est pas prise en compte, pour n'importe quelle modification de script.
    Y aurait il quelque chose à changer dans la configuration de mon serveur ?

    Merci pour votre aide

  2. #2
    Rédacteur
    Avatar de _Mac_
    Profil pro
    Inscrit en
    août 2005
    Messages
    9 601
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2005
    Messages : 9 601
    Points : 12 747
    Points
    12 747
    Par défaut
    Bonjour,

    mod_cache est activé ? On peut avoir ton fichier de configuration Apache ?

    Du détail, du détail, du détail !!!
    Revenons à la source : lisons la documentation et les fichiers de trace, la réponse à notre problème s'y trouve sans doute

  3. #3
    Candidat au Club
    Inscrit en
    décembre 2008
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : décembre 2008
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Bonjour,

    Merci de te soucier de mon problème,
    Je suis débutant en php
    voila mon fichier de config :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    LoadModule proxy_module /QSYS.LIB/QHTTPSVR.LIB/QZSRCORE.SRVPGM
    LoadModule proxy_http_module /QSYS.LIB/QHTTPSVR.LIB/QZSRCORE.SRVPGM
    LoadModule proxy_connect_module /QSYS.LIB/QHTTPSVR.LIB/QZSRCORE.SRVPGM
    LoadModule proxy_ftp_module /QSYS.LIB/QHTTPSVR.LIB/QZSRCORE.SRVPGM
    Listen *:89
    DocumentRoot /www/zendcore/htdocs
    Options -ExecCGI -FollowSymLinks -SymLinksIfOwnerMatch -Includes -IncludesNoExec -Indexes -MultiViews
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%{Cookie}n \"%r\" %t" cookie
    LogFormat "%{User-agent}i" agent
    LogFormat "%{Referer}i -> %U" referer
    LogFormat "%h %l %u %t \"%r\" %>s %b" common
    CustomLog logs/access_log combined
    SetEnvIf "User-Agent" "Mozilla/2" nokeepalive
    SetEnvIf "User-Agent" "JDK/1\.0" force-response-1.0
    SetEnvIf "User-Agent" "Java/1\.0" force-response-1.0
    SetEnvIf "User-Agent" "RealPlayer 4\.0" force-response-1.0
    SetEnvIf "User-Agent" "MSIE 4\.0b2;" nokeepalive
    SetEnvIf "User-Agent" "MSIE 4\.0b2;" force-response-1.0
    ProxyPass / http://127.0.0.1:8000/
    ProxyPassReverse / http://127.0.0.1:8000/
    <Directory />
       Order Deny,Allow
       Deny From all
    </Directory>
    <Directory /www/zendcore/htdocs>
       Order Allow,Deny
       Allow From all
    </Directory>
    <Location /ZendCore>
     Order Allow,Deny
      Allow From all
    </Location>
    Alias /ZendCore "/usr/local/Zend/Core/GUI"

  4. #4
    Rédacteur
    Avatar de _Mac_
    Profil pro
    Inscrit en
    août 2005
    Messages
    9 601
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2005
    Messages : 9 601
    Points : 12 747
    Points
    12 747
    Par défaut
    Je ne vois pas trop le problème... Y a quoi sur le port 8000 ? Quand tu modifies un fichier, il se trouve dans quel répertoire ? C'est un fichier du truc qui écoute sur le port 8000 ?

    Du détail, du détail, du détail !!!
    Revenons à la source : lisons la documentation et les fichiers de trace, la réponse à notre problème s'y trouve sans doute

  5. #5
    Candidat au Club
    Inscrit en
    décembre 2008
    Messages
    11
    Détails du profil
    Informations forums :
    Inscription : décembre 2008
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Toutes les pages sont dans le répertoire /www/zendcore/htdocs.

    En fait, le serveur que j'ai installé tourne sur un as400.
    les pages php, se trouvent dans un réprtoire sur l'as400.
    Je peux les executer en accédant au port 89 de l'as400.
    le port 8000 sert apparament de proxy, je ne sais pas trop, j'ai téléchargé la config sur le site de zendcore, je leur ai posé la question mais ils sont pas très réactifs sur leur forum.

    Il n'y aurait rien dans php ini ou dans la config qui activerais ou désactiverais un cache ou quelquechose qui executerais une page savegardé et non la nouvelle ?

  6. #6
    Rédacteur
    Avatar de _Mac_
    Profil pro
    Inscrit en
    août 2005
    Messages
    9 601
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2005
    Messages : 9 601
    Points : 12 747
    Points
    12 747
    Par défaut
    Je ne sais pas trop. Ca pourrait venir de Zend mais je ne connais pas du tout.

    C'est le même serveur Apache qui écoute sur le port 8000 ?

    Du détail, du détail, du détail !!!
    Revenons à la source : lisons la documentation et les fichiers de trace, la réponse à notre problème s'y trouve sans doute

Discussions similaires

  1. Saisie fabrication DiValto après redémarrage serveur
    Par didier_14 dans le forum Divalto
    Réponses: 1
    Dernier message: 15/10/2012, 18h23
  2. [MySQL] Après modification d'un nom, j'ai "Erreur 500 : Erreur interne du serveur"
    Par swampsnake dans le forum PHP & Base de données
    Réponses: 2
    Dernier message: 09/05/2009, 09h08
  3. Redémarrages automatiques après modification de JSP
    Par ubu37 dans le forum Tomcat et TomEE
    Réponses: 2
    Dernier message: 21/07/2008, 16h24
  4. Erreur de compilation après modification du Uses
    Par DevelOpeR13 dans le forum Langage
    Réponses: 5
    Dernier message: 30/10/2007, 14h23
  5. [] Datagrid vide après modification des propriétés
    Par SpaceFrog dans le forum VB 6 et antérieur
    Réponses: 9
    Dernier message: 20/09/2002, 16h37

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo