Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Expert éminent
    Quelle version d'Eclipse utilisez-vous ? Pourquoi ?
    Sondage archivé.
    Retrouvez le sondage actuel ici.

    -------------------------

    Bonjour,

    Nous renouvelons ce sondage sur l'utilisation d'Eclipse par nos membres : à savoir la version que vous utilisez principalement au quotidien.
    Vous pouvez également consulter l'archive 2008 de ce sondage.

    N'hésitez pas à poster vos impressions et sentiments sur la version que vous utilisez, les raisons de ce choix, ...

    N'oubliez pas également le sujet vous permettant de partager vos impressions sur les plugins que vous utilisez : http://www.developpez.net/forums/sho...ad.php?t=14436

  2. #2
    Membre émérite
    Bonjour,

    j'utilise pour le moment Eclipse Ganymède (3.4), mais je compte bien migrer sur Galileo lorsque la version stable s'approchera.
    "Le bon ni le mauvais ne me feraient de peine si si si je savais que j'en aurais l'étrenne." B.V.
    Non au langage SMS ! Je ne répondrai pas aux questions techniques par MP.
    Eclipse : News, FAQ, Cours, Livres, Blogs.Et moi.

  3. #3
    Expert éminent
    Citation Envoyé par xavlours Voir le message
    Bonjour,

    j'utilise pour le moment Eclipse Ganymède (3.4), mais je compte bien migrer sur Galileo lorsque la version stable s'approchera.
    Idem, j'utilise Ganymede pour le moment, mais je compte migrer vers Galileo dès la première RC (et/ou disponibilité des packages JEE/RCP).

  4. #4
    Membre averti
    Citation Envoyé par djo.mos Voir le message
    Idem, j'utilise Ganymede pour le moment, mais je compte migrer vers Galileo dès la première RC (et/ou disponibilité des packages JEE/RCP).
    exactement pareil ^^
    Aurélien Pupier
    Eclipse GMF-Runtime Committer
    R&D Eclipse Engineer, Studio Project Leader
    BonitaSoft S.A.

  5. #5
    Expert confirmé
    Bonjour
    Pareil que les précédents Ganymède (que j'utilise principalement), mais j'utilise aussi Europa une partie du temps(5%) vu que c'est qu'on utilise à la fac =>en vue Galileo
    Je suis ce que je suis grâce à ce que nous sommes tous Humanité aux Humains!! !

    Entre ce que je pense, ce que je veux dire, ce que je crois dire, ce que je dis ce que vous avez envie d'entendre, ce que vous croyez entendre, ce que vous entendez, ce que vous avez envie de comprendre, ce que vous comprenez ... Il y a dix possibilités que nous ayons des difficultés à communiquer. Mais essayons quand meme ....... E. Wells

  6. #6
    Membre averti
    Moi j'utilise Ganymede pour le moment uniquement pour développer en java. Et comme actuellement je fais du PHP 5 je ne savais pas qu'une autre version plus récente existait.
    Alors comme les autres j'attendrai une version plus stable et je m'y mettrai.

  7. #7
    Responsable Java

    J'utilise Ganymede pour tous les développements Eclipse et "pur Java".

    Le passage total vers Galileo se fera une fois la version finale sortie. Mais n'empêche que je jouerai avec pour étudier les nouveautés de la partie PDE et plateforme Workbench.

    Mickael
    Responsable Java de Developpez.com (Twitter et Facebook)
    Besoin d"un article/tutoriel/cours sur Java, consulter la page cours
    N'hésitez pas à consulter la FAQ Java et à poser vos questions sur les forums d'entraide Java
    --------
    Ingénieur de Recherche en informatique au LIAS / ISAE-ENSMA
    Page de Developpez.com : mbaron.developpez.com
    Twitter : www.twitter.com/mickaelbaron
    Blog : mickael-baron.fr
    LinkedIn : www.linkedin.com/in/mickaelbaron
    DBLP : dblp.uni-trier.de/pers/hd/b/Baron:Micka=euml=l

  8. #8
    Candidat au Club
    Bonjour,

    J'utilise GANYMEDE principalement, mais de temps en temps je repasse sous EUROPA pour utiliser certains plugins qui ne fonctionnent pas sous GANYMEDE. Le gros reproche que l'on pourrait faire sur cette version est qu'elle est très gourmande en ressources système. Mais à part ça, je la trouve très agréable pour développer plus vite.

  9. #9
    Rédacteur

    Je suis toujours sur une version 3.3 car je l'ai installée peu de temps après la sortie de la 3.4 et cette dernière n'était pas compatible avec JBoss Tools pour faire du JSF.
    Donc je suis resté à la 3.3 car j'ai eu la flemme de me mettre à jour
    Mais j'irais sur la 3.5 bientôt je pense...
    Nous sommes tous semblables, alors acceptons nos différences !
    --------------------------------------------------------------
    Liens : Blog | Page DVP | Twitter
    Articles : Hudson | Sonar | Outils de builds Java Maven 3 | Play! 1 | TeamCity| CitConf 2009
    Critiques : Apache Maven

  10. #10
    Candidat au Club
    Bonjour,

    J'utilise la 3.3.x au bureau. J'ai bien testé la Ganymede, mais vraiment trop gourmande en ressources sur le PC du bureau ... Déjà que j'arrive à faire planter la 3.3.x facilement en enchaînant trop rapidement les opérations, j'imagine pas la 3.4

  11. #11
    Membre expérimenté
    Comme beaucoup de monde, j'utilise la dernière version stable en priorité, donc Ganymède. Migration sur la suivante dès qu'elle sera stable.
    En premier lieu, utilisez un moteur de recherche.
    En second lieu, postez sur le forum adéquat !

  12. #12
    Membre confirmé
    GANYMEDE
    GANYMEDE avec PHPEclipse et SUBVersion

  13. #13
    Membre actif
    Pour ma part Ganimède, mes collègues Europa (je suis le seul à avoir fait le pas ... chair à canon ) et de même, en attente de la version stable de Galileo (pas trop le temps de me risquer à tester en ce moment) ...

  14. #14
    Nouveau membre du Club
    Utilisation d'ECLIPSE Ganymède 3.4.1
    Salut à tous,

    Je suis nouveau venu dans le monde JAVA à travers Eclipse que je trouve
    plutôt agréable et en Free pour un jeune Padawan comme moi.

    L'aspect riche de la communautée JAVA est aussi très apréciable,
    moi qui viens du monde Mainframe.

    Je vais d'aiileurs utiliser Eclipe en JAVA et en COBOL / SQL.

    Bye
    HULK77

  15. #15
    Rédacteur

    Moi la 3.2 pour 2 raisons très simple : pour le moment je ne dev avec Eclipse que sous Ubuntu, et la 3.2 est la version la plus récente disponible dans les packages

    Tutoriels sur les UPS, e-commerce, PHP, critiques de livres...

    Pensez à consulter les FAQs et les cours et tutoriels.
    FAQ Linux - Cours et tutoriels Linux - FAQ PHP - Cours et tutoriels PHP
    Ce forum est fait pour vous et surtout par vous, merci d'en respecter les règles.

    Je n'ai rien à voir avec la société www.ovh.com !

  16. #16
    Membre régulier
    J'utilise encore la version 3.1.1 pour développer.

    Pouvez-vous me dire les avantages a utiliser une version plus récente?

  17. #17
    Responsable Java

    Salut,

    Pouvez-vous me dire les avantages a utiliser une version plus récente?
    Il y en a beaucoup

    Du point de vue de la plateforme Eclipse, il y a de nouvelles APIs qui facilitent le développement d'applications Eclipse RCP.

    Comme exemples
    - la 3.1.1 n'est pas supportée par Vista
    - Support OSGi à partir de 3.2
    - de nombreux plugins ne fonctionnent pas avec les versions antérieures
    - ...

    Mickael
    Responsable Java de Developpez.com (Twitter et Facebook)
    Besoin d"un article/tutoriel/cours sur Java, consulter la page cours
    N'hésitez pas à consulter la FAQ Java et à poser vos questions sur les forums d'entraide Java
    --------
    Ingénieur de Recherche en informatique au LIAS / ISAE-ENSMA
    Page de Developpez.com : mbaron.developpez.com
    Twitter : www.twitter.com/mickaelbaron
    Blog : mickael-baron.fr
    LinkedIn : www.linkedin.com/in/mickaelbaron
    DBLP : dblp.uni-trier.de/pers/hd/b/Baron:Micka=euml=l

  18. #18
    Membre régulier
    Citation Envoyé par keulkeul Voir le message
    Salut,



    Il y en a beaucoup

    Du point de vue de la plateforme Eclipse, il y a de nouvelles APIs qui facilitent le développement d'applications Eclipse RCP.

    Comme exemples
    - la 3.1.1 n'est pas supportée par Vista
    - Support OSGi à partir de 3.2
    - de nombreux plugins ne fonctionnent pas avec les versions antérieures
    - ...

    Mickael
    Et quelle version me conseilleriez-vous de tester afin de continuer mes développement java?

    Merci

    MichaËl

  19. #19
    Rédacteur

    Citation Envoyé par mika0102 Voir le message
    Et quelle version me conseilleriez-vous de tester afin de continuer mes développement java?
    Probablement la dernière
    Je ne répondrai à aucune question technique en privé

  20. #20
    Responsable Java

    Et quelle version me conseilleriez-vous de tester afin de continuer mes développement java?
    Au vu de la version que tu utilises, je dirais également la dernière version : 3.4.2

    Par contre, il faut s'assurer que les plugins tiers que tu utilises soit compatibles avec la dernière version et là c'est pas gagné. Tu fais quand même un bon de plusieurs années.

    Mickael
    Responsable Java de Developpez.com (Twitter et Facebook)
    Besoin d"un article/tutoriel/cours sur Java, consulter la page cours
    N'hésitez pas à consulter la FAQ Java et à poser vos questions sur les forums d'entraide Java
    --------
    Ingénieur de Recherche en informatique au LIAS / ISAE-ENSMA
    Page de Developpez.com : mbaron.developpez.com
    Twitter : www.twitter.com/mickaelbaron
    Blog : mickael-baron.fr
    LinkedIn : www.linkedin.com/in/mickaelbaron
    DBLP : dblp.uni-trier.de/pers/hd/b/Baron:Micka=euml=l

###raw>template_hook.ano_emploi###