IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Bases de données Delphi Discussion :

Problème de connexion TFDConnection


Sujet :

Bases de données Delphi

  1. #1
    Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2012
    Messages
    81
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Algérie

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2012
    Messages : 81
    Points : 54
    Points
    54
    Par défaut Problème de connexion TFDConnection
    Bonjour à tous !

    Je travaille sous Windows 10 64 bits
    Et Delphi 10.4
    Je veux connecter mon application à un serveur distant INFORMIX 9.80.
    J'ai créé le DSN au niveau du ODBC, ça connecte normalement.
    j'ai placé un Tfdconnection, je l'ai paramétré en mode "Expert" et je teste la connexion, j'obtiens "réussi"
    Mais quand j'essaye de cocher "Connected" un message d'erreur s'affiche, disant que le driver n'est pas mentionné.

    Des idées ?

  2. #2
    Membre émérite Avatar de pprem
    Homme Profil pro
    MVP Embarcadero - développeur Delphi, PHP et JS
    Inscrit en
    juin 2013
    Messages
    1 153
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Loiret (Centre)

    Informations professionnelles :
    Activité : MVP Embarcadero - développeur Delphi, PHP et JS
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : juin 2013
    Messages : 1 153
    Points : 2 428
    Points
    2 428
    Par défaut
    Ajoute le composant TFDPhysXXXDriver correspondant à ta base de données. Ca devrait passer à l'exécution, mais dans l'IDE, c'est plus étrange qu'il bloque alors que c'est ok en testant depuis l'assistant.

  3. #3
    Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2012
    Messages
    81
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Algérie

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2012
    Messages : 81
    Points : 54
    Points
    54
    Par défaut
    J'utilisais le driver informix (infx),
    Dès que j'ai testé avec le driver ODBC ça marche sans faute !
    Merci quand même @pprem

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Première installation] Problème de connexion
    Par sekiryou dans le forum Installation
    Réponses: 2
    Dernier message: 02/03/2004, 20h18
  2. [ Oracle 9ias / 10g] problème de connexion
    Par Boosters dans le forum JDeveloper
    Réponses: 2
    Dernier message: 20/01/2004, 18h23
  3. Problème de connexion au serveur MYSQL
    Par ETOKA dans le forum Outils
    Réponses: 2
    Dernier message: 27/11/2003, 10h28
  4. Réponses: 11
    Dernier message: 13/10/2003, 15h48
  5. problème de connexion 2 PC
    Par guitalca dans le forum Développement
    Réponses: 3
    Dernier message: 22/09/2003, 15h04

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo