Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Android Java Discussion :

Error: Contenu non autorisé dans le prologue


Sujet :

Android Java

  1. #1
    Candidat au Club
    Error: Contenu non autorisé dans le prologue
    Salut les développeurs j'ai un bug qui m'empêche de poursuivre mon travail
    En fait le problème est le suivant :
    lorsque je lance un nouveau projet , sans l'avoir modifier ; je reçois une erreur stipulant Error: Contenu non autorisé dans le prologue
    cet erreur survient dans mon fichier colors.xml pendant le build du projet
    je souhaiterais etres gracier d'une solution par tous ceux qui le veulent bien merci d'avance

  2. #2
    Modérateur

    Salut,

    Ce type d'erreur est produit en général par un parser de fichier XML qui ne reconnait pas le fichier (en particulier le début). Vu l'extension du fichier, on cherche bien à lire un fichier XML, mais ton fichier n'a rien d'un fichier XML.
    L'expression "ça marche pas" ne veut rien dire. Indiquez l'erreur, et/ou les comportements attendus et obtenus, et donnez un Exemple Complet Minimal qui permet de reproduire le problème.
    La plupart des réponses à vos questions sont déjà dans les FAQs ou les Tutoriels, ou peut-être dans une autre discussion : utilisez la recherche interne.
    Des questions sur Java : consultez le Forum Java. Des questions sur l'EDI Eclipse ou la plateforme Eclipse RCP : consultez le Forum Eclipse.
    Une question correctement posée et rédigée et vous aurez plus de chances de réponses adaptées et rapides.
    N'oubliez pas de mettre vos extraits de code entre balises CODE (Voir Mode d'emploi de l'éditeur de messages).
    Nouveau sur le forum ? Consultez Les Règles du Club.

  3. #3
    Nouveau membre du Club
    Bonjour,

    J'ai exactement le même problème mais pas avec l'utilisation du fichier XML mais du fichier POM à l’exécution du premier projet comme montre l'image ci-joint.

    "Caused by: org.xml.sax.SAXParseException; systemId: file:/C:/Users/Forst/.gradle/caches/modules-2/files-2.1/com.android.tools.build/aapt2/3.5.0-5435860/6c4cbb583680b808bee7e4a01ec9e72dad862a17/aapt2-3.5.0-5435860.pom; "

    help