Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Rédacteur/Modérateur

    Avatar de Fabien Celaia
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    octobre 2002
    Messages
    4 152
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : Suisse

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Service public

    Informations forums :
    Inscription : octobre 2002
    Messages : 4 152
    Points : 18 372
    Points
    18 372
    Billets dans le blog
    23

    Par défaut AlwaysOn pas toujours Always on

    Bonjour,

    J'ai un cluster SQL AlwaysOn à 2 noeuds.

    Pour des raisons de maintenance, je devais redémarrer le noeud 2.

    J'ai donc passé tous mes Availability Groups sur le noeud1 sans souci.
    Tout était au vert, toutes les bases synchronisées.

    J'ai ensuite redémarré le noeud 2.

    J'ai maintenant une bonne moitié de bases OK (synchronized), mais le reste est en synchronizing.... et ce statut ne semble pas bouger avec le temps...

    Comment puis-je savoir ce qui bloque et comment puis-je réparer.... si possible sans passer par la suppression de la base secondaire, la suppression de la base primaire de l'availability group et son rajout ?

    Je pense qu'il s'agit du même problème qu'ici
    Sr DBA Oracle / MS-SQL / MySQL / Postgresql / SAP-Sybase / Informix / DB2

    N'oublie pas de consulter mes articles, mon blog, les cours et les FAQ SGBD

    Attention : pas de réponse technique par MP : pensez aux autres, passez par les forums !

  2. #2
    Expert éminent sénior
    Avatar de mikedavem
    Homme Profil pro
    Architecte de base de données
    Inscrit en
    août 2005
    Messages
    5 178
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ain (Rhône Alpes)

    Informations professionnelles :
    Activité : Architecte de base de données
    Secteur : Conseil

    Informations forums :
    Inscription : août 2005
    Messages : 5 178
    Points : 12 026
    Points
    12 026

    Par défaut

    Hello Fabien,

    La réponse n'est pas triviale ... Cela dépend du scénario de départ

    - Est-ce SYNCHRONIZING ou NOT SYNCRONIZING que tu vois? => Si 2ème alors peut être un problème côté base de données .. a voir dans les logs
    - Est-ce que tes bases étaient bien synchronisés quand tu as redémarré le 2ème noeud? => Dans ce cas un simple resume de la session de réplication va résoudre ton pb
    - Est-ce ta réplication n'est pas vue comme en asynchrone depuis le noeud primaire? => Dans ce cas il faut juste reconfigurer correctement en synchrone si tu vas avoir un état SYNCHRONIZED. En asynchrone SYNCHRONIZING est tout à fait normal
    - Si tu n'es dans aucun de ces cas il faut commencer à regarder dans les différents journaux SQL pour comprendre ce qui se passe

    ++

Discussions similaires

  1. Fonction ne retournant pas toujours une valeur
    Par mastochard dans le forum C
    Réponses: 14
    Dernier message: 25/05/2006, 13h13
  2. [CSS] a:active ne fonctionne pas toujours ?
    Par KpTn dans le forum Mise en page CSS
    Réponses: 2
    Dernier message: 10/05/2006, 18h25
  3. Réponses: 9
    Dernier message: 04/10/2005, 20h39
  4. db enregistre pas toujour
    Par cre3000 dans le forum Bases de données
    Réponses: 1
    Dernier message: 23/05/2005, 13h16
  5. [VB6] [Validate et CausesValidation] Ca marche pas toujours !!!
    Par HPJ dans le forum VB 6 et antérieur
    Réponses: 8
    Dernier message: 16/12/2003, 23h09

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo