Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Nouveau membre du Club
    Profil pro
    Inscrit en
    décembre 2012
    Messages
    50
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2012
    Messages : 50
    Points : 28
    Points
    28

    Par défaut Importation librairie sous vs2010

    Bonjour,

    Je viens de télécharger la derniere version d'Havok physics et animation (2012.2.0).

    Sous Visual Studio 2010 j'essaye de compiler une demo, il me met le message :
    Avertissement 118 warning LNK4099: PDB 'hkbase.pdb' n'a pu être trouvé avec 'hkBase.lib(hkVariantDataUtil.obj)' ou sur 'C:\...\hk2012_2_0_r1\Demo\StandAloneDemos\StepByStep\MemoryUtilInit\hkbase.pdb'*; l'objet sera lié sans informations de débogage C:\...\hk2012_2_0_r1\Demo\StandAloneDemos\StepByStep\MemoryUtilInit\hkBase.lib(hkVariantDataUtil.obj)
    Je pense que sa vient des fichiers .lib a importer.

    J'ai essayé de suivre ce tuto http://stardeath.developpez.com/tuto...ique/havok/fr/ mais c'est sous vs2008

    Si quelqu'un sait comment faire, ou voit d'ou vient mon problème, je suis preneur !

    Cordialement

  2. #2
    Membre expert

    Profil pro
    Inscrit en
    février 2006
    Messages
    2 082
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2006
    Messages : 2 082
    Points : 3 388
    Points
    3 388

    Par défaut

    le fichier .pdb est en fait une bibliothèque de symbole pour le débogage, absolument pas nécessaire pour l'exécution.

    havok, pour certaines configurations, telle full debug, ne fournis pas ces bibliothèques.

    donc tu devrais pouvoir jouer avec le moteur physique sans problème.

  3. #3
    Nouveau membre du Club
    Profil pro
    Inscrit en
    décembre 2012
    Messages
    50
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2012
    Messages : 50
    Points : 28
    Points
    28

    Par défaut

    en configuration Realease j'ai 1 message qui me demande de générer le debug



    Que je fasse oui ou non j'ai :
    Le programme '[1304] MemoryUtilInit_win32-vs2010_noSimd_release.exe: Natif' s'est arrêté avec le code 0 (0x0).

  4. #4
    Membre expert

    Profil pro
    Inscrit en
    février 2006
    Messages
    2 082
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2006
    Messages : 2 082
    Points : 3 388
    Points
    3 388

    Par défaut

    si tu parles du code exemple fournis dans le sdk havok (Demo\StandAloneDemos\StepByStep\MemoryUtilInit), de base il ne fait rien, il ne fait qu'initialiser le module de gestion de la mémoire.

    si tu veux un exemple qui fait réeelement de la simulation physique, regarde plutôt Demo\StandAloneDemos\ConsoleExampleMt
    par contre il me semble le mentionner dans l'article, certains samples ne font rien de graphiquement visible, il faut passer par le visual debugger pour voir quelque chose.

  5. #5
    Nouveau membre du Club
    Profil pro
    Inscrit en
    décembre 2012
    Messages
    50
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2012
    Messages : 50
    Points : 28
    Points
    28

    Par défaut

    ok sa marche !

    Du coup pour 1 exemple j'ai compilé et exécuté le projet qui montre les différents possibilité et sa a marché !

    Mon problème n'en était pas vraiment un .

  6. #6
    Membre expert

    Profil pro
    Inscrit en
    février 2006
    Messages
    2 082
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2006
    Messages : 2 082
    Points : 3 388
    Points
    3 388

    Par défaut

    Citation Envoyé par Johnny29 Voir le message
    ok sa marche !
    c'est bien ça l'essentiel, bonne continuation avec ce moteur physique !

Discussions similaires

  1. Import de librairie sous Netbeans en C
    Par Erouans dans le forum NetBeans
    Réponses: 2
    Dernier message: 06/12/2009, 03h22
  2. Import CSV sous Excel, garder les 0 inutile
    Par ePoX dans le forum Excel
    Réponses: 4
    Dernier message: 26/01/2009, 16h25
  3. Inclusion de librairie sous visual
    Par petdelascar dans le forum C
    Réponses: 11
    Dernier message: 07/12/2005, 20h39
  4. importer dump sous oracle 9i
    Par m@estro dans le forum Oracle
    Réponses: 9
    Dernier message: 24/10/2005, 14h13
  5. Importer librairies avec LCC WIN32
    Par Jiraiya42 dans le forum Autres éditeurs
    Réponses: 1
    Dernier message: 02/10/2005, 22h30

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo