Voir le flux RSS

Pierre Fauconnier

Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire

Noter ce billet
par , 20/10/2017 à 11h40 (366 Affichages)
Salut.

Pour savoir si un jour est ouvré ou férié, il y a plusieurs manières de faire, mais avec la fonction NB.JOURS.OUVRES.INTL(), c'est on ne peut plus facile:
  • Un tableau des jours fériés ( nommé t_Fériés dans ce billet)
  • Une grille de travail hebdomadaire, sous forme d'une suite de 0 (jour ouvré) et de 1 (jour férié)
  • Un peu d'astuce



Ainsi, si je souhaite calculer le nombre de jours ouvrés entre deux dates pour une personne qui travaille du lundi au vendredi, je peux utiliser la formule suivante, avec la date de départ en A1 et la date d'arrivée en B1: =NB.JOURS.OUVRES.INTL(A1;B1;"0000011";t_JoursFériés)

Oui, mais je souhaite savoir si un jour est ouvré ou pas...

Et bien, l'astuce consiste à renseigner la même date pour le départ et l'arrivée. En testant que la valeur retournée par la fonction est égale à 0 ou pas, on peut déterminer que la date pointe vers un jour ouvré ou férié...

=SI(NB.JOURS.OUVRES.INTL(A4;A4;$B$1;t_JoursFériés)>0;"Ouvré";"Férié")

Nom : 2017-10-20_103852.png
Affichages : 117
Taille : 13,9 Ko

Et 0010011, ça veut dire quoi? Cette suite de sept signes représente les jours de la semaine en commençant au lundi. Un 0 signale un jour ouvré, un 1 renseigne un jour férié:
  • 0010011 veut dire que l'on travaille lundi, mardi, jeudi et vendredi;
  • 0000011 veut dire que l'on travaille du lundi au vendredi;
  • 1001000 veut dire que l'on travaille mardi, mercredi, vendredi, samedi et dimanche.


Truc: Pour saisir ce code dans une cellule, faites-le précéder du signe ' (apostrophe) ou mettez votre cellule au format texte

Elle est pas belle, la vie

Envoyer le billet « Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire » dans le blog Viadeo Envoyer le billet « Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire » dans le blog Twitter Envoyer le billet « Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire » dans le blog Google Envoyer le billet « Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire » dans le blog Facebook Envoyer le billet « Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire » dans le blog Digg Envoyer le billet « Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire » dans le blog Delicious Envoyer le billet « Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire » dans le blog MySpace Envoyer le billet « Excel: Savoir si un jour est ouvré ou pas... en fonction du régime de travail hebdomadaire » dans le blog Yahoo

Mis à jour 20/10/2017 à 13h49 par Pierre Fauconnier

Catégories
Excel , MS Office , Trucs & Astuces

Commentaires