Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI Discussion :

Utiliser Qt Eclipse Integration sous Linux [Eclipse]


Sujet :

EDI

  1. #1
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut Utiliser Qt Eclipse Integration sous Linux
    Salut à tous et à toutes,

    Je galère pour installer Qt Eclipse Integration sous Eclipse sur Fedora 12 en appliquant les instructions dans ce lien.. Mais sans résultat !

    Le problème c'est que rien ne change dans l'interface d'Eclipse, aucun dossier Qt ne s'ajoute dans l'assistant New Project..

    Quelqu'un a-t-il une idée ? Merci d'avance.

  2. #2
    Rédacteur

    Avatar de johnlamericain
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2004
    Messages
    3 742
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Royaume-Uni

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 3 742
    Points : 8 140
    Points
    8 140
    Par défaut
    Citation Envoyé par Chatbour Voir le message
    Quelqu'un a-t-il une idée ? Merci d'avance.
    Tu as bien démarré Eclipse avec le paramètre "-clean" ?

  3. #3
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut
    oui déjà fait.

    pardonnes mon ignorance, je suis en fait habitué à travailler sous Windows : est-ce que Eclipse reconnait automatiquement QT ? La version 3 est déjà installé, et je suis entrains de compiler la version 4..

  4. #4
    Rédacteur

    Avatar de johnlamericain
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2004
    Messages
    3 742
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Royaume-Uni

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 3 742
    Points : 8 140
    Points
    8 140
    Par défaut
    Citation Envoyé par Chatbour Voir le message
    pardonnes mon ignorance, je suis en fait habitué à travailler sous Windows : est-ce que Eclipse reconnait automatiquement QT ? La version 3 est déjà installé, et je suis entrains de compiler la version 4..
    Il faut très certainement lui indiquer dans Eclipse mais ça ne change rien au fait qu'il faut que l'interface de Qt Eclipse integration aparraise pour que tu puisse le faire !

  5. #5
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut
    rien n'est apparu ! et je me demande pourquoi : il suffit de télécharger l'archive de Qt Eclipse Integration, l'extraire puis le mettre dans le chemin des plugins d'Eclipse. Et enfin de lancer Eclipse avec l'option -clean. C'est tout non ?

  6. #6
    Rédacteur

    Avatar de johnlamericain
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2004
    Messages
    3 742
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Royaume-Uni

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 3 742
    Points : 8 140
    Points
    8 140
    Par défaut
    Citation Envoyé par Chatbour Voir le message
    rien n'est apparu ! et je me demande pourquoi : il suffit de télécharger l'archive de Qt Eclipse Integration, l'extraire puis le mettre dans le chemin des plugins d'Eclipse. Et enfin de lancer Eclipse avec l'option -clean. C'est tout non ?
    Ba sur le papier oui c'est ça ! Comment tu as installé Eclipse, à partir du gestionnaire de paquet ou à la main ?

  7. #7
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut
    Citation Envoyé par johnlamericain Voir le message
    Ba sur le papier oui c'est ça ! Comment tu as installé Eclipse, à partir du gestionnaire de paquet ou à la main ?
    je ne souviens plus mais le chemin des plugins pour mon cas est /usr/lib/eclipse/plugins. Je pense donc que j'ai du l'installer avec le gestionnaire de paquets.

  8. #8
    Rédacteur

    Avatar de johnlamericain
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2004
    Messages
    3 742
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Royaume-Uni

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 3 742
    Points : 8 140
    Points
    8 140
    Par défaut
    Citation Envoyé par Chatbour Voir le message
    je ne souviens plus mais le chemin des plugins pour mon cas est /usr/lib/eclipse/plugins. Je pense donc que j'ai du l'installer avec le gestionnaire de paquets.
    Tu n'as créer aucun répertoire, juste déplacer ton plugins dedans ?

    Est ce que tu as également déplacer dans features ce répertoire et son contenu :

    com.trolltech.qtcpp.feature_1.6.1

  9. #9
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut
    euh, en fait d'abord j'ai mis juste le répertoire crée par l'extraction : ce répertoire s'appelait "eclipse" tout cours. Puis lorsque les choses n'ont pas marchés j'ai fait toute sorte de copier/coller comme apporter le contenu de ce répertoire dans le répertoire plugins....
    donc peux-tu s'il te plait me décrire exactement hiérarchie des répertoires ?
    merci.

  10. #10
    Rédacteur

    Avatar de johnlamericain
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2004
    Messages
    3 742
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Royaume-Uni

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 3 742
    Points : 8 140
    Points
    8 140
    Par défaut
    Citation Envoyé par Chatbour Voir le message
    euh, en fait d'abord j'ai mis juste le répertoire crée par l'extraction : ce répertoire s'appelait "eclipse" tout cours. Puis lorsque les choses n'ont pas marchés j'ai fait toute sorte de copier/coller comme apporter le contenu de ce répertoire dans le répertoire plugins....
    donc peux-tu s'il te plait me décrire exactement hiérarchie des répertoires ?
    merci.
    Ton problème vient de là ! Tu dois copier le contenue du répertoire eclipse dans /usr/lib/eclipse. Ton logiciel de copie devrais faire le reste.

    Au final tu auras :

    /usr/lib/eclipse
    -- features
    ---- com.trolltech.qtcpp.feature_1.6.1
    ------ .project
    ------ build.properties
    ------ Changes-1.4.0
    ------ feature.xml
    ------ ...
    -- plugins
    ---- com.trolltech.qtcpp.linux.x86_4.6.1
    ---- com.trolltech.qtcppdesigner.linux.x86_1.6.1
    ---- autre repertoires...
    ---- com.trolltech.qtcpp_1.6.1.jar
    ---- com.trolltech.qtcppdesigner.qtcpp_1.6.1.jar
    ---- autres fichiers...

  11. #11
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut
    merci merci merci merci beaucoup johnlamericain

    la prise en charge de du plugin s'est ajoutée dans la boite de dialogue Help -> About Eclipse Platform !

    que faire maintenant pour ajouter la bibliothèque Qt à Eclipse ?

    J'essayes de le faire mais il y a une message d'erreur qui s'affiche, je vais voir..

    Merci énormément tu m'as sauvé

  12. #12
    Rédacteur

    Avatar de johnlamericain
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2004
    Messages
    3 742
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Royaume-Uni

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 3 742
    Points : 8 140
    Points
    8 140
    Par défaut
    Citation Envoyé par Chatbour Voir le message
    J'essayes de le faire mais il y a une message d'erreur qui s'affiche, je vais voir..

    Merci énormément tu m'as sauvé
    Je ne l'ai jamais utilisé pour ma part mais peut être que cet article sur les Qt Labs Blogs peut t'aider : http://labs.trolltech.com/blogs/2007...ns-in-eclipse/

  13. #13
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut
    merci bien, maintenant lorsque j'ouvre la fenetre de configuration de Qt Eclipse Integration un message d'erreur s'affiche :
    Problems occurred when invoking code from plug-in: "org.eclipse.jface".

  14. #14
    Rédacteur

    Avatar de johnlamericain
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2004
    Messages
    3 742
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Royaume-Uni

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 3 742
    Points : 8 140
    Points
    8 140
    Par défaut
    Citation Envoyé par Chatbour Voir le message
    merci bien, maintenant lorsque j'ouvre la fenetre de configuration de Qt Eclipse Integration un message d'erreur s'affiche :
    Malheureusement c'est une erreur Eclipse et non plus Qt. J'ai fais quelque recherche sur le web, à priori le -clean ne change pas grand chose, la solution est la réinstallation d'éclipse...

    Regarde si tu ne trouves pas d'autres informations sur cette erreur.

  15. #15
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut
    Bonjour,

    le problème est résolu ! il m'a fallut désinstaller Fedora Eclipse et installer manuellement Eclipse Galileo contenant le plugin CDT puis ajouter le plugin QT Eclipse Integration, et enfin spécifier le chemin de la bibliothèque QT 4. C’était un bon exercice Linux ^^ A Dieu les assistants de Windows

    merci encore pour ton aide

    ah l'ami dernière question : le fait que j'ai téléchargé Eclipse manuellement et pas en passant par le gestionnaire de packages, y'a-t-il quelque chose a craindre ?

  16. #16
    Rédacteur

    Avatar de johnlamericain
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    août 2004
    Messages
    3 742
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Royaume-Uni

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 3 742
    Points : 8 140
    Points
    8 140
    Par défaut
    Citation Envoyé par Chatbour Voir le message
    ah l'ami dernière question : le fait que j'ai téléchargé Eclipse manuellement et pas en passant par le gestionnaire de packages, y'a-t-il quelque chose a craindre ?
    Non aucune, le gestionnaire de packages c'est pour faciliter l'utilisation au débutant mais techniquement tu peux gérer tes paquets toi même, Linux est construit comme ça. Tu ne peux pas comparer avec le registre de Windows ou autres joyeusetés de ce genre qui ont besoin d'une installation "propre" sous Windows.

    PS : il s'agit du framework Qt et non QT -> http://www.developpez.net/forums/d22...ter/qt-non-qt/

  17. #17
    Membre averti Avatar de Chatbour
    Profil pro
    Étudiant
    Inscrit en
    septembre 2006
    Messages
    431
    Détails du profil
    Informations personnelles :
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2006
    Messages : 431
    Points : 305
    Points
    305
    Par défaut
    merci
    Citation Envoyé par johnlamericain Voir le message
    PS : il s'agit du framework Qt et non QT -> http://www.developpez.net/forums/d22...ter/qt-non-qt/
    je vois, désolé je savais pas. En fait justement maintenant je connais une des raisons de tous ces modifications effectuées sur mes posts par les modérateurs

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Utiliser un fichier .exe sous linux?
    Par Guig74 dans le forum Administration système
    Réponses: 3
    Dernier message: 04/06/2007, 18h01
  2. Comment utiliser une librarie .so (sous linux)
    Par philipina dans le forum Linux
    Réponses: 14
    Dernier message: 20/02/2007, 14h05
  3. Peut-on utiliser une appllication .Net sous Linux ?
    Par goof_22 dans le forum Framework .NET
    Réponses: 8
    Dernier message: 18/10/2006, 12h08
  4. Créer et utiliser des fichiers excel sous linux
    Par cronos6 dans le forum Zope
    Réponses: 2
    Dernier message: 02/06/2006, 10h14
  5. [Perf]Eclipse rame sous linux, Que faire ?
    Par Zapan dans le forum Eclipse Java
    Réponses: 4
    Dernier message: 15/01/2006, 16h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo