IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

C++Builder Discussion :

Problème avec la LIB ftd2xx de FTDI


Sujet :

C++Builder

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    Janvier 2010
    Messages
    17
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : Janvier 2010
    Messages : 17
    Points : 12
    Points
    12
    Par défaut Problème avec la LIB ftd2xx de FTDI
    Bonjour à tous,

    j'ai un problème avec mon C++ Builder 10.4 Community Edition et la lib de FTDI, si quelqu'un peut m'aider, je vous explique ce que je pretend.

    Je veux connecter mon PC à un module FT232RL de FTDI pour faire un programateur de microcontroleurs, alors j'ai ajouté le fichier ftd2xx.h et la lib ftd2xx.lib dans le dossir du projet. Quand je fais le include je n'ai pas d'erreur, si j'appele un fonction pas d'erreur non plus, mais quand je fais le debug j'ai l'erreur suivante:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    [ilink64 Error] Error: Unresolved external 'FT_CreateDeviceInfoList' referenced from C:\EMBARCADERO\STUDIO\PROJECTS\UPROG\WIN64\DEBUG\UI_FORM.O
    Merci d'avance.

  2. #2
    Membre chevronné
    Avatar de DjmSoftware
    Homme Profil pro
    Responsable de compte
    Inscrit en
    Mars 2002
    Messages
    1 044
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Responsable de compte
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : Mars 2002
    Messages : 1 044
    Points : 2 187
    Points
    2 187
    Billets dans le blog
    1
    Par défaut
    Salut
    le message d'erreur du linnker indique que tu travaille en 64 bits
    les fichiers .lib sont valable uniquement en 32 bits
    tu dois utiliser l'outil embarcadero mkexp si tu est en 64bits https://docwiki.embarcadero.com/RADS...s_pour_C%2B%2B

    cordialement
    vous trouverez mes tutoriels à l'adresse suivante: http://djmsoftware.developpez.com/
    je vous en souhaite une excellente lecture ...

    A lire : Les règles du forum

  3. #3
    Membre à l'essai
    Profil pro
    Inscrit en
    Janvier 2010
    Messages
    17
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : Janvier 2010
    Messages : 17
    Points : 12
    Points
    12
    Par défaut
    Salut DjmSoftware,

    merci pour la réponse je vais essayer et je retourne vers toi.

    Merci.

  4. #4
    Membre à l'essai
    Profil pro
    Inscrit en
    Janvier 2010
    Messages
    17
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : Janvier 2010
    Messages : 17
    Points : 12
    Points
    12
    Par défaut
    Salut DjmSoftware,

    ça fonctionne, mais j'ai du mettre la dll dans le dossier win64/debug. Mais vu que j'utilise la librairie ce ne devrait pas l'inclure dans le fichier exe lors de la compilation?

    Merci.

  5. #5
    Membre chevronné
    Avatar de DjmSoftware
    Homme Profil pro
    Responsable de compte
    Inscrit en
    Mars 2002
    Messages
    1 044
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Responsable de compte
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : Mars 2002
    Messages : 1 044
    Points : 2 187
    Points
    2 187
    Billets dans le blog
    1
    Par défaut
    Salut cela signifie simplement que le chemin de cette DLL n’est pas connu.
    En principe ta DLL doit se trouver dans le même chemin que ton exécutable ou alors il te faut ajouter manuellement le chemin de cette DLL au path général.
    Pour ma part pour des raisons de maintenance (versioning et autre) je préfère que les DLL utilisées par mon application soient déposées dans le même répertoire.
    Cordialement

    .
    vous trouverez mes tutoriels à l'adresse suivante: http://djmsoftware.developpez.com/
    je vous en souhaite une excellente lecture ...

    A lire : Les règles du forum

  6. #6
    Membre à l'essai
    Profil pro
    Inscrit en
    Janvier 2010
    Messages
    17
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : Janvier 2010
    Messages : 17
    Points : 12
    Points
    12
    Par défaut
    Salut,

    merci pour ton explication, je suis un peu plus au clair.

    Meilleures salutations.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. problème avec CapGetDriverDescriptionA Lib "avicap32.dll"
    Par Mario Rousson dans le forum VB.NET
    Réponses: 0
    Dernier message: 18/12/2013, 03h11
  2. problème avec un .lib
    Par jackk dans le forum VC++ .NET
    Réponses: 9
    Dernier message: 06/12/2012, 15h37
  3. Problème avec oleacc.lib suite à l'install de TMS component
    Par petitclem dans le forum C++Builder
    Réponses: 15
    Dernier message: 26/02/2009, 01h05
  4. Problème avec la lib lti et visual studio 2005
    Par pasqual dans le forum Visual C++
    Réponses: 3
    Dernier message: 25/11/2008, 16h31
  5. [VS 2008] Problème avec Libc.lib
    Par Ange44 dans le forum Visual C++
    Réponses: 4
    Dernier message: 05/09/2008, 11h12

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo