IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Angular Discussion :

npm install ERREUR : 1 moderate severity vulnerability


Sujet :

Angular

  1. #1
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    novembre 2014
    Messages
    28
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : novembre 2014
    Messages : 28
    Points : 20
    Points
    20
    Par défaut npm install ERREUR : 1 moderate severity vulnerability
    Bonjour,

    Je souhaite apprendre angular à partir de zéro et suis un tutoriel a priori bien fait d'après les avis
    (déjà, est-ce que vous avez un tutoriel référence à me conseiller ? simple et pédago, pour apprendre de A à Z pour les débutants totaux ? Merci par avance).

    J'ai donc essayé d'installer le dernier package npm en date (ici, le 16.13.1 LTS).
    Mais quand je saisis dans la console
    npm install -g npm@latest
    , il m'apparaît :
    removed 176 packages, changed 3 packages, and audited 39 packages in 11s

    1 moderate severity vulnerability

    To address all issues, run:
    npm audit fix

    Run `npm audit` for details.


    J'ai bien essayé de lancer npm audit mais il m'apparaît alors :
    npm ERR! code ENOLOCK
    npm ERR! audit This command requires an existing lockfile.
    npm ERR! audit Try creating one first with: npm i --package-lock-only
    npm ERR! audit Original error: loadVirtual requires existing shrinkwrap file

    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\(mon nom)\AppData\Local\npm-cache\_logs\2021-12-07T14_47_53_049Z-debug-0.log

    Je ne comprends pas ce que je dois faire.
    Pouvez-vous m'aider s'il vous plaît ?

    Merci d'avance.

  2. #2
    Membre éprouvé
    Homme Profil pro
    Développeur Web
    Inscrit en
    janvier 2019
    Messages
    707
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : janvier 2019
    Messages : 707
    Points : 1 030
    Points
    1 030
    Par défaut
    npm version

    t'affiche quoi ?

    sinon tu t'en fou

    windows ?


    "ninja angular" propose un tuto complet. c payant mais tu donnes ce que tu veux...

  3. #3
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    novembre 2014
    Messages
    28
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : novembre 2014
    Messages : 28
    Points : 20
    Points
    20
    Par défaut
    Oui pardon, je suis sur windows.

    npm version me donne ça :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    {
      npm: '8.2.0',
      node: '16.13.1',
      v8: '9.4.146.24-node.14',
      uv: '1.42.0',
      zlib: '1.2.11',
      brotli: '1.0.9',
      ares: '1.18.1',
      modules: '93',
      nghttp2: '1.45.1',
      napi: '8',
      llhttp: '6.0.4',
      openssl: '1.1.1l+quic',
      cldr: '39.0',
      icu: '69.1',
      tz: '2021a',
      unicode: '13.0',
      ngtcp2: '0.1.0-DEV',
      nghttp3: '0.1.0-DEV'
    }
    Bon, a priori c'est effectivement bien installé, mais pourquoi toutes ces erreurs ?
    et comment les gérer ? (ne faut-il pas les gérer pour éviter des vulnérabilités dans son code ?)

    Merci pour ta réponse en tout cas

  4. #4
    Membre éprouvé
    Homme Profil pro
    Développeur Web
    Inscrit en
    janvier 2019
    Messages
    707
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : janvier 2019
    Messages : 707
    Points : 1 030
    Points
    1 030
    Par défaut
    je ne sais pas trop.
    faudrait que quelqu'un pirate ton pc mais bon

Discussions similaires

  1. Réponses: 2
    Dernier message: 06/04/2018, 15h06
  2. [npm] installation d'un package npm
    Par HAM_10 dans le forum Général JavaScript
    Réponses: 4
    Dernier message: 28/09/2017, 19h53
  3. npm install est instable
    Par sylvain m. dans le forum NodeJS
    Réponses: 3
    Dernier message: 26/09/2014, 09h07
  4. [Node.js / NPM] Installation de Yeoman sur windows
    Par Khrono dans le forum NodeJS
    Réponses: 0
    Dernier message: 22/08/2014, 13h53
  5. probléme d'installation de sql sever 2000 edition entreprise.
    Par MAJIK_ENIS dans le forum MS SQL Server
    Réponses: 5
    Dernier message: 11/06/2007, 11h17

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo