IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Python Discussion :

Problème encodage donnée


Sujet :

Python

  1. #1
    Nouveau Candidat au Club
    Femme Profil pro
    Enseignant
    Inscrit en
    octobre 2021
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Pyrénées Atlantiques (Aquitaine)

    Informations professionnelles :
    Activité : Enseignant
    Secteur : Enseignement

    Informations forums :
    Inscription : octobre 2021
    Messages : 1
    Points : 1
    Points
    1
    Par défaut Problème encodage donnée
    Bonjour

    Débutante en python et n'ayant pas trouvé la solution malgré mes recherches je vous soumets le problème suivant

    Je veux utiliser la fonction "encode" sur une valeur d'un dictionnaire et j'ai créé l'exemple suivant pour le présenter

    Code python : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    recherche  = {
    'cle-1': ['valeur cle 1']
    }
    val = 'valeur cle 1'
    vv = val.encode()
    print ("val bien encodé")
    key  = 'cle-1'
    x=recherche[key]
    print("x = ",x)
    ww = x.encode()

    Sur le contenu de la donnée isolée (vv) l'encode se fait bien
    Sur la donnée extraite du dictionnaire(x) "l'encode" capote par le message suivant sans doute inhérent aux []

    C:\Users\MJFG\AppData\Local\Programs\Python\Python36\python.exe C:/Users/MJFG/PycharmProjects/Python/test_dictionnaire_02.py
    x = ['valeur cle 1']
    Traceback (most recent call last):
    File "C:/Users/MJFG/PycharmProjects/Python/test_dictionnaire_02.py", line 12, in <module>
    ww = x.encode()
    AttributeError: 'list' object has no attribute 'encode'

    Process finished with exit code 1

    [Ainsi ...
    Comment puis-je "éradiquer" les [] pour avoir une chaine de caractère compatible avec mon but ?

    Je remercie par avance tous ceux qui s'intéresseront à ce problème de débutant

  2. #2
    Expert éminent sénior
    Homme Profil pro
    Architecte technique retraité
    Inscrit en
    juin 2008
    Messages
    18 651
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Architecte technique retraité
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2008
    Messages : 18 651
    Points : 32 203
    Points
    32 203
    Par défaut
    Salut,

    Ce que vous voulez encoder est le premier élément de la liste (et non la liste).

    Ouvrez votre tuto préféré aux chapitres qui parlent des listes pour (re)voir comment y accéder.... profiter des exercices corrigés qui y sont proposés (car c'est plein de pièges) et améliorer votre vocabulaire technique (la compréhension commence par savoir décrire le problème à résoudre).

    - W
    Architectures post-modernes.
    Python sur DVP c'est aussi des FAQs, des cours et tutoriels

  3. #3
    Membre expérimenté
    Inscrit en
    février 2003
    Messages
    1 267
    Détails du profil
    Informations forums :
    Inscription : février 2003
    Messages : 1 267
    Points : 1 348
    Points
    1 348
    Par défaut
    Votre code fonctionne parfaitement tel quel chez moi (Windows, Python 3.9).

  4. #4
    Expert confirmé
    Avatar de jurassic pork
    Homme Profil pro
    Bidouilleur
    Inscrit en
    décembre 2008
    Messages
    2 334
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Bidouilleur
    Secteur : Industrie

    Informations forums :
    Inscription : décembre 2008
    Messages : 2 334
    Points : 5 899
    Points
    5 899
    Par défaut
    hello,
    Arioch cela ne fonctionne pas chez moi en python 3.7 ( c'est pas moi qui ait mis le pouce vers le bas )
    Citation Envoyé par JMMM64 Voir le message

    Code python : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    recherche  = {
    'cle-1': ['valeur cle 1']
    }
    val = 'valeur cle 1'
    vv = val.encode()
    print ("val bien encodé")
    key  = 'cle-1'
    x=recherche[key]
    print("x = ",x)
    ww = x.encode()

    Sur le contenu de la donnée isolée (vv) l'encode se fait bien
    Sur la donnée extraite du dictionnaire(x) "l'encode" capote par le message suivant sans doute inhérent aux []
    pourquoi as-tu mis une liste ([]) comme valeur dans ton dictionnaire ?
    Avec ceci cela devrait mieux fonctionner :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    recherche  = {'cle-1': 'valeur cle 1'}
    Ami calmant, J.P
    Jurassic computer : Sinclair ZX81 - Zilog Z80A à 3,25 MHz - RAM 1 Ko - ROM 8 Ko

  5. #5
    Expert éminent sénior
    Avatar de Sve@r
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    février 2006
    Messages
    9 632
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Oise (Picardie)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2006
    Messages : 9 632
    Points : 26 318
    Points
    26 318
    Billets dans le blog
    1
    Par défaut
    Bonjour
    Citation Envoyé par jurassic pork Voir le message
    ( c'est pas moi qui ait mis le pouce vers le bas )
    Pas moi non plus mais en effet ça mérite. Hier je suis venu, ai survolé en digaonale et voyant que Arioch avait validé je n'ai pas insisté.
    Aujourd'hui je vois une nouvelle réponse, je reviens et je vois que ça ne fonctionne pas donc là je regarde avec plus d'attention et en effet je ne comprends pas comment Arioch peut dire que ça fonctionne chez-lui. "x" étant une liste (on peut mieux le voir si on écrit à la ligne 9 print(x, type(x))), et une liste ne possédant pas de méthode encode(), cela ne peut pas fonctionner
    Et c'est moi qui te mets le pouce vers le haut pour avoir mieux regardé que ce que je ne l'ai fait hier

    Citation Envoyé par JMMM64 Voir le message
    Comment puis-je "éradiquer" les [] pour avoir une chaine de caractère compatible avec mon but ?
    Ben... c'est un petit peu toi qui les as mis ces []. Si tu ne les veux pas à l'arrivée, et s'ils ne servent pas entre temps, autant ne pas les mettre au départ...
    Mon Tutoriel sur la programmation «Shell»
    Sinon il y en a pleins d'autres. N'oubliez pas non plus les différentes faq disponibles sur ce site

  6. #6
    Membre confirmé Avatar de Hominidé
    Homme Profil pro
    Paysan à 3 francs six sous
    Inscrit en
    juin 2018
    Messages
    351
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pyrénées Orientales (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Paysan à 3 francs six sous

    Informations forums :
    Inscription : juin 2018
    Messages : 351
    Points : 509
    Points
    509
    Par défaut
    Bonjour,
    Citation Envoyé par Sve@r Voir le message

    Pas moi non plus mais en effet ça mérite
    J'avoue, c'est moi
    J'aurais dû probablement ajouter un commentaire, mais bon j'ai estimé qu'avec l'exception rencontrée et la réponse de @wiztricks, il n'y avait rien à ajouter...

  7. #7
    Membre expérimenté
    Inscrit en
    février 2003
    Messages
    1 267
    Détails du profil
    Informations forums :
    Inscription : février 2003
    Messages : 1 267
    Points : 1 348
    Points
    1 348
    Par défaut
    Bah, pas de ma faute si, en reprenant le code initial tel quel et en l'exécutant, ça fonctionne chez moi.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    Christophe@DESKTOP-QASEGFE MINGW64 ~/Downloads
    $ cat t.py
    recherche  = {
    'cle-1': ['valeur cle 1']
    }
    val = 'valeur cle 1'
    vv = val.encode()
    print ("val bien encodé")
    key  = 'cle-1'
    x=recherche[key]
    print("x = ",x)
    Christophe@DESKTOP-QASEGFE MINGW64 ~/Downloads
    $ python t.py
    val bien encode
    x =  ['valeur cle 1']
     
    Christophe@DESKTOP-QASEGFE MINGW64 ~/Downloads
    $

  8. #8
    Expert éminent sénior
    Homme Profil pro
    Architecte technique retraité
    Inscrit en
    juin 2008
    Messages
    18 651
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Architecte technique retraité
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2008
    Messages : 18 651
    Points : 32 203
    Points
    32 203
    Par défaut
    Citation Envoyé par Arioch Voir le message
    Bah, pas de ma faute si, en reprenant le code initial tel quel et en l'exécutant, ça fonctionne chez moi.
    Certes mais vous avez oublié de recopier la dernière ligne!
    Un peu de "rigueur", vous aurait permis de le remarquer en regardant la trace qui a été posté (pourquoi l'instruction qui plante n'est pas là?).

    Mais c'est pas grave, se tromper, ça arrive.

    - W
    Architectures post-modernes.
    Python sur DVP c'est aussi des FAQs, des cours et tutoriels

  9. #9
    Membre expérimenté
    Inscrit en
    février 2003
    Messages
    1 267
    Détails du profil
    Informations forums :
    Inscription : février 2003
    Messages : 1 267
    Points : 1 348
    Points
    1 348
    Par défaut
    Oups, toutes mes excuses !

Discussions similaires

  1. Réponses: 1
    Dernier message: 22/05/2016, 15h46
  2. Réponses: 3
    Dernier message: 12/11/2007, 15h55
  3. Problème encodage des données POST lues
    Par cheprod dans le forum Apache
    Réponses: 2
    Dernier message: 12/11/2007, 10h59
  4. [débutant] problème affichage données table ds TDBGrid
    Par lidouka dans le forum Composants VCL
    Réponses: 1
    Dernier message: 16/12/2005, 14h50
  5. problème ajout données avec db.execute et access
    Par Dauphind dans le forum Access
    Réponses: 2
    Dernier message: 29/11/2005, 13h03

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo