Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Visual Studio Discussion :

Déploiement d'une application c#


Sujet :

Visual Studio

  1. #1
    Membre à l'essai
    Déploiement d'une application c#
    Bonjour,

    Je vous sollicite car je me trouve face à un souci de déploiement encore jamais rencontré...
    J'ai développé une petite application c# Windows sous Visual Studio 2015. Elle ouvre un port série et affiche les données...

    Lorsque j’exécute l'application sur mes 2 PC de développement (avec VS2015 installé) tout est OK.

    Par contre si je l’exécute sur d'autres PC (sans VS2015), l'application se lance normalement puis reste figée... Mais sans jamais affiché le message (cette application ne répond pas).
    Les frameworks .Net sont a jour sur ces PC.
    La conso processeur de l'application est a 0%.
    Si je fais un clique droit dans la barre des taches je peux fermer l’application instantanément, par contre la croix en haut de la form ne fait rien !
    Aucune exception n'est levée.
    J'ai tenté de publier l'application: même résultat.

    La difficulté est que je me retrouve devant une application qui ne réagit pas mais qui ne plante pas et qui ne génère aucun message d'erreur...
    Des idées ?

    Merci
    Gaétan

  2. #2
    Expert éminent sénior
    le port a le même nom sur ce pc que sur les autres ?
    la gestion du port série est-elle bien déportée sur un thread séparée pour ne pas figer en cas de non dialogue ?
    Cours complets, tutos et autres FAQ ici : C# - VB.NET

  3. #3
    Membre à l'essai
    Je viens de trouver...
    Les PC sur lesquels le soft est lent, dispose de Bluetooth en natif.
    J'utilise les fonction WMI pour détecter la présence de ma carte en USB:
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    ManObjSearch = new ManagementObjectSearcher("Select * from Win32_SerialPort");


    Le traitement de cette fonction met 11 ms sur mes machines sans BlueTooth alors qu'elle met plus de 5 secondes sur les machines équipées de Bluetooth !!!

    J'ai modifié mon code afin de ne faire qu'un contrôle au démarrage de l'application au lieu d'un contrôle permanent toutes les secondes.

    Gaétan