Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Documents Java Discussion :

lignes et colonnes de tableau Java


Sujet :

Documents Java

  1. #21
    Modérateur

    Citation Envoyé par Dali29 Voir le message

    je travaille en Java 2 Edition 1.4 (J2SE)
    Pourquoi travailler avec une si ancienne version (et j'espère que c'est au moins la 1.4.2) ?
    [EDIT]Je viens de regarder la JavaDoc 1.4.2 et les attributs DISPLAY et WHITE_SPACE existent dans javax.swing.text.html.CSS.Attribute.
    L'expression "ça marche pas" ne veut rien dire. Indiquez l'erreur, et/ou les comportements attendus et obtenus, et donnez un Exemple Complet Minimal qui permet de reproduire le problème.
    La plupart des réponses à vos questions sont déjà dans les FAQs ou les Tutoriels, ou peut-être dans une autre discussion : utilisez la recherche interne.
    Des questions sur Java : consultez le Forum Java. Des questions sur l'EDI Eclipse ou la plateforme Eclipse RCP : consultez le Forum Eclipse.
    Une question correctement posée et rédigée et vous aurez plus de chances de réponses adaptées et rapides.
    N'oubliez pas de mettre vos extraits de code entre balises CODE (Voir Mode d'emploi de l'éditeur de messages).
    Nouveau sur le forum ? Consultez Les Règles du Club.

  2. #22
    Candidat au Club
    Citation Envoyé par joel.drigo Voir le message
    Pourquoi travailler avec une si ancienne version (et j'espère que c'est au moins la 1.4.2) ?
    [EDIT]Je viens de regarder la JavaDoc 1.4.2 et les attributs DISPLAY et WHITE_SPACE existent dans javax.swing.text.html.CSS.Attribute.
    Par ce que je travaille sur un logiciel Open Source et je suis entrain de le modifier.

  3. #23
    Modérateur

    1. si tu contribues à un projet Open Source, il serait temps que quelqu'un décide de passer à une version de Java plus récente, vu que la 1.4 date de 16 ans, et n'est plus supportée publiquement depuis 2008 (en payant c'est 2013, mais je doute que pour un projet Open Source, quelqu'un paye un support). Il y a de potentiels soucis de sécurité avec la 1.4.
    2. si tu modifies le projet de ton côté, nonobstant toute la problématique liée au droit de le faire ou pas, tu peux assez facilement passer à une version plus récente de Java. Il y aura peut-être deux ou trois soucis de compilation, qui devront se corriger assez rapidement, et il y aura un problème en particulier avec toutes les bibliothèques relatives à Xalan (qui ont changé de package entre la 1.4 et Java 5) : il suffit de juste ajouter au classpath les bibliothèques de Xalan chargées à part (ou se taper toute la translation de packages).
    L'expression "ça marche pas" ne veut rien dire. Indiquez l'erreur, et/ou les comportements attendus et obtenus, et donnez un Exemple Complet Minimal qui permet de reproduire le problème.
    La plupart des réponses à vos questions sont déjà dans les FAQs ou les Tutoriels, ou peut-être dans une autre discussion : utilisez la recherche interne.
    Des questions sur Java : consultez le Forum Java. Des questions sur l'EDI Eclipse ou la plateforme Eclipse RCP : consultez le Forum Eclipse.
    Une question correctement posée et rédigée et vous aurez plus de chances de réponses adaptées et rapides.
    N'oubliez pas de mettre vos extraits de code entre balises CODE (Voir Mode d'emploi de l'éditeur de messages).
    Nouveau sur le forum ? Consultez Les Règles du Club.

###raw>template_hook.ano_emploi###