1. #1
    Membre averti
    Homme Profil pro
    Étudiant
    Inscrit en
    août 2011
    Messages
    689
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 24
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : août 2011
    Messages : 689
    Points : 349
    Points
    349

    Par défaut Problème d'installation avec eclipse

    Bonsoir,

    je suis en train d'installer mon nouveau linux et j'ai un soucis avec eclipse, peut-être pourrez vous m'aider ?


    Lorsque je tente de lancer l'application eclipse provenant de eclipse-java-photon-M4-linux-gtk-x86_64.tar.gz j'obtiens le message d'erreur suivant

    JVM terminated. Exit code=1
    /usr/bin/java
    -Dosgi.requiredJavaVersion=1.8
    -Dosgi.instance.area.default=@user.home/eclipse-workspace
    -XX:+UseG1GC
    -XX:+UseStringDeduplication
    --add-modules=ALL-SYSTEM
    -Dosgi.requiredJavaVersion=1.8
    -Dosgi.dataAreaRequiresExplicitInit=true
    -Xms256m
    -Xmx1024m
    --add-modules=ALL-SYSTEM
    -jar /home/minirock/Téléchargements/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
    -os linux
    -ws gtk
    -arch x86_64
    -showsplash /home/minirock/Téléchargements/eclipse//plugins/org.eclipse.epp.package.common_4.8.0.20171204-0932/splash.bmp
    -launcher /home/minirock/Téléchargements/eclipse/eclipse
    -name Eclipse
    --launcher.library /home/minirock/Téléchargements/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.600.v20170921-0935/eclipse_1627.so
    -startup /home/minirock/Téléchargements/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
    --launcher.appendVmargs
    -exitdata 24e0018
    -product org.eclipse.epp.package.java.product
    -vm /usr/bin/java
    -vmargs
    -Dosgi.requiredJavaVersion=1.8
    -Dosgi.instance.area.default=@user.home/eclipse-workspace
    -XX:+UseG1GC
    -XX:+UseStringDeduplication
    --add-modules=ALL-SYSTEM
    -Dosgi.requiredJavaVersion=1.8
    -Dosgi.dataAreaRequiresExplicitInit=true
    -Xms256m
    -Xmx1024m
    --add-modules=ALL-SYSTEM
    -jar /home/minirock/Téléchargements/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
    D'après ce qu'il me dit,il a besoin de la version 1.8 de java ceci étant dit mon java est installé donc normalement ça devrait être ok il me semble

    java -version me retourne

    openjdk version "9-internal"
    OpenJDK Runtime Environment (build 9-internal+0-2016-04-14-195246.buildd.src)
    OpenJDK 64-Bit Server VM (build 9-internal+0-2016-04-14-195246.buildd.src, mixed mode)
    Merci pour votre aide

  2. #2
    Membre émérite
    Avatar de Mickael_Istria
    Homme Profil pro
    Développeur Expert Eclipse IDE/RCP, pour Red Hat
    Inscrit en
    juillet 2008
    Messages
    1 178
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Expert Eclipse IDE/RCP, pour Red Hat
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2008
    Messages : 1 178
    Points : 2 495
    Points
    2 495

    Par défaut

    Le build de OpenJDK que tu utilises est marque "internal", ce qui peut signifier qu'il est encore en developpement et peut avoir des bugs. Il y a moyen que tu essayes avec une autre version de Java?
    Tu fais du JEE/Web/Mobile dans Eclipse IDE? Essaye JBoss Tools !
    Follow me on twitter

  3. #3
    Membre averti
    Homme Profil pro
    Étudiant
    Inscrit en
    août 2011
    Messages
    689
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 24
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : août 2011
    Messages : 689
    Points : 349
    Points
    349

    Par défaut

    Salut,

    merci de la réponse, effectivement en passant sous le jre 8 mon eclipse se lance bien désormais.

    Mais c'est bizarre je pensais que java 9 était déjà disponible.
    A moins que cela vienne du fait que les librairies java oracle ne sont pas les mêmes que celle sur un linux. Je ne sais pas, enfin bref tout est ok maintenant.

    l existe 2 choix pour l'alternative java (qui fournit /usr/bin/java).

    Sélection Chemin Priorité État
    ------------------------------------------------------------
    * 0 /usr/lib/jvm/java-9-openjdk-amd64/bin/java 1091 mode automatique
    1 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java 1081 mode manuel
    2 /usr/lib/jvm/java-9-openjdk-amd64/bin/java 1091 mode m
    A noter que j'ai tenté avec le 2 aussi et que ça ne marchait pas non plus, seul le 8 a fonctionné.

    Peut-être tout simplement que la version d'éclipse que j'ai prise demande spécifiquement la version 8 (comme indiqué dans le message d'erreur d'ailleurs).

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Problème d'installation avec Eclipse Neon
    Par momo310795 dans le forum Eclipse
    Réponses: 2
    Dernier message: 26/01/2017, 20h57
  2. problème d'installation avec eclipse
    Par kphp dans le forum Eclipse Java
    Réponses: 2
    Dernier message: 28/01/2007, 23h46
  3. problème d'installation+my eclipse
    Par mjihanne dans le forum Eclipse Java
    Réponses: 2
    Dernier message: 28/08/2006, 03h58
  4. [Tomcat]Problème fonctionnement Tomcat avec Eclipse
    Par ditique dans le forum Eclipse Java
    Réponses: 4
    Dernier message: 26/01/2006, 15h23
  5. install avec Eclipse / mySQL
    Par gdauvergne dans le forum XMLRAD
    Réponses: 1
    Dernier message: 15/02/2005, 12h25

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo