Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Java Discussion :

[FXML] Problème Root Element


Sujet :

Eclipse Java

  1. #1
    Membre averti
    [FXML] Problème Root Element
    Bonjour,

    J'ai un problème sous Eclipse, lorsque je veux créer un nouveau fichier FXML l'element "Root Element" reste grisé, il ne se passe rien quand je clique sur "browser"....
    Et il y a marqué en haut "Select a root element" donc je ne peux pas créer de fichier FXML comme je le voudrais ...

    Quelqu'un saurait-il m'indiquer d'où peut venir le problème ?

    Merci d'avance pour votre aide.

  2. #2
    Modérateur

    Salut,

    Personnellement, je ne constate pas ce problème. Quelle version d'Eclipse utilises-tu ? As-tu installé E(fx)clipse ?
    L'expression "ça marche pas" ne veut rien dire. Indiquez l'erreur, et/ou les comportements attendus et obtenus, et donnez un Exemple Complet Minimal qui permet de reproduire le problème.
    La plupart des réponses à vos questions sont déjà dans les FAQs ou les Tutoriels, ou peut-être dans une autre discussion : utilisez la recherche interne.
    Des questions sur Java : consultez le Forum Java. Des questions sur l'EDI Eclipse ou la plateforme Eclipse RCP : consultez le Forum Eclipse.
    Une question correctement posée et rédigée et vous aurez plus de chances de réponses adaptées et rapides.
    N'oubliez pas de mettre vos extraits de code entre balises CODE (Voir Mode d'emploi de l'éditeur de messages).
    Nouveau sur le forum ? Consultez Les Règles du Club.

  3. #3
    Membre averti
    Salut merci de ta réponse.
    oui j'ai bien installlé E(fx)clipse...
    J'ai la Version: Mars.1 (4.5.1)

  4. #4
    Membre du Club
    Désolé de déterrer cette discussion mais je vois qu'elle est notée résolue alors qu'aucune réponse n'a été donnée.

    Je rencontre exactement le même problème.
    Ma version d'eclipse est la 2019-09, le jdk est le 13 et e(fx)clipse est installé (via http://download.eclipse.org/releases/oxygen dans le menu help -> Install new software)

    J'ai parcouru le net et je vois que je ne suis pas le seul dans cette situation mais il n'y a pas vraiment de réponse...

  5. #5
    Modérateur

    Salut,

    Vérifie que les jars de JavaFX sont bien dans le build path de ton projet (en particulier jfxrt.jar).
    L'expression "ça marche pas" ne veut rien dire. Indiquez l'erreur, et/ou les comportements attendus et obtenus, et donnez un Exemple Complet Minimal qui permet de reproduire le problème.
    La plupart des réponses à vos questions sont déjà dans les FAQs ou les Tutoriels, ou peut-être dans une autre discussion : utilisez la recherche interne.
    Des questions sur Java : consultez le Forum Java. Des questions sur l'EDI Eclipse ou la plateforme Eclipse RCP : consultez le Forum Eclipse.
    Une question correctement posée et rédigée et vous aurez plus de chances de réponses adaptées et rapides.
    N'oubliez pas de mettre vos extraits de code entre balises CODE (Voir Mode d'emploi de l'éditeur de messages).
    Nouveau sur le forum ? Consultez Les Règles du Club.

  6. #6
    Candidat au Club
    Bonjour

    Je déterre à mon tour car je n'arrive pas à résoudre ce problème et je ne trouve de réponse nulle part.
    Ma version d'eclipse est la 4.15.0. J'ai installé le JDK 11, SceneBuilder pour Java 11, e(fx)clipse, mis le compiler sur la version 11 comme ça je me suis dis que je n'aurais aucun problème de compatibilité. En venant ici, j'ai vu qu'il fallait que je vérifie que les jars de JavaFx soient dans le build path de mon projet.
    Voici ce que j'ai :



    J'ai cherché dans mon ordinateur et impossible de trouver le jfxrt.jar par exemple. Mais je n'arrive pas à comprendre ce que j'ai oublié pour ne pas l'avoir.

    Merci d'avance pour votre aide

###raw>template_hook.ano_emploi###