IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI Delphi Discussion :

[Delphi 10] Bug aléatoire dans l'IDE : "Index ImageList non valide"


Sujet :

EDI Delphi

  1. #1
    Expert éminent
    Avatar de Lung
    Profil pro
    Analyste-programmeur
    Inscrit en
    mai 2002
    Messages
    2 614
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste-programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 2 614
    Points : 6 147
    Points
    6 147
    Par défaut [Delphi 10] Bug aléatoire dans l'IDE : "Index ImageList non valide"
    Dans Delphi 10, j'ai parfois un message d'erreur qui survient aléatoirement.

    Nom : Erreur D10.png
Affichages : 316
Taille : 5,1 Ko

    Quand le problème a décidé d'apparaître, la fenêtre s'affiche après chaque action de modification en conception (ce qui est très pénible ! ).
    Par exemple : quand je modifie une valeur dans l'inspecteur d'objet (peu importe le composant), ou que je déplace ou redimensionne un composant dans une fenêtre.

    Après un certain temps, le message d'erreur n'apparaît plus. Et puis, il ré-apparaîtra de nouveau plus tard.

    Ce message d'erreur apparait dans n'importe quel projet, et je n'ai pas de TImageList dans ces projets.
    Même un tout nouveau projet peut faire apparaître ce message (donc pas encore de bibliothèques autres que celles par défaut).

    Quelqu'un aurait-il déjà rencontré ce problème ?
    Et si oui, comment s'en débarrasser, ou le contourner ?

    L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai. Écrivez dans un français correct !!

    Delphi 6#2 Entreprise - Delphi 2007 Entreprise - Delphi 2010 Architecte - Delphi XE Entreprise - Delphi XE7 Entreprise - Delphi 10 Entreprise - Delphi 10.3.2 Entreprise
    OpenGL 2.1 - Oracle 10g - Interbase (7 - XE) - PostgreSQL 11.6

  2. #2
    Expert éminent sénior
    Avatar de Paul TOTH
    Homme Profil pro
    Freelance
    Inscrit en
    novembre 2002
    Messages
    8 108
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 51
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Freelance
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2002
    Messages : 8 108
    Points : 26 262
    Points
    26 262
    Par défaut
    Bonjour,

    je n'ai jamais vu cette erreur...as-tu installé des outils tiers dans l'IDE ?
    Developpez.com: Mes articles, forum FlashPascal
    Entreprise: Execute SARL
    Le Store Excute Store

  3. #3
    Expert éminent sénior
    Avatar de ShaiLeTroll
    Homme Profil pro
    Développeur C++\Delphi
    Inscrit en
    juillet 2006
    Messages
    12 063
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Seine Saint Denis (Île de France)

    Informations professionnelles :
    Activité : Développeur C++\Delphi
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : juillet 2006
    Messages : 12 063
    Points : 21 208
    Points
    21 208
    Par défaut
    Je n'ai pas eu exactement ce message mais plutôt 'Index hors limite" en XE2, c'est rarissime lors du changement d'onglet d'une unité à une autre.

    Clique sur Détails, tu auras la pile d'appel, cela peut même te donner le nom de l'élément Delphi qui plante, genre ObjectInspector (TInspListBox), CodeEditor ...

    Comme l'IDE Delphi est écrit en Delphi, on trouve clairement SImageIndexError dans le code de la TImageList
    Cela ne vient pas de ton projet mais soit de Delphi lui-même, soit d'un outils comme le mentionne Paul TOTH, et peut-être d'un BPL avec un composant tiers gérant mal le DesignTime

    Dans l'IDE Delphi, on trouve des TImageList partout comme l'icone des onglets (TTabSet, TGradientTabSet, TIDEGradientTabSet), c'est une TImageList,
    Cela concerne aussi bien les onglets des units que ceux de groupements de panneau (TTabDockHostForm) tel que Inspecteur (TProperyInspector), Gestionnaire Projet (TProjetManagerForm), Structure (TStructureViewForm), ...
    Aide via F1 - FAQ - Guide du développeur Delphi devant un problème - Pensez-y !
    Attention Troll Méchant !
    "Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson" Confucius
    Mieux vaut se taire et paraître idiot, Que l'ouvrir et de le confirmer !
    L'ignorance n'excuse pas la médiocrité !

    L'expérience, c'est le nom que chacun donne à ses erreurs. (Oscar Wilde)
    Il faut avoir le courage de se tromper et d'apprendre de ses erreurs

  4. #4
    Expert éminent
    Avatar de Lung
    Profil pro
    Analyste-programmeur
    Inscrit en
    mai 2002
    Messages
    2 614
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste-programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 2 614
    Points : 6 147
    Points
    6 147
    Par défaut
    Citation Envoyé par Paul TOTH Voir le message
    je n'ai jamais vu cette erreur...as-tu installé des outils tiers dans l'IDE ?
    Seulement GExpert.

    Citation Envoyé par ShaiLeTroll Voir le message
    Clique sur Détails, tu auras la pile d'appel, cela peut même te donner le nom de l'élément Delphi qui plante, genre ObjectInspector (TInspListBox), CodeEditor ...
    Je n'y ai même pas pensé.
    Dès que ça se reproduit, je jette un oeil et je vous tiens au courant ...

    L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai. Écrivez dans un français correct !!

    Delphi 6#2 Entreprise - Delphi 2007 Entreprise - Delphi 2010 Architecte - Delphi XE Entreprise - Delphi XE7 Entreprise - Delphi 10 Entreprise - Delphi 10.3.2 Entreprise
    OpenGL 2.1 - Oracle 10g - Interbase (7 - XE) - PostgreSQL 11.6

  5. #5
    Expert éminent
    Avatar de Lung
    Profil pro
    Analyste-programmeur
    Inscrit en
    mai 2002
    Messages
    2 614
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste-programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 2 614
    Points : 6 147
    Points
    6 147
    Par défaut
    Voici le contenu du détail :
    [50AB8A48]{vcl230.bpl } Vcl.ImgList.TCustomImageList.Delete (Line 664, "Vcl.ImgList.pas" + 2) + $1C
    [0E93EDEC]{MultidevicePreview230.bpl} DesignPreviewFrm.TfrmDesignPreview.UpdateThumb (Line 751, "DesignPreviewFrm.pas" + 50) + $8
    [0E93E9F7]{MultidevicePreview230.bpl} DesignPreviewFrm.TfrmDesignPreview.TickTackTimer (Line 660, "DesignPreviewFrm.pas" + 27) + $7
    [50A4DFF3]{vcl230.bpl } Vcl.ExtCtrls.TTimer.Timer (Line 3096, "Vcl.ExtCtrls.pas" + 1) + $E
    [50A4DED7]{vcl230.bpl } Vcl.ExtCtrls.TTimer.WndProc (Line 3054, "Vcl.ExtCtrls.pas" + 4) + $7
    [5017252C]{rtl230.bpl } System.Classes.StdWndProc (Line 16881, "System.Classes.pas" + 8) + $0
    [50ADCEBB]{vcl230.bpl } Vcl.Forms.TApplication.ProcessMessage (Line 10438, "Vcl.Forms.pas" + 23) + $1
    [50ADCEFE]{vcl230.bpl } Vcl.Forms.TApplication.HandleMessage (Line 10468, "Vcl.Forms.pas" + 1) + $4
    [50ADD231]{vcl230.bpl } Vcl.Forms.TApplication.Run (Line 10606, "Vcl.Forms.pas" + 26) + $3
    On voit des paquets de la VCL / RTL, et MultidevicePreview230.
    Ça ne m'inspire pas grand chose ...
    L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai. Écrivez dans un français correct !!

    Delphi 6#2 Entreprise - Delphi 2007 Entreprise - Delphi 2010 Architecte - Delphi XE Entreprise - Delphi XE7 Entreprise - Delphi 10 Entreprise - Delphi 10.3.2 Entreprise
    OpenGL 2.1 - Oracle 10g - Interbase (7 - XE) - PostgreSQL 11.6

  6. #6
    Membre expérimenté Avatar de guillemouze
    Profil pro
    Inscrit en
    novembre 2004
    Messages
    876
    Détails du profil
    Informations personnelles :
    Âge : 38
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations forums :
    Inscription : novembre 2004
    Messages : 876
    Points : 1 448
    Points
    1 448
    Par défaut
    a priori c'est la fenetre de prévisualisation multi device qui deconne (Multi-Device_Preview) !
    Sur un forum russe, ils disent que passer en classique undocked semble retirer le problème.
    Regarde peut-être dans ta liste des fenêtres si elle n'est pas ouverte, tu pourrai la fermer si tu n'en as pas besoin (je n'ai pas D10, mais en D7 dans le menu fenêtre tu as toutes les fenetres ouvertes).
    Tu devrais plutôt ouvrir un ticket sur l'EDN, car ca ressemble à un bug de l'IDE.

  7. #7
    Expert éminent sénior
    Avatar de ShaiLeTroll
    Homme Profil pro
    Développeur C++\Delphi
    Inscrit en
    juillet 2006
    Messages
    12 063
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Seine Saint Denis (Île de France)

    Informations professionnelles :
    Activité : Développeur C++\Delphi
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : juillet 2006
    Messages : 12 063
    Points : 21 208
    Points
    21 208
    Par défaut
    Citation Envoyé par guillemouze Voir le message
    a priori c'est la fenetre de prévisualisation multi device qui deconne (Multi-Device_Preview) !
    C'est vraiment pourri si l'EDI fait appel à la gestion Multi-Device pour un projet VCL ne fonctionnant que sur Windows !
    C'est un Bug ou même une manque d'optimisation de l'IDE en mode VCL

    Perso, je suis en mode Classique Flottant (le mode Classique Delphi 7) avec le concepteur non incorporé, FMX d'ailleurs ne supporte pas le mode non incorporé
    C'est surement un problème lié ! au lieu de faire en sorte que cela soit stable en mode non incorporé , ils ont fait l'autruche et retirer l'option (que l'on peut modifier en BDR)
    Aide via F1 - FAQ - Guide du développeur Delphi devant un problème - Pensez-y !
    Attention Troll Méchant !
    "Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson" Confucius
    Mieux vaut se taire et paraître idiot, Que l'ouvrir et de le confirmer !
    L'ignorance n'excuse pas la médiocrité !

    L'expérience, c'est le nom que chacun donne à ses erreurs. (Oscar Wilde)
    Il faut avoir le courage de se tromper et d'apprendre de ses erreurs

  8. #8
    Expert éminent
    Avatar de Lung
    Profil pro
    Analyste-programmeur
    Inscrit en
    mai 2002
    Messages
    2 614
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste-programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 2 614
    Points : 6 147
    Points
    6 147
    Par défaut
    Citation Envoyé par guillemouze Voir le message
    a priori c'est la fenetre de prévisualisation multi device qui deconne (Multi-Device_Preview) !
    Sur un forum russe, ils disent que passer en classique undocked semble retirer le problème.
    J'ai sélectionné "Classique flottante" pour tester.
    Je vais voir ce que ça donne ...

    Citation Envoyé par guillemouze Voir le message
    Regarde peut-être dans ta liste des fenêtres si elle n'est pas ouverte, tu pourrai la fermer si tu n'en as pas besoin (je n'ai pas D10, mais en D7 dans le menu fenêtre tu as toutes les fenetres ouvertes).
    La liste est vide.

    Citation Envoyé par guillemouze Voir le message
    Tu devrais plutôt ouvrir un ticket sur l'EDN, car ca ressemble à un bug de l'IDE.
    J'ai déjà remonté le problème à Thierry Laborde.

    Citation Envoyé par ShaiLeTroll Voir le message
    C'est vraiment pourri si l'EDI fait appel à la gestion Multi-Device pour un projet VCL ne fonctionnant que sur Windows !
    Sous D10, je n'ai que des projets en FMX.
    L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai. Écrivez dans un français correct !!

    Delphi 6#2 Entreprise - Delphi 2007 Entreprise - Delphi 2010 Architecte - Delphi XE Entreprise - Delphi XE7 Entreprise - Delphi 10 Entreprise - Delphi 10.3.2 Entreprise
    OpenGL 2.1 - Oracle 10g - Interbase (7 - XE) - PostgreSQL 11.6

  9. #9
    Expert éminent
    Avatar de Lung
    Profil pro
    Analyste-programmeur
    Inscrit en
    mai 2002
    Messages
    2 614
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste-programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 2 614
    Points : 6 147
    Points
    6 147
    Par défaut
    Pour l'instant, le message d'erreur n'est pas revenu.

    Par contre, j'ai remarqué qu'en mode "Classique flottante" Delphi était dédoublé dans la barre windows :

    Nom : D10.png
Affichages : 202
Taille : 9,8 Ko

    En plus d'être assez instable, il est quand même pas mal bugué !
    L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai. Écrivez dans un français correct !!

    Delphi 6#2 Entreprise - Delphi 2007 Entreprise - Delphi 2010 Architecte - Delphi XE Entreprise - Delphi XE7 Entreprise - Delphi 10 Entreprise - Delphi 10.3.2 Entreprise
    OpenGL 2.1 - Oracle 10g - Interbase (7 - XE) - PostgreSQL 11.6

  10. #10
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    12 893
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 65
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 12 893
    Points : 34 850
    Points
    34 850
    Billets dans le blog
    54
    Par défaut
    Bonjour,

    instable : oui donc bogué, moi j'ai souvent une erreur en clôture (a propos de la RTL)
    par contre je viens de revérifier (W10 64) le mode Classique Flottant et je n'ai pas ce dédoublage

    pour le multi device preview, ne serait-ce pas parce que un/le projet a plusieurs vues et que certains devices ont été désinstallé ou/et que l’aperçu multi-périphérique a un problème ?
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  11. #11
    Expert éminent
    Avatar de Lung
    Profil pro
    Analyste-programmeur
    Inscrit en
    mai 2002
    Messages
    2 614
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste-programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 2 614
    Points : 6 147
    Points
    6 147
    Par défaut
    Citation Envoyé par SergioMaster Voir le message
    pour le multi device preview, ne serait-ce pas parce que un/le projet a plusieurs vues et que certains devices ont été désinstallé ou/et que l’aperçu multi-périphérique a un problème ?
    Je fais du FMX, mais que pour windows.
    Donc, je n'ai pas installé ou désinstallé quoi que ce soit depuis l'install de Delphi. Mais j'ai peut-être mal fait l'install ... (même si je ne vois pas comment) ?
    L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai. Écrivez dans un français correct !!

    Delphi 6#2 Entreprise - Delphi 2007 Entreprise - Delphi 2010 Architecte - Delphi XE Entreprise - Delphi XE7 Entreprise - Delphi 10 Entreprise - Delphi 10.3.2 Entreprise
    OpenGL 2.1 - Oracle 10g - Interbase (7 - XE) - PostgreSQL 11.6

  12. #12
    Membre expérimenté Avatar de guillemouze
    Profil pro
    Inscrit en
    novembre 2004
    Messages
    876
    Détails du profil
    Informations personnelles :
    Âge : 38
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations forums :
    Inscription : novembre 2004
    Messages : 876
    Points : 1 448
    Points
    1 448
    Par défaut
    A une époque, j'avais eu tout un paquet de plantages suite à l'enregistrement de l'espace de travail sur D7 (la combo avec "<aucun>"), j'ai supprimé un fichier a cote de l'exe (delphi32.dro il me semble), et tout était revenu à la normal.
    Peut-être qu'il créé la fenêtre en masqué dans ton espace de travail, et donc le supprimer corrigerait le problème

  13. #13
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    12 893
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 65
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 12 893
    Points : 34 850
    Points
    34 850
    Billets dans le blog
    54
    Par défaut
    Citation Envoyé par Lung Voir le message
    Je fais du FMX, mais que pour windows.
    Donc, je n'ai pas installé ou désinstallé quoi que ce soit depuis l'install de Delphi. Mais j'ai peut-être mal fait l'install ...
    moi aussi, mais j'ai quand même installé le SDK Androïd ce que tu n'as peut être pas fait
    décoche dans l’aperçu multi-périphérique tout ce qui pourrait être coché, regarde dans les sources du projet s'il n'y a pas des
    {$R ....fmx} autre que {$R *.fmx}
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  14. #14
    Expert éminent
    Avatar de Lung
    Profil pro
    Analyste-programmeur
    Inscrit en
    mai 2002
    Messages
    2 614
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste-programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2002
    Messages : 2 614
    Points : 6 147
    Points
    6 147
    Par défaut
    Citation Envoyé par guillemouze Voir le message
    , j'ai supprimé un fichier a cote de l'exe (delphi32.dro il me semble), et tout était revenu à la normal.
    Je n'ai pas trouvé de fichier *.dro

    Citation Envoyé par SergioMaster Voir le message
    moi aussi, mais j'ai quand même installé le SDK Androïd ce que tu n'as peut être pas fait
    Aucun souvenir ...

    Citation Envoyé par SergioMaster Voir le message
    décoche dans l’aperçu multi-périphérique tout ce qui pourrait être coché
    Je ne connaissais pas cet onglet (première fois que je le vois).
    Impossible de décocher les deux éléments cochés. J'ai l'erreur dès que je déroule la liste.
    Pas de doute : son problème vient bien de là.
    J'ai fermé cet onglet, et l'erreur semble disparaitre avec. Je vais voir si ça dure ...

    Citation Envoyé par SergioMaster Voir le message
    regarde dans les sources du projet s'il n'y a pas des {$R ....fmx} autre que {$R *.fmx}
    Il n'y en a pas.
    L'urgent est fait, l'impossible est en cours, pour les miracles prévoir un délai. Écrivez dans un français correct !!

    Delphi 6#2 Entreprise - Delphi 2007 Entreprise - Delphi 2010 Architecte - Delphi XE Entreprise - Delphi XE7 Entreprise - Delphi 10 Entreprise - Delphi 10.3.2 Entreprise
    OpenGL 2.1 - Oracle 10g - Interbase (7 - XE) - PostgreSQL 11.6

  15. #15
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    12 893
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 65
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 12 893
    Points : 34 850
    Points
    34 850
    Billets dans le blog
    54
    Par défaut
    Citation Envoyé par Lung Voir le message
    Je ne connaissais pas cet onglet (première fois que je le vois).
    Impossible de décocher les deux éléments cochés.
    déjà, on sait d'où vient le problème
    donc, si tu ouvres cette fenêtre (voir/aperçu multi-périphérique) tu vois 1 écran Iphone 4 pouces et 1 écran téléphone Android 4 pouces ?
    si c'est le cas et si la liste déroulante à tendance à se bloquer après les périphériques Apple il y a de fortes chances que le SDK Android n'ai pas été installé (genre "j'en ai pas besoin, je l'installe pas") reste à trouver dans la base de registre où sont mémorisés les aperçus
    certainement quelque part là dedans HKEY_CURRENT_USER\SOFTWARE\Embarcadero\BDS\17.0
    La seule chose absolue dans un monde comme le nôtre, c'est l'humour. » Albert Einstein

    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) et peut être quelques autres
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

Discussions similaires

  1. [Windows] [Delphi 10] Bug lors de l'application d'un style dans StyleLookup ?
    Par Lung dans le forum Composants FMX
    Réponses: 2
    Dernier message: 02/12/2015, 14h19
  2. Réponses: 2
    Dernier message: 21/03/2012, 22h53
  3. Réponses: 1
    Dernier message: 14/08/2006, 00h06
  4. [bug aléatoire] sauvegarde dans un fichier
    Par poukill dans le forum C++
    Réponses: 11
    Dernier message: 30/05/2006, 08h36
  5. Pas de liste "A Faire" dans l'IDE de BCB5
    Par psau dans le forum C++Builder
    Réponses: 3
    Dernier message: 06/08/2003, 13h57

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo