Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Excel Discussion :

Formule Rang - saut dans le classement


Sujet :

Excel

  1. #1
    Futur Membre du Club
    Inscrit en
    mai 2007
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : mai 2007
    Messages : 8
    Points : 7
    Points
    7
    Par défaut Formule Rang - saut dans le classement
    Bonjour,

    La formule Rang fonctionne bien, mais s'il y a des ex-aequo, le rang sera le chiffre correspondant au précédent rang + le nombre d'ex-aequo.
    Rang
    1
    2
    4
    6
    10
    etc.
    J'aimerais un classement sans sauts, quelque soit le nombre d'ex-aequo par "classe".
    1
    2
    3
    4
    5
    etc.

    Bonne journée :-)

  2. #2
    Membre du Club
    Profil pro
    Inscrit en
    août 2007
    Messages
    46
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2007
    Messages : 46
    Points : 49
    Points
    49
    Par défaut
    Bonjour,

    Si on met dans la colonne A, à partir de A2, les points au classement, et dans la colonne B, à partir de B2, le classement lui-même, on a donc par exemple :
    5
    5
    3
    3
    3
    1
    1
    1
    0

    en colonne A, et :
    1
    1
    3
    3
    3
    6
    6
    6
    9

    en colonne B. Le problème est de transformer ce classement en :

    1
    1
    2
    2
    2
    3
    3
    3
    4

    J'ai une proposition, qui vaut ce qu'elle vaut.
    Pour cela, on peut ajouter, par exemple en D2, la formule :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SI(A2="";"";SI(NB.SI($B$2:B2;B2)>1;-1;A2))
    , et l'étirer vers le bas, mettons jusqu'en A30 pour l'exemple.
    Ensuite, on peut ajouter en E2 la formule :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SIERREUR(SI(D2=-1;RECHERCHEV(A2;DECALER($D$2;0;0;LIGNE()-LIGNE($D$2);2);2;FAUX);RANG(D2;$D$2:$D$30;0));"")
    , et l'étirer vers le bas jusqu'en E30.
    La colonne E donne le classement souhaité. On peut éventuellement masquer la colonne D pour cacher ces calculs intermédiaires.

    Il y a sûrement plus simple, mais c'est le premier truc qui me vient à l'esprit.

    Cordialement

  3. #3
    Futur Membre du Club
    Inscrit en
    mai 2007
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : mai 2007
    Messages : 8
    Points : 7
    Points
    7
    Par défaut
    J'ai trouvé une solution toute bête.
    Dans la première cellule (B2) de classement je mets "1"
    Dans la cellule en dessous:
    la formule:
    =SI(A3<A2;B2+1;B2)
    Que je recopie vers le bas.

    J'aimerais classer en intervalles (classes)....je vais réfléchir...

    Merci pour la contribution.

  4. #4
    Membre du Club
    Profil pro
    Inscrit en
    août 2007
    Messages
    46
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2007
    Messages : 46
    Points : 49
    Points
    49
    Par défaut
    Ben oui, beaucoup plus simple, en effet

Discussions similaires

  1. N° de rang dans un classement
    Par Christophe Charron dans le forum Outils
    Réponses: 4
    Dernier message: 28/06/2007, 22h29
  2. [Système] Exécution Formule de calcul dans une chaîne
    Par san--antonio dans le forum Langage
    Réponses: 2
    Dernier message: 16/06/2006, 08h11
  3. [FLASH 8] Saut dans un jeu
    Par Destiny dans le forum Flash
    Réponses: 6
    Dernier message: 04/05/2006, 16h41
  4. Formule de calcul dans Access
    Par 29041977 dans le forum Access
    Réponses: 2
    Dernier message: 26/04/2006, 12h40
  5. [VBA-E] Copier une formule de calcul dans toute la ligne
    Par kernel57 dans le forum Macros et VBA Excel
    Réponses: 2
    Dernier message: 12/12/2005, 18h18

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo