+ Répondre à la discussion
Affichage des résultats 1 à 5 sur 5
  1. #1
    Invité de passage
    Inscrit en
    mai 2008
    Messages
    18
    Détails du profil
    Informations forums :
    Inscription : mai 2008
    Messages : 18
    Points : 1
    Points
    1

    Par défaut make menuconfig noyau linux, buildroot

    Bonjour tout le monde,

    J'essaie de lancer la configuration d'un noyau linux, ainsi que celle de l'outil de compilation croisée buildroot. Pour cela j'effectue un make menuconfig, mais la compilation se termine par une erreur, à la suite du warning suivant : as: unrecognized option '--64'

    Pour information, j'utilise un ordinateur avec processeur 64 bits, j'ai donc vérifié que mon gcc était celui-correspondant, ce qui est le cas, et fais de même avec buildroot et mon noyau, qui supportent bien cette architecture.
    Auriez-vous des idées sur ce qui génère ce warning, et qui provoque une erreur de mon make ?

    Merci d'avance.

  2. #2
    Membre Expert
    Avatar de Aquanum
    Homme Profil pro
    Ingénieur Linux Embarqué
    Inscrit en
    janvier 2006
    Messages
    704
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur Linux Embarqué
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : janvier 2006
    Messages : 704
    Points : 2 169
    Points
    2 169

    Par défaut

    Salut.
    Peux-tu nous donner plus de logs stp ?
    Quelle est ta version de gcc ?

  3. #3
    Invité de passage
    Inscrit en
    mai 2008
    Messages
    18
    Détails du profil
    Informations forums :
    Inscription : mai 2008
    Messages : 18
    Points : 1
    Points
    1

    Par défaut

    J'utilise gcc 4.7, arch x86_64. J'ai tenté d'ajouter l'option -m32 dans le makefile, au niveau du gcc,mais cela n'a rien changé. J'ai ensuite compris que "as" correspondait à l'assembleur gnu, donc c'est à son niveau qu'il faut indiquer l'option -march=x86_64. Mais cela ne fonctionne toujours pas. Pour vérifier que c'était bien un problème de compilation 64 bits pour une cible 32, j'ai utiliser un ubuntu 32 bits ne machine virtuelle, et le make menuconfig fonctionnait parfaitement. A ce stage, je pense faire un chroot d'un fedora 32 bits pour pouvoir faire mes compilations. Bonne idée ou mon problème peut être résolu ?
    De plus, j'ai fait un grep de "--64" pour voir si l'option était indiquée dans un des fichiers, mais résultat nul.

    messages obtenus à la suite de make menuconfig :

    make[1]: Entering directory `/home/LeBadaking/Desktop/Entrainement/buildroot-2012.08/support/kconfig'
    /usr/bin/gcc /usr/bin/gcc -DCURSES_LOC="<curses.h>" -DLOCALE -DKBUILD_NO_NLS -I/home/LeBadaking/Desktop/Entrainement/buildroot-2012.08/output/build/buildroot-config -c conf.c -o /home/LeBadaking/Desktop/Entrainement/buildroot-2012.08/output/build/buildroot-config/conf.o
    as: unrecognized option '--64'
    make[1]: *** [/home/LeBadaking/Desktop/Entrainement/buildroot-2012.08/output/build/buildroot-config/conf.o] Error 1

  4. #4
    Membre Expert
    Avatar de Aquanum
    Homme Profil pro
    Ingénieur Linux Embarqué
    Inscrit en
    janvier 2006
    Messages
    704
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur Linux Embarqué
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : janvier 2006
    Messages : 704
    Points : 2 169
    Points
    2 169

    Par défaut

    Je viens d'essayer sur une machine Ubuntu 64 bit (à jour) depuis zéro avec la même version de buildroot que toi mais avec gcc 4.6.3, ça marche sans soucis de mon côté.

    As-tu essayé make xconfig ou make gconfig à la place ? Ça ne règlera pas le problème, mais peut-être que le soucis n'impacte que la compilation de kconfig
    Et si tu changes la version de gcc en essayant une version plus ancienne ? Il me semble que le dernier gcc n'est pas l'ami de Buildroot sur les 64bits. Je me demande même si je n'ai pas déjà entendu parler de ce bug au boulot chez certains collègues qui ont une machine plus récente (et un gcc 4.7.x). Bref, je suspecte fortement ta version de gcc.

    Et si vraiment ça ne change rien, je t'invite à contacter la mailing list de buildroot. Tu auras très certainement la réponse à ton problème Car si ce n'est pas gcc, je suis à court d'idée pour le moment.

  5. #5
    Invité de passage
    Inscrit en
    mai 2008
    Messages
    18
    Détails du profil
    Informations forums :
    Inscription : mai 2008
    Messages : 18
    Points : 1
    Points
    1

    Par défaut

    Pour make xconfig, et gconfig cela ne change rien. Tu as sûrement raison pour gcc si cela marche chez toi, mais je suis sous fedora 17, et pas possible de repasser à la version 4.6.3, donc j'utilise un debootsrap, qui marche parfaitement. En tout cas, merci de ton aide !

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •