IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Affichage des résultats du sondage: Où en êtes vous par rapport à l'EOL Java SE 5.0 ?

Votants
28. Vous ne pouvez pas participer à ce sondage.
  • Nous avons migré en Java SE 6.0

    16 57,14%
  • Nous sommes passé à Java SE for Business 5.0 auprès de Sun

    0 0%
  • Nous avons oublié ce petit détail

    6 21,43%
  • Nous prenons le risque

    5 17,86%
  • Ce n'est pas mon problème

    1 3,57%
Langage Java Discussion :

Fin de support standard (EOL) pour Java SE 5.0, où en êtes vous ?


Sujet :

Langage Java

  1. #1
    Expert éminent sénior


    Profil pro
    Inscrit en
    octobre 2003
    Messages
    7 856
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2003
    Messages : 7 856
    Points : 34 373
    Points
    34 373
    Par défaut Fin de support standard (EOL) pour Java SE 5.0, où en êtes vous ?
    Bonsoir,

    Demain 30 octobre correspond à l'EOL (End Of Live) pour Java SE 5.0.

    Ou en êtes vous sur vos projets professionnels ?
    Avez vous :
    • migré en Java SE 6.0
    • passé à Java SE for Business 5.0 auprès de Sun
    • oublié ce petit détail
    • pas de crainte


    ?

    Pour info, une dernière version publique a été rendue disponible le 3 novembre : Sortie de Java SE 6 Update 17 et Java SE 5 Update 22 : mises à jour de sécurité

    Cf. http://java.sun.com/products/archive/eol.policy.html

  2. #2
    Inactif  
    Profil pro
    Inscrit en
    avril 2008
    Messages
    885
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations forums :
    Inscription : avril 2008
    Messages : 885
    Points : 1 310
    Points
    1 310
    Par défaut
    On vient de passer de Java 1.4 à un mixe Java 1.5 / Java 1.6, car une partie de notre solution logicielle tierce était passée en 1.5 / 1.6 (c'est tellement mal fichu que je suis incapable de dire si c'est full 1.6 :p)
    Quant à la fin du support 1.5 : ne l'ayant jamais utilisé, je ne pense pas que cela ne nous dérange, mais alors pas du tout. Je me demande même quelle update est installée sur nos serveurs / chez les collègues :p


    Parcontre, sur le plan personnel, je commence à me poser la question : pourrais-je voir en cette nouvelle une bonne excuse pour abandonner moi aussi la 1.5 ? Rhaaaa c'est ultra tentant.
    *graou* et même *graou*, ou encore *graou*

  3. #3
    Membre averti Avatar de vintz72
    Profil pro
    Inscrit en
    octobre 2005
    Messages
    154
    Détails du profil
    Informations personnelles :
    Âge : 49
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2005
    Messages : 154
    Points : 308
    Points
    308
    Par défaut
    Actuellement sur des projets conçus en JDK 1.6. Donc pas de problème.
    Précédemment, un projet monstrueux en 1.4... et là, c'est le drame.

    Franchement, si je dois revenir en JDK 1.4, ça me ferait hyper mal au c... parce que les generics notamment, c'est tout simplement indispensable une fois qu'on y a goûté !

  4. #4
    Inactif  
    Profil pro
    Inscrit en
    avril 2008
    Messages
    885
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations forums :
    Inscription : avril 2008
    Messages : 885
    Points : 1 310
    Points
    1 310
    Par défaut
    Idem pour le calvaire 1.4 quand on a gouté à 1.5
    j'ai quand même eu la chance d'arriver lors de la transition 1.4=>1.5 : sauvé.

    Parcontre, je ne pense pas que le passage 1.5=>1.6 soit aussi significatif : on n'a pas les mêmes changements connus lors de la migration précédente, cette fois-ci il n'y a pas de grandes nouveautés qui nous fassent maudire 1.5, contrairement à 1.4.
    *graou* et même *graou*, ou encore *graou*

  5. #5
    Membre régulier

    Inscrit en
    août 2006
    Messages
    93
    Détails du profil
    Informations personnelles :
    Âge : 41

    Informations forums :
    Inscription : août 2006
    Messages : 93
    Points : 120
    Points
    120
    Par défaut
    Ce qui fait peur dans ce tableau, c'est la fin du support du JDK 6 pour dans un an environ s'ils s'en tiennent à leurs prévisions

  6. #6
    Membre du Club
    Profil pro
    Inscrit en
    mai 2008
    Messages
    55
    Détails du profil
    Informations personnelles :
    Localisation : France, Nord (Nord Pas de Calais)

    Informations forums :
    Inscription : mai 2008
    Messages : 55
    Points : 53
    Points
    53
    Par défaut
    Perso ma dernière mission était en 1.4, et quand je vois le nombre d'applis qui sont encore développées en 1.4... l'année dernière j'ai même bossé sur du 1.3.

    S'ils arrêtent le support de jdk 6 l'année prochaine, qu'est ce qu'on est mal.

  7. #7
    Rédacteur
    Avatar de CyberChouan
    Homme Profil pro
    Directeur technique
    Inscrit en
    janvier 2007
    Messages
    2 752
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Directeur technique
    Secteur : Communication - Médias

    Informations forums :
    Inscription : janvier 2007
    Messages : 2 752
    Points : 4 437
    Points
    4 437
    Par défaut
    Citation Envoyé par xtope Voir le message
    Perso ma dernière mission était en 1.4, et quand je vois le nombre d'applis qui sont encore développées en 1.4... l'année dernière j'ai même bossé sur du 1.3.
    Même avis... Je travaille encore (pas par choix) sur des JVM 1.4 (serveurs Sun One 6.1).

    Donc pour ce que je peux voir, je dirais que la politique est : "on prend le risque !"
    Avant de poster, pensez à regarder la FAQ, les tutoriaux, la Javadoc (de la JRE que vous utilisez) et à faire une recherche
    Je ne réponds pas aux questions techniques par MP: les forums sont faits pour ça
    Mes articles et tutoriaux & Mon blog informatique

  8. #8
    Membre du Club
    Profil pro
    Inscrit en
    avril 2006
    Messages
    51
    Détails du profil
    Informations personnelles :
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : avril 2006
    Messages : 51
    Points : 64
    Points
    64
    Par défaut
    J'ai un doute, cette police est bien mentionnée pour J2SE qu'en est-il pour J2EE, est-ce qu'il s'agit de la même police de fin de vie ?

  9. #9
    Expert éminent sénior


    Profil pro
    Inscrit en
    octobre 2003
    Messages
    7 856
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2003
    Messages : 7 856
    Points : 34 373
    Points
    34 373
    Par défaut
    Citation Envoyé par TheNOHDirector Voir le message
    J'ai un doute, cette police est bien mentionnée pour J2SE qu'en est-il pour J2EE, est-ce qu'il s'agit de la même police de fin de vie ?
    Pas du tout, d'ailleurs J2EE/Java EE n'est qu'une spécification, la police de fin de vie dépend de l'implémentation utilisée (et donc du éditeur/revendeur concerné).

  10. #10
    Expert éminent sénior


    Profil pro
    Inscrit en
    octobre 2003
    Messages
    7 856
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2003
    Messages : 7 856
    Points : 34 373
    Points
    34 373
    Par défaut
    Pour info, une dernière version publique a été rendue disponible : Sortie de Java SE 6 Update 17 et Java SE 5 Update 22 : mises à jour de sécurité

  11. #11
    Membre du Club
    Profil pro
    Inscrit en
    avril 2006
    Messages
    51
    Détails du profil
    Informations personnelles :
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : avril 2006
    Messages : 51
    Points : 64
    Points
    64
    Par défaut
    Merci Ricky, effectivement je connaissais le support J2EE de l'éditeur, mais le doute que j'avais me laissait penser que Sun avait également un support sur cette spécification.

  12. #12
    lvr
    lvr est déconnecté
    Membre extrêmement actif Avatar de lvr
    Profil pro
    Responsable de projet fonctionnel
    Inscrit en
    avril 2006
    Messages
    877
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations professionnelles :
    Activité : Responsable de projet fonctionnel
    Secteur : Arts - Culture

    Informations forums :
    Inscription : avril 2006
    Messages : 877
    Points : 1 222
    Points
    1 222
    Par défaut
    Quid du support sur Mac ? D'après mes dernières infos (qui datent un peu), le Java 6 n'était pas supportés sur plusieurs versions du MacOS. Ca a changé ? Etre obligé de passer à Java 6 ne nous ferme-t-il pas les portes du monde Mac ?

Discussions similaires

  1. Réponses: 35
    Dernier message: 03/02/2015, 16h21
  2. Microsoft annonce la fin du support standard de Windows Phone 7.8
    Par Hinault Romaric dans le forum Windows Phone
    Réponses: 9
    Dernier message: 10/07/2014, 16h01
  3. Fin du support d’IE 8 pour Google Apps
    Par Hinault Romaric dans le forum Actualités
    Réponses: 8
    Dernier message: 17/09/2012, 16h29
  4. Rappel : Dates de fin de support pour SQL Server
    Par mikedavem dans le forum Actualités
    Réponses: 5
    Dernier message: 18/01/2010, 17h36
  5. Réponses: 7
    Dernier message: 07/07/2009, 11h06

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo