IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Java Discussion :

[Environnement]Problème avec JAVA_HOME


Sujet :

Java

  1. #1
    Membre du Club
    Inscrit en
    juin 2005
    Messages
    47
    Détails du profil
    Informations forums :
    Inscription : juin 2005
    Messages : 47
    Points : 41
    Points
    41
    Par défaut [Environnement]Problème avec JAVA_HOME
    Bonjour à tous,
    Voilà j'execute ANT, tout marche très bien. Je compile des .java, je les execute, tout marche très bien.
    Mais lorsque je le mets dans la crontab, là il me retourne une erreur :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    Error: JAVA_HOME is not defined correctly.
      We cannot execute java
    Et si je veux juste executer une compilation et une execution d'un programme java avec la crontab, il me ressortira qu'il ne connait pas javac et java !!!
    Je comprends pas parce que ça marche bien en tant normal alors pourquoi ça me fait cela quand j'utilise la crontab ?
    Merci,


    [Modéré par Didier] : ajout de tag dans le titre - Les règles du forum Java

  2. #2
    Expert éminent sénior
    Avatar de adiGuba
    Homme Profil pro
    Développeur Java/Web
    Inscrit en
    avril 2002
    Messages
    13 938
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Java/Web
    Secteur : Transports

    Informations forums :
    Inscription : avril 2002
    Messages : 13 938
    Points : 23 015
    Points
    23 015
    Billets dans le blog
    1
    Par défaut
    Salut,

    Soit le crontab démarre ant avec un autre utilisateur.
    Soit il ne 'charge' pas ton .profile

    Bref il ne trouve pas ton JAVA_HOME...

    a++

  3. #3
    Expert confirmé
    Avatar de le y@m's
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    février 2005
    Messages
    2 636
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : février 2005
    Messages : 2 636
    Points : 5 940
    Points
    5 940
    Par défaut
    il me semble que la variable JAVA_HOME est initialisée au lancement du shell (.profile, .bashrc, etc ...) donc avec crontab ta variable n'est pas initialisée.
    pour régler ton probleme, crées un script qui:
    • initialise JAVA_HOME
    • puis execute ant
    c'est le script que tu lanceras avec la crontab et non plus ant directement
    Je ne répondrai à aucune question technique par MP.

    Pensez aux Tutoriels et aux FAQs avant de poster (pour le java il y a aussi JavaSearch), n'oubliez pas non plus la fonction Rechercher.
    Enfin, quand une solution a été trouvée à votre problème
    pensez au tag

    Cours Dvp : http://ydisanto.developpez.com
    Blog : http://yann-disanto.blogspot.com/
    Page perso : http://yann-disanto.fr

  4. #4
    Membre du Club
    Inscrit en
    juin 2005
    Messages
    47
    Détails du profil
    Informations forums :
    Inscription : juin 2005
    Messages : 47
    Points : 41
    Points
    41
    Par défaut [Résolu]
    C'est bon !!
    Bien joué, j'avoue que je n'avais pas pensé à remettre tous mes "export" dans un script.
    Merci.

    PS : j'aime bien ta citation le y@m's !!

  5. #5
    Expert confirmé
    Avatar de le y@m's
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    février 2005
    Messages
    2 636
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 38
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : février 2005
    Messages : 2 636
    Points : 5 940
    Points
    5 940
    Par défaut Re: [Résolu]
    merci, et n'oublie pas le tag resolu
    Je ne répondrai à aucune question technique par MP.

    Pensez aux Tutoriels et aux FAQs avant de poster (pour le java il y a aussi JavaSearch), n'oubliez pas non plus la fonction Rechercher.
    Enfin, quand une solution a été trouvée à votre problème
    pensez au tag

    Cours Dvp : http://ydisanto.developpez.com
    Blog : http://yann-disanto.blogspot.com/
    Page perso : http://yann-disanto.fr

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Environnement de développement QxOrm avec MinGW
    Par cgMorpheus82 dans le forum QxOrm
    Réponses: 4
    Dernier message: 17/04/2014, 14h19
  2. Réponses: 24
    Dernier message: 15/12/2012, 20h42
  3. Réponses: 11
    Dernier message: 27/06/2012, 16h59
  4. [subversion/trac] Probl. de permission avec authz dans svnserve.conf
    Par mcdeffice dans le forum Administration système
    Réponses: 0
    Dernier message: 23/07/2009, 16h21
  5. Choix d'un environnement de dev GUI avec contraintes
    Par Dazdh dans le forum Interfaces Graphiques en Java
    Réponses: 6
    Dernier message: 17/03/2009, 16h16

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo