IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Editeurs / Outils Discussion :

[TeXnicCenter] Compilation lente


Sujet :

Editeurs / Outils

  1. #1
    Membre actif Avatar de Fango
    Profil pro
    Inscrit en
    décembre 2005
    Messages
    197
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations forums :
    Inscription : décembre 2005
    Messages : 197
    Points : 205
    Points
    205
    Par défaut [TeXnicCenter] Compilation lente
    Bonjour a tous,

    Je ne peux plus compiler mon projet car la compilation est devenue tres lente et demande beaucoup de ressources. Pourtant, je n'ai pas trouve d'erreurs dans ce que j'ai rajoute et les fichiers de log ne m'ont pas permis de trouver l'origine du probleme.

    Quelqu'un a t'il une idee sur la question? Merci d'avance de votre aide.

  2. #2
    Membre régulier
    Avatar de Olivier_
    Profil pro
    Inscrit en
    mars 2005
    Messages
    111
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2005
    Messages : 111
    Points : 124
    Points
    124
    Par défaut
    Hoplà,

    je suis débutant LaTeX donc je peux dire une grosse bétise

    Perso, quand je compile, j'utilise PDFLatex, et c'est super lent lorsque j'ai des images à intégrer, je commente donc toutes mes images sauf pour la compilation d'une version plus ou moins finale.

    ++

  3. #3
    Membre actif Avatar de Fango
    Profil pro
    Inscrit en
    décembre 2005
    Messages
    197
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations forums :
    Inscription : décembre 2005
    Messages : 197
    Points : 205
    Points
    205
    Par défaut
    Merci de ta reponse. Mon probleme vient du fait que ce n'en etait pas un avant et cette lenteur subite m'en pose un sacre gros (de probleme)
    Et je n'ai pas insere de nouvelles images, etc... bref, je ne comprend pas!

  4. #4
    Membre actif Avatar de Fango
    Profil pro
    Inscrit en
    décembre 2005
    Messages
    197
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations forums :
    Inscription : décembre 2005
    Messages : 197
    Points : 205
    Points
    205
    Par défaut
    J'ai le même probleme que je genere un pdf ou un dvi. J'ai verifie la structure de mon document, mais je ne vois rien qui cloche...

  5. #5
    Membre actif Avatar de Fango
    Profil pro
    Inscrit en
    décembre 2005
    Messages
    197
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations forums :
    Inscription : décembre 2005
    Messages : 197
    Points : 205
    Points
    205
    Par défaut
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    %% The List of Figures
    \clearpage
    \addcontentsline{toc}{chapter}{List of Figures}
    \listoffigures
     
    %% The List of Tables
    \clearpage
    \addcontentsline{toc}{chapter}{List of Tables}
    \listoftables
    Bon, c'est plus rapide quand je commente ces lignes de mon fichier principal... sachant qu'elles sont la depuis le debut et qu'elles ne m'ont jamais pose probleme... quelqu'un y comprend quelque chose?

  6. #6
    Candidat au Club
    Inscrit en
    juin 2007
    Messages
    3
    Détails du profil
    Informations forums :
    Inscription : juin 2007
    Messages : 3
    Points : 4
    Points
    4
    Par défaut
    Citation Envoyé par Fango
    Bonjour a tous,

    Je ne peux plus compiler mon projet car la compilation est devenue tres lente et demande beaucoup de ressources. Pourtant, je n'ai pas trouve d'erreurs dans ce que j'ai rajoute et les fichiers de log ne m'ont pas permis de trouver l'origine du probleme.

    Quelqu'un a t'il une idee sur la question? Merci d'avance de votre aide.
    J'ai rencontré le même problème. Voilà ma conf lorsque ça ne marchait plus (soudainement !).
    - Vista ultimate / UAC désactivé
    - Miktex 2.5
    Mon install de miktex a été faite en copiant une install qui fonctionnait à partir d'une autre partition dans le répertoire "c:/program files"

    Symptomes :
    - temps de chargement des packages lors de la compilation interminable, compilation latex très longue
    - idem pour pdflatex

    Résolution du problème :
    - installation propre de miktex 2.6 à partir du setup officiel et en dehors du répertoire "Program Files"
    - modif du path pour pointer sur la 2.6

    J'avoue c'est un peu radical mais au moins tout est rentré dans l'ordre

    Bon courage

  7. #7
    Membre actif Avatar de Fango
    Profil pro
    Inscrit en
    décembre 2005
    Messages
    197
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations forums :
    Inscription : décembre 2005
    Messages : 197
    Points : 205
    Points
    205
    Par défaut
    Merci pour ta réponse, mais cela n'avait pas marché dans mon cas. Je l'ai résolu comme indiqué dans ce sujet, en ecrasant mon fichier projet par une version antérieure. J'espére que cela peut t'aider.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. TeXnicCenter compilation trop lente
    Par abel413 dans le forum Editeurs / Outils
    Réponses: 14
    Dernier message: 22/08/2013, 21h34
  2. QProgressDialog inopérante et compilation lente
    Par stanfillirenfro dans le forum Débuter
    Réponses: 3
    Dernier message: 08/01/2013, 01h07
  3. [QProgressDialog] Lancement décalé et compilation lente
    Par stanfillirenfro dans le forum Débuter
    Réponses: 0
    Dernier message: 26/09/2012, 13h14
  4. Compilation lente ifpdf.sty
    Par papal02 dans le forum Editeurs / Outils
    Réponses: 2
    Dernier message: 29/10/2010, 19h51
  5. probleme texniccenter compilation
    Par sebpiano dans le forum Débuter
    Réponses: 1
    Dernier message: 23/10/2009, 13h03

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo