IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Java Discussion :

Problème de plugins svn avec eclipse


Sujet :

Eclipse Java

  1. #1
    Nouveau Candidat au Club
    Inscrit en
    octobre 2004
    Messages
    2
    Détails du profil
    Informations forums :
    Inscription : octobre 2004
    Messages : 2
    Points : 1
    Points
    1
    Par défaut Problème de plugins svn avec eclipse
    Bonjour
    Je souhaiterais installer le plugs svn dans eclipse apres avoir mis:
    nom:Subclipse
    url:http://subclipse.tigris.org/update_1.2.x

    voila ce que j 'ai comme erreur:
    Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
    ----- Current configuration problems -----
    Eclipse BIRT Chart Runtime Feature (2.1.2.v20070205-1728) requires feature "org.apache.commons.codec (1.3.0)", or later version.
    Eclipse BIRT Chart Framework (2.1.2.v20070205-1728) requires feature "org.apache.commons.codec (1.3.0)", or later version.
    Data Tools Platform Model Base (0.9.1.200609201) requires feature "org.eclipse.emf (2.1.0)", or later version.
    Data Tools Platform Open Data Access Designer (0.9.1.200609201) requires feature "org.eclipse.emf (2.1.0)", or later version.
    Eclipse BIRT Example (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse BIRT Report Designer Framework (2.1.2.v20070205-1728) requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
    Eclipse BIRT Report Designer Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Data Tools Platform SQL Development Tools (0.9.1.200609201) requires feature "org.eclipse.gef (3.2.0)", or compatible.
    Eclipse BIRT Report Runtime Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    ----- Configuration problems after the operation -----
    Eclipse BIRT Chart Runtime Feature (2.1.2.v20070205-1728) requires feature "org.apache.commons.codec (1.3.0)", or later version.
    Eclipse BIRT Chart Framework (2.1.2.v20070205-1728) requires feature "org.apache.commons.codec (1.3.0)", or later version.
    Data Tools Platform Model Base (0.9.1.200609201) requires feature "org.eclipse.emf (2.1.0)", or later version.
    Data Tools Platform Open Data Access Designer (0.9.1.200609201) requires feature "org.eclipse.emf (2.1.0)", or later version.
    Eclipse BIRT Example (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse BIRT Report Designer Framework (2.1.2.v20070205-1728) requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
    Eclipse BIRT Report Designer Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Data Tools Platform SQL Development Tools (0.9.1.200609201) requires feature "org.eclipse.gef (3.2.0)", or compatible.
    Eclipse BIRT Report Runtime Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Subclipse Mylar Integration (1.0.1) requires plug-in "org.eclipse.mylar.tasks.core (0.9.2)", or later version.
    quelqu'un pourrait me dire quoi faire svp
    Merci

  2. #2
    Membre habitué Avatar de nicgando
    Profil pro
    Inscrit en
    mars 2006
    Messages
    128
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : mars 2006
    Messages : 128
    Points : 163
    Points
    163
    Par défaut
    Peux être un problème de compatibilité ente la version de ton plugin et la version de ton Eclipse.

    Sinon tu peux essayer un autre plugin pour svn: subversive
    Comme dit dans le lien "Support Eclipse Version: 3.0 and later"
    Pushing the limits ...

  3. #3
    Membre expert
    Avatar de natha
    Profil pro
    Inscrit en
    janvier 2006
    Messages
    2 346
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : janvier 2006
    Messages : 2 346
    Points : 3 083
    Points
    3 083
    Par défaut
    Subclipse est quand même meilleur que Subversive.
    Comment ça ? La réponse à ton problème n'est ni dans la faq, ni dans les tutos, ni dans sources ??? Etonnant...
    De la bonne manière de poser une question (et de répondre).
    Je ne fais pas de service par MP. Merci (...de lire les règles...).
    Ma page dvp.com

  4. #4
    Nouveau Candidat au Club
    Inscrit en
    octobre 2004
    Messages
    2
    Détails du profil
    Informations forums :
    Inscription : octobre 2004
    Messages : 2
    Points : 1
    Points
    1
    Par défaut
    Citation Envoyé par nicgando
    Peux être un problème de compatibilité ente la version de ton plugin et la version de ton Eclipse.

    Sinon tu peux essayer un autre plugin pour svn: subversive
    Comme dit dans le lien "Support Eclipse Version: 3.0 and later"
    Oui mais j'utilise la version 3.2 sur kubuntu

  5. #5
    Membre expert
    Avatar de natha
    Profil pro
    Inscrit en
    janvier 2006
    Messages
    2 346
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : janvier 2006
    Messages : 2 346
    Points : 3 083
    Points
    3 083
    Par défaut
    J'ai surtout l'impression que ça n'a rien à voir avec ton plugin SVN mais plutôt avec les plugins déjà installés auxquels il manque des dépendances.
    Comment ça ? La réponse à ton problème n'est ni dans la faq, ni dans les tutos, ni dans sources ??? Etonnant...
    De la bonne manière de poser une question (et de répondre).
    Je ne fais pas de service par MP. Merci (...de lire les règles...).
    Ma page dvp.com

  6. #6
    Expert éminent sénior
    Avatar de Baptiste Wicht
    Homme Profil pro
    Étudiant
    Inscrit en
    octobre 2005
    Messages
    7 431
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Suisse

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2005
    Messages : 7 431
    Points : 21 318
    Points
    21 318
    Par défaut
    Citation Envoyé par natha
    J'ai surtout l'impression que ça n'a rien à voir avec ton plugin SVN mais plutôt avec les plugins déjà installés auxquels il manque des dépendances.
    +1

    Il me semble que le problème vient que des plugins ont besoin de ressources qui ne sont pas disponibles.

    Si j'étais toi, je réinstallerais proprement Eclipse en utilisant la mise à jour directe depuis Eclipse pour faire ça bien.

  7. #7
    Candidat au Club
    Profil pro
    Inscrit en
    mai 2007
    Messages
    2
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2007
    Messages : 2
    Points : 2
    Points
    2
    Par défaut
    Citation Envoyé par michael2000
    Bonjour
    Je souhaiterais installer le plugs svn dans eclipse apres avoir mis:
    nom:Subclipse
    url:http://subclipse.tigris.org/update_1.2.x

    voila ce que j 'ai comme erreur:
    Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
    ----- Current configuration problems -----
    Eclipse BIRT Chart Runtime Feature (2.1.2.v20070205-1728) requires feature "org.apache.commons.codec (1.3.0)", or later version.
    Eclipse BIRT Chart Framework (2.1.2.v20070205-1728) requires feature "org.apache.commons.codec (1.3.0)", or later version.
    Data Tools Platform Model Base (0.9.1.200609201) requires feature "org.eclipse.emf (2.1.0)", or later version.
    Data Tools Platform Open Data Access Designer (0.9.1.200609201) requires feature "org.eclipse.emf (2.1.0)", or later version.
    Eclipse BIRT Example (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse BIRT Report Designer Framework (2.1.2.v20070205-1728) requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
    Eclipse BIRT Report Designer Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Data Tools Platform SQL Development Tools (0.9.1.200609201) requires feature "org.eclipse.gef (3.2.0)", or compatible.
    Eclipse BIRT Report Runtime Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    ----- Configuration problems after the operation -----
    Eclipse BIRT Chart Runtime Feature (2.1.2.v20070205-1728) requires feature "org.apache.commons.codec (1.3.0)", or later version.
    Eclipse BIRT Chart Framework (2.1.2.v20070205-1728) requires feature "org.apache.commons.codec (1.3.0)", or later version.
    Data Tools Platform Model Base (0.9.1.200609201) requires feature "org.eclipse.emf (2.1.0)", or later version.
    Data Tools Platform Open Data Access Designer (0.9.1.200609201) requires feature "org.eclipse.emf (2.1.0)", or later version.
    Eclipse BIRT Example (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Eclipse BIRT Report Designer Framework (2.1.2.v20070205-1728) requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
    Eclipse BIRT Report Designer Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Data Tools Platform SQL Development Tools (0.9.1.200609201) requires feature "org.eclipse.gef (3.2.0)", or compatible.
    Eclipse BIRT Report Runtime Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.tomcat (4.1.130)", or compatible.
    Subclipse Mylar Integration (1.0.1) requires plug-in "org.eclipse.mylar.tasks.core (0.9.2)", or later version.

    culcun pourrait me dire quoi faire svp
    Merci
    C'est cette ligne -ci qui doit être le problème:
    Subclipse Mylar Integration (1.0.1) requires plug-in "org.eclipse.mylar.tasks.core (0.9.2)", or later version.
    Apparemment après installation ce serait là d'ou viendrait le problème.
    Donc ce que je pourrais conseiller comme solution c'est d'upgrader org.eclipse.mylar.tasks.core à la version demandée (0.9.2). Je crois que c'est faisable en updatant ou installant le plugin Mylar si tu l'utilises.

    Site de download du plugin Mylar:
    http://www.eclipse.org/mylar/dl.php

    Mais d'après cette page:
    http://www.nabble.com/installation-p...-t3345510.html
    Il n'est pas necessaire de faire cette opération et Subclipse devrait fonctionner même sans mylar.

    A par ça je vois pas.

  8. #8
    Nouveau membre du Club
    Profil pro
    Étudiant
    Inscrit en
    janvier 2007
    Messages
    39
    Détails du profil
    Informations personnelles :
    Âge : 34
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : janvier 2007
    Messages : 39
    Points : 30
    Points
    30
    Par défaut
    Bonjour tout le monde, je relance un vieux topic mais ne vous inquiétez je ne suis pas un homme préhistorique. Je me permets de répondre au problème posé sur ce forum car il m'est arrivé la même mésaventure aujourd'hui.

    Le problème vient de l'archive téléchargée contenant l'application Eclipse. Si l'archive est cassée certains plugins ne fonctionnent pas correctement. Avant de décompresser l'archive il faudrait donc tester si cette archive est bonne avec des outils comme IzArc (gratuit) ou WinRar (payant).

    Si celle-ci est cassée il suffit de la réparer avec ces mêmes outils. Et si cela ne fonctionne toujours pas, il faut retélécharger Eclipse sur le site officiel.

Discussions similaires

  1. Problème de clic droit avec Eclipse sous Ubuntu
    Par CocoRambo dans le forum Eclipse
    Réponses: 1
    Dernier message: 18/11/2009, 10h20
  2. Problème de plugin(Tomcat) sur Eclipse
    Par pracede2005 dans le forum Eclipse Java
    Réponses: 4
    Dernier message: 10/11/2008, 19h42
  3. problème création plugin projet wizard eclipse
    Par koko_boy dans le forum Eclipse Java
    Réponses: 0
    Dernier message: 29/10/2007, 13h09
  4. Plugin TOMCAT avec eclipse
    Par faico dans le forum Eclipse Java
    Réponses: 6
    Dernier message: 27/09/2006, 18h29
  5. Problème de fichier jar avec eclipse<débutant>
    Par melodie53 dans le forum Eclipse Java
    Réponses: 7
    Dernier message: 28/07/2006, 16h41

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo