IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Requêtes et SQL. Discussion :

critères de sélection qui ne fonctionne pas avec les tables attachées


Sujet :

Requêtes et SQL.

  1. #1
    Nouveau membre du Club
    Inscrit en
    mars 2007
    Messages
    63
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 63
    Points : 36
    Points
    36
    Par défaut critères de sélection qui ne fonctionne pas avec les tables attachées
    Bonjour,
    quand j'essaie d'appliquer un critère de sélection sur une date qui est dans une table liée, ça ne fonctionne pas.
    J'utilise la requête Entre Maintenant() Et Maintenant()-1 qui fonctionne très bien sur les tables de la base access mais cela ne fonctionne pas sur les tables qui sont liées sur un BD Oracle.
    Je ne peux pas modifier les tables qui sont sur Oracle.
    J'ai aussi essayé Entre Maintenant() Et AjDate("j";-1;Date()).
    D'ou vient le problème et surtout avez vous une solution?

  2. #2
    Rédacteur/Modérateur
    Avatar de loufab
    Homme Profil pro
    rédacteur/modérateur
    Inscrit en
    avril 2005
    Messages
    11 342
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : rédacteur/modérateur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2005
    Messages : 11 342
    Points : 23 061
    Points
    23 061
    Par défaut
    Bonjour,

    Je en connais pas trop le Sql Oracle mais il se peut que le Between ou maintenant() ne soit pas pris en compte.

    Tu peux peut-être utiliser ceci

    ChampDate > madate and champDate < madate-1

    A
    Détecter les modifications formulaire Cloud storage et ACCESS
    Classe MELA(CRUD) Opérateur IN et zone de liste Opérateur LIKE
    Visitez mon Blog
    Les questions techniques par MP ne sont pas lues et je ne pratique pas la bactériomancie

  3. #3
    Nouveau membre du Club
    Inscrit en
    mars 2007
    Messages
    63
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 63
    Points : 36
    Points
    36
    Par défaut
    Et oui bien vu,
    je pensais que c'était la fonction Maintenant() qui n'étais pas reconnue et je n'arrivais pas à trouver d'alternative,
    mais en fait c'est la fonction Entre...Et... qui n'est pas reconnue dans le sql.
    C'est quand même bizarre mais j'ai donc réussi avec :
    [Champ]<Maintenant() Et [Champ]>Maintenant()-1
    Merci

  4. #4
    Rédacteur/Modérateur
    Avatar de loufab
    Homme Profil pro
    rédacteur/modérateur
    Inscrit en
    avril 2005
    Messages
    11 342
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : rédacteur/modérateur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2005
    Messages : 11 342
    Points : 23 061
    Points
    23 061
    Par défaut
    Bizarre ?! pas trop chaque SQL est propre au produit. Vive le standard SQL.
    Détecter les modifications formulaire Cloud storage et ACCESS
    Classe MELA(CRUD) Opérateur IN et zone de liste Opérateur LIKE
    Visitez mon Blog
    Les questions techniques par MP ne sont pas lues et je ne pratique pas la bactériomancie

  5. #5
    Membre expérimenté

    Profil pro
    Inscrit en
    juin 2003
    Messages
    1 227
    Détails du profil
    Informations personnelles :
    Localisation : Sénégal

    Informations forums :
    Inscription : juin 2003
    Messages : 1 227
    Points : 1 550
    Points
    1 550
    Par défaut
    Citation Envoyé par arn.oo
    Et oui bien vu,
    mais en fait c'est la fonction Entre...Et... qui n'est pas reconnue dans le sql.
    As tu essayer avec Between ... And ... au lieu de Entre .... Et...

    Si Oracle ne connait pas de Between
    Amicalement

  6. #6
    Rédacteur/Modérateur
    Avatar de loufab
    Homme Profil pro
    rédacteur/modérateur
    Inscrit en
    avril 2005
    Messages
    11 342
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : rédacteur/modérateur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2005
    Messages : 11 342
    Points : 23 061
    Points
    23 061
    Par défaut
    Salut DMboup !

    La chaine SQL est toujours traduite en anglais.

    Fait beau chez toi ? question idiote tu peux le dire
    Détecter les modifications formulaire Cloud storage et ACCESS
    Classe MELA(CRUD) Opérateur IN et zone de liste Opérateur LIKE
    Visitez mon Blog
    Les questions techniques par MP ne sont pas lues et je ne pratique pas la bactériomancie

  7. #7
    Membre expérimenté

    Profil pro
    Inscrit en
    juin 2003
    Messages
    1 227
    Détails du profil
    Informations personnelles :
    Localisation : Sénégal

    Informations forums :
    Inscription : juin 2003
    Messages : 1 227
    Points : 1 550
    Points
    1 550
    Par défaut
    Citation Envoyé par loufab
    La chaine SQL est toujours traduite en anglais.
    Eh bien attendons que SQLPro passe par là. Parce que Oracle connait bien Between pour moi.

    Citation Envoyé par loufab
    Fait beau chez toi ?
    si si , et même toujours.
    Amicalement

  8. #8
    Nouveau membre du Club
    Inscrit en
    mars 2007
    Messages
    63
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 63
    Points : 36
    Points
    36
    Par défaut
    Je confirme que oracle connais between mais je sais pas pourquoi ça marche pas.
    J'ai plusieurs bugs de ce genre et il faut feinter.
    Par exemple il veut bien prendre le < mais pas le > comme critère sans rien changer d'autre
    ça existe de fonctions supérieur() et inférieur() histoire de le forcer un peu?

  9. #9
    Nouveau membre du Club
    Inscrit en
    mars 2007
    Messages
    63
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 63
    Points : 36
    Points
    36
    Par défaut
    c'est ma base qui est mal construite ou access 2000 qui bug?

  10. #10
    Rédacteur/Modérateur
    Avatar de loufab
    Homme Profil pro
    rédacteur/modérateur
    Inscrit en
    avril 2005
    Messages
    11 342
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : rédacteur/modérateur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2005
    Messages : 11 342
    Points : 23 061
    Points
    23 061
    Par défaut
    Le format de date ?
    Détecter les modifications formulaire Cloud storage et ACCESS
    Classe MELA(CRUD) Opérateur IN et zone de liste Opérateur LIKE
    Visitez mon Blog
    Les questions techniques par MP ne sont pas lues et je ne pratique pas la bactériomancie

  11. #11
    Nouveau membre du Club
    Inscrit en
    mars 2007
    Messages
    63
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 63
    Points : 36
    Points
    36
    Par défaut
    alors en fait mon calcul de délais se fait à partir de deux champs de type date/heure.
    Le résultat est écris dans un champs de type texte.
    Mon critère de sélection est >="10".
    En fait ça fonctionne pour les nombres et pas pour les chiffres (ça marche avec >="1" >="2"..... >="9" et à partir de >="10" ça marche plus )

Discussions similaires

  1. Réponses: 4
    Dernier message: 04/11/2009, 23h31
  2. Ancre qui ne fonctionne pas avec IE6
    Par bractar dans le forum Balisage (X)HTML et validation W3C
    Réponses: 2
    Dernier message: 03/06/2008, 17h17
  3. Problème de addEventListener qui ne fonctionne pas avec un attachMovie
    Par jeremie74 dans le forum ActionScript 1 & ActionScript 2
    Réponses: 1
    Dernier message: 27/09/2007, 11h47
  4. un For Each qui ne fonctionne pas avec une collection maison !
    Par grenouillesiverte dans le forum Windows Forms
    Réponses: 7
    Dernier message: 01/09/2007, 22h00
  5. tutoriel qui ne fonctionne pas avec glassfish
    Par dev7 dans le forum Glassfish et Payara
    Réponses: 1
    Dernier message: 13/04/2007, 18h25

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo