IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

DB2 Discussion :

HTTPPOSTCLOBVERBOSE : RESPONSEMSG qui contient un - lors d'une 400


Sujet :

DB2

  1. #1
    Membre régulier
    Profil pro
    Inscrit en
    décembre 2008
    Messages
    176
    Détails du profil
    Informations personnelles :
    Âge : 40
    Localisation : Belgique

    Informations forums :
    Inscription : décembre 2008
    Messages : 176
    Points : 91
    Points
    91
    Par défaut HTTPPOSTCLOBVERBOSE : RESPONSEMSG qui contient un - lors d'une 400
    Hello,

    J’essaie d’utiliser le HTTPPOSTCLOBVERBOSE de SYSTOOLS mais je ne reçois pas le body d’API attaquée quand le code retour est 400 ou 500 mais un simple -.

    Aucun problème quand le code retour est 200.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    select * 
    FROM TABLE (systools.httpPostClobVERBOSE ( CAST ( 'URL' as varchar(200) CCSID 1208), 
    cast('<httpHeader> <header name="Content-Type" value="application/json;charset=utf-8"/><header name="Authorization" value=" TOKKEN" /> </httpHeader>' as clob(10k) ccsid 1208), 
    cast('{ "Key1":699, "Key2":51 }' as clob(10k) ccsid 1208)) )as tabtes ;
    Avez-vous une idée*?

    D'avance, merci.
    Raphaël.
    Images attachées Images attachées  

  2. #2
    Membre régulier
    Profil pro
    Inscrit en
    décembre 2008
    Messages
    176
    Détails du profil
    Informations personnelles :
    Âge : 40
    Localisation : Belgique

    Informations forums :
    Inscription : décembre 2008
    Messages : 176
    Points : 91
    Points
    91
    Par défaut
    J’aurais du le préciser. J’ai évidement testé via postman.

    L’API répond bien un message de retour du genre.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    [
        {
            "message": "RC: bad value for restricted picklist field: 35",
            "errorCode": "INVALID_OR_NULL_FOR_RESTRICTED_PICKLIST",
            "fields": [
                "FW_Commerciale__c"
            ]
        }
    ]

  3. #3
    Membre régulier
    Profil pro
    Inscrit en
    décembre 2008
    Messages
    176
    Détails du profil
    Informations personnelles :
    Âge : 40
    Localisation : Belgique

    Informations forums :
    Inscription : décembre 2008
    Messages : 176
    Points : 91
    Points
    91
    Par défaut
    Pour le suivant en galère !

    Il faut simplement le spécifier dans le header quand on veut recevoir l'erreur.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    <httpHeader includeErrorMsg="true" />

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Ajout automatique d'une page qui contient des WebParts dans une bibliothèque
    Par hassine dans le forum Développement Sharepoint
    Réponses: 3
    Dernier message: 29/04/2011, 08h36
  2. Creer un pdf qui contient un diagramme et une table
    Par 3aychoucha dans le forum C#
    Réponses: 12
    Dernier message: 31/12/2010, 11h27
  3. champs qui s'efface lors d'une requete ajax.
    Par starr dans le forum Langage
    Réponses: 3
    Dernier message: 27/10/2006, 08h33
  4. Réponses: 12
    Dernier message: 21/02/2006, 11h47
  5. [C#] DataGrid qui contient un lien vers une page
    Par Roach dans le forum ASP.NET
    Réponses: 6
    Dernier message: 19/08/2005, 13h54

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo