IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

C++Builder Discussion :

WIA erreur de compilation


Sujet :

C++Builder

  1. #1
    Nouveau membre du Club
    Inscrit en
    août 2003
    Messages
    61
    Détails du profil
    Informations forums :
    Inscription : août 2003
    Messages : 61
    Points : 37
    Points
    37
    Par défaut WIA erreur de compilation
    Bonjour,

    la ligne suivante
    vMSWIACommonDialog = Variant::CreateObject("WIA.CommonDialog");
    me génère l'erreur de compilation :
    EOleSysError avec le message 'Chaine de classe incorrecte'
    le problème se trouve sur WIA.CommonDialog,
    je ne sais pas si quelqu'un a une idée de là où WIA.CommonDialog est définie.

    Merci d'avance,
    cordialement,
    Dibak

  2. #2
    Membre chevronné
    Avatar de DjmSoftware
    Homme Profil pro
    Responsable de compte
    Inscrit en
    mars 2002
    Messages
    977
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Responsable de compte
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2002
    Messages : 977
    Points : 2 053
    Points
    2 053
    Par défaut
    Salut
    réfère toi a ce document de microsoft https://docs.microsoft.com/en-us/pre...t-commondialog


    Je travaille sous la version 10.4 et l'instruction ci-dessous ne provoque pas d'erreur de compilation

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
     
     
    Variant MSWIACommonDialog = Variant::CreateObject("WIA.CommonDialog");
    cdlt
    vous trouverez mes tutoriels à l'adresse suivante: http://djmsoftware.developpez.com/
    je vous en souhaite une excellente lecture ...

    A lire : Les règles du forum

Discussions similaires

  1. Erreur de compilation après modification du Uses
    Par DevelOpeR13 dans le forum Langage
    Réponses: 5
    Dernier message: 30/10/2007, 15h23
  2. Réponses: 2
    Dernier message: 23/09/2003, 15h32
  3. Réponses: 10
    Dernier message: 22/09/2003, 22h58
  4. Réponses: 4
    Dernier message: 27/08/2003, 22h34
  5. Réponses: 2
    Dernier message: 05/03/2003, 00h24

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo