IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Réseau/Web Python Discussion :

[Micropython][ESP8266][API] Problème allumage led requête API [Python 3.X]


Sujet :

Réseau/Web Python

  1. #1
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    juillet 2020
    Messages
    5
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juillet 2020
    Messages : 5
    Points : 7
    Points
    7
    Par défaut [Micropython][ESP8266][API] Problème allumage led requête API
    Bonjour,

    Je travaille actuellement sur un code en micropython avec un esp8266. Je dois faire une requête sur une api, et allumer une led en fonction du résultat de ma requête. J'ai testé l'allumage de ma led avant et tout fonctionne. J'ai également testé ma requête auparavant sur postman et elle fonctionne.

    Problème : Dès que j'ajoute mon code relatif à la requête (import requests, requests.get(), etc...) plus rien ne fonctionne. J'ai l'impression que les deux sont liés mais je ne comprends pas pourquoi.

    J'ai mis le code plus bas. Certaines informations sont confidentielles, je les masque donc.

    Est-ce que quelqu'un sait d'où vient le problème et pourrait m'aider ?

    Par avance, merci

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
     
    from time import sleep
    from machine import Pin
    import network
    import requests
     
    def connectWifi():
        # Connect ESP8266 to Wifi
        station = network.WLAN(network.STA_IF)
     
        if not station.isconnected():
            station.active(True)
            station.connect(CONFIDENTIEL)
     
        if station.isconnected():
            RedLed.value(1)
            return True
     
     
    if __name__ == '__main__':
     
        GreenLed = Pin(5, Pin.OUT)
        RedLed = Pin(4, Pin.OUT)
     
        if connectWifi():
            response = requests.get(CONFIDENTIEL)
     
            for result_item in response.json()["results"]:
                 for item_key, item_value in result_item.items():
                      if item_key == "subject":
                           if not re.match(r"CONFIDENTIEL", item_value):
                                 GreenLed.value(1)

  2. #2
    Expert éminent sénior
    Homme Profil pro
    Architecte technique retraité
    Inscrit en
    juin 2008
    Messages
    17 674
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Architecte technique retraité
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2008
    Messages : 17 674
    Points : 30 504
    Points
    30 504
    Par défaut
    Salut,

    Citation Envoyé par Liobra Voir le message
    Dès que j'ajoute mon code relatif à la requête (import requests, requests.get(), etc...) plus rien ne fonctionne.
    Plus rien ne fonctionne? Normalement, vous devriez avoir un message d'erreur qui donne une idée de la nature de l'erreur.

    Et sans ce message d'erreur, comme pas grand monde peut facilement recopier le code chez lui pour reproduire quoi que ce soit, pas grand monde pourra vous aider.

    - W
    Architectures post-modernes.
    Python sur DVP c'est aussi des FAQs, des cours et tutoriels

  3. #3
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    juillet 2020
    Messages
    5
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juillet 2020
    Messages : 5
    Points : 7
    Points
    7
    Par défaut
    Bonjour wiztricks,

    J'ai fais des recherches sur les librairies et il semblerait que beaucoup de librairies en python ne soit pas pris en charge en micropython (dont requests). A la place, il faut utiliser urequests.
    Merci tout de même pour ton aide !

    Je mets la discussion en résolu

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. problème d'allumage LED par liaison labview RS232
    Par eng_mimi dans le forum LabVIEW
    Réponses: 0
    Dernier message: 27/04/2011, 14h58
  2. Problème avec une requête
    Par snoopy69 dans le forum Débuter
    Réponses: 2
    Dernier message: 20/01/2005, 12h39
  3. problème avec une requête imbriquée
    Par jaimepasteevy dans le forum Langage SQL
    Réponses: 13
    Dernier message: 05/12/2003, 10h29
  4. Problème sur une requête INSERT
    Par Marion dans le forum Langage SQL
    Réponses: 3
    Dernier message: 17/06/2003, 08h45
  5. problème sur une requête!!!!!
    Par Mcgrady_01 dans le forum Langage SQL
    Réponses: 2
    Dernier message: 13/06/2003, 01h17

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo