Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre habitué
    je n'arrive plus à me débarrasser de la prise RJ45 pour démarrer
    Bonjour Tous,
    Mon RPI 4 me fait des misères au démarrage,
    Je n'ai JAMAIS pu le configurer par le HDMI sur une TV malgré toutes les combines trouvé sur le NET, donc je suis passé par un câble RJ45 sur mon routeur,
    J'ai créé un fichier ssh et ai donné une adresse libre de mon réseau dans le fichier cmdline.txt comme l'explique plusieurs site web, AINSI j'ai pu démarrer, faire un "raspi-config" et paramétrer ce Raspberry sous Raspbian Buster
    Il doit ABSOLUMENT tourner avec le WIFI
    MAIS MAINTENANT je n'arrive plus à me débarrasser de la prise RJ45, et ceci au démarrage uniquement, alors que j'ai paramétrer correctement le WIFI puisqu'ensuite tout fonctionne correctement
    IL me faut ABSOLUMENT la RJ45 pour démarrer, et après je peux l'enlever,
    Il me semblai logique de me débarrasser du fichier ssh mais je n'en trouve plus trace ! ! !
    Je suis plutôt novice avec LINUX, donc je sollicite votre aide et conseils sur ce problème,
    merci à tous pour vos conseils à venir,
    Henri

  2. #2
    Rédacteur

    Salut Henri,

    C'est peut-être tout simple, mais sans doute difficile à chercher et à expliquer.
    Si j'étais à côté de toi, j'y arriverais peut-être, car cette partie de Linux n'est pas forcément facile.

    A ta place, j'oublierai le RJ45, si tu n'en n'as pas besoin plus tard.
    Je referais une installation complète avec WiFi seulement, et avec Raspbian sans écran (wpa_supplicant.conf ... etc).
    Il y a plein d'articles là-dessus.
    J'ai toujours fait comme ça et avec PuTTY sous Windows.
    Si tu actives plus tard le HDMI avec un écran, cela fonctionnera aussi.

    Quand j'ai acheté mon RPi 4 à sa sortie, je l'ai fait de cette manière et avec une ancienne TV Sony HDMI. Aucun soucis.

    Ensuite tu pourras essayer ton écran en nous expliquant ce que tu essaies de faire et tes soucis.

    Je n'ai pas trop le temps, mais il y a certainement des personnes qui pourront t'aider en bidouillant tes fichiers de configuration du réseau en sortant la partie non WiFi.

    Cordialement

  3. #3
    Membre habitué
    Je n'ai besoin ni du câble ni du HDM
    Bonjour Joibea et tous,

    Je n'ai pu faire l'installation actuel sur ce premier RPI 4 que par câble RJ45,
    Je n'ai besoin ni du câble ni du HDMI,
    J'utilise d'autre Raspberry RPI 3 et Zero toujours installé grâce au HDMI et toujours utilisé avec WIFI, sans problème jusqu'ici et pourtant je ne suis pas un crack avec Linux
    C'est mon premier RPI 4, et je n'ai pas réussi à le connecter sur le HDMI d'où l'utilisation du RJ45, apparemment les sorties HDMI manquent un peu de pêche(beaucoup de commentaires sur le sujet à travers le Net)
    J'ai fais une installation avec un RPI 3 et ensuite passer la carte sur le RPI 4 : malheureusement sans succès, d'ou en désespoir de cause l'utilisation du RJ45

    Le but de tout ceci est d'utiliser Flask et OPENCV, mais j'en suis encore loin ! ! !

    Merci de votre réponse et je reste à l'écoute,
    Henri

    Petite réflexion : Et si je désactivais le SSH par raspi-config ou par l'interface ? pourrai-je régler le problème ? ? ?

  4. #4
    Membre habitué
    Bonjour,

    Je suis sorti de ce mauvais pas en décommentant une ligne dans le fichier config.txt
    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    Une fois cette ligne dé-commenter, j'ai pu accéder à mon écran TV.
    Je n'ai malheureusement plus le lien www de cette info, un site en Anglais

    Merci à tous,
    Henri

  5. #5
    Rédacteur

    Citation Envoyé par Henri-gp Voir le message

    Je suis sorti de ce mauvais pas en décommentant une ligne dans le fichier config.txt
    Toute la doc:
    https://www.raspberrypi.org/document...g-txt/video.md

    En français par exemple:
    https://raspberry-pi.fr/hdmi-raspber...-pas-solution/

    Dans ces cas, je pense, que ce n'est jamais trop bon de mettre en commentaire.
    En mettant 0 ou 1, c'est clair.
    En mettant en commentaire, il faudrait voir le code source pour décider ce qu'il fait dans ce cas, 0 ou 1.

    Cordialement

  6. #6
    Rédacteur

    Désolé je ne me suis pas connecté hier! Oui, cela arrive, mais rarement!

    Oui, je sais, la discussion est marquée résolue, mais j'ai rajouté mon grain de sel.
    Ces discussion souvent souvent utilisée plus tard par les lecteurs.

    Citation Envoyé par Henri-gp Voir le message

    J'ai fais une installation avec un RPI 3 et ensuite passer la carte sur le RPI 4 : malheureusement sans succès, d'ou en désespoir de cause l'utilisation du RJ45
    Absolument impossible.
    C'est un autre hardware nécessitant des extensions dans le système d'exploitation avec des options lues de fichiers de configuration.