Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Apache Discussion :

Réécriture d'url ne marche pas sur serveur


Sujet :

Apache

  1. #1
    Membre à l'essai
    Réécriture d'url ne marche pas sur serveur
    Bonjour,

    Je rencontre un problème pour la configuration de mon serveur web sous debian. J'ai installer apache2, php et mariadb mais quand j'upload mon site, la réécriture d'url ne semble pas marcher. J'ai bien fais les étapes suivantes :
    • a2enmod rewrite
    • nano /etc/apache2/sites-available/000-default.conf

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
     
    <Directory /var/www/html>
            AllowOverride All
            Require all granted
    </Directory>

    • systemctl restart apache2



    J'ai aussi configuré mon htaccess de la sorte :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
     
    RewriteEngine On
    RewriteCond %{REQUEST_URI} !\.php$ [NC]
    RewriteCond %{REQUEST_URI} [^/]$
    RewriteRule ^([^\.]+)$ $1.php [NC,L]


    Mais peut importe la page sur laquelle je vais, je tombe sur une erreur qui me dit que le fichier est introuvable (p.e: monsite.com/login).

    Ce qui est étrange c'est que j'ai exactement la même configuration du htaccess en local et je ne rencontre pas le problème.

    Je suis à l'écoute de vos idées.

  2. #2
    Membre du Club
    Ca va te faire une belle jambe mais j'ai le meme problème. Je pensais qu'en mettant "AllowOverride All" dans apache2.conf ca marcherait mais c'est pas mieux

  3. #3
    Membre du Club
    Je sais pas si ton problème est exactement le meme que le mien.
    Je voulais que les url sans extensions pointent vers les extensions .php. Exemple monsite.com/login envoi a monsite.com/login.php

    Il a fallu que j'ajoute php aux extensions connues d'apache.

    Il suffit d'ajouter dans la ligne (dans etc/apache2/mods-enabled/mime.conf):
    AddType application/x-httpd-php .php

    Bien sur le module mime doit etre activé.