Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Futur Membre du Club
    Configuration XAMPP pour multiple virtualhost sous ubuntu 19.04
    Bonjour,

    J'utilise Ubuntu 19.04 et XAMPP sur mon ordinateur pour tester et developper plusieurs apps et sites webs.
    Sous ubuntu, XAMPP s'installe sous "/opt/lampp" avec un repertoire "htdocs" et un autre "docs".

    Alors que HTDOCS est clairement utiliser par XAMPP pour son panneau d'affichage des information concernant le serveur, il s'avere que dans le fichier httpd-vhosts.conf, c'est le repertoire DOCS qui est utilise.
    En gros je ne vois pas pourquoi car avec la directive <DIRECTORY> le repertoire root du site peut etre n'importe ou.

    Mon soucis est le suivant:
    j'aimera pouvoir acceder a mes sites locaux en tapant par exemple: http://test1.dev et http://test2.dev

    1. dans mon fichier hosts, j'ai declare 127.0.0.1 pour test1.dev ainsi que pour test2.dev
    2. mon site "test1.dev" est disponible sous "/home/developpement/test1.dev" et pour mon site "test2.dev" il est disponible sous "/home/developpement/test2.dev"
    3. dans mon fichier httpd-vhosts.conf, j'ai declare:
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    <VirtualHost *:80>
        DocumentRoot "/home/developpement/test1.dev"
        ServerName www.test1.dev
        ServerAlias test1.dev
    	<Directory "/home/developpement/test1.dev">
    		Options Indexes FollowSymLinks Includes ExecCGI
            	AllowOverride None
    	        Require all granted
    	</Directory>
        ErrorLog "logs/test1.dev.com-error_log"
        CustomLog "logs/test1.dev.com-access_log" common
    </VirtualHost>


    Dans mon navigateur quand je tape: http://test1.dev, XAMPP me redirige toujours sur localhost/dashboard (donc le repertoire par defaut de XAMPP).

    Pourquoi ?

  2. #2
    Expert éminent sénior
    si "www.test1.dev" fonctionne et non "test1.dev" vous n'avez peut-être pas redémarré le serveur puisque votre configuration à l'air correcte.

###raw>template_hook.ano_emploi###