Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre à l'essai
    Fixer l’erreur : " JavaFX runtime components are missing, and are required to run this application"
    Salut tout le monde !!
    Vous utilisez le jdk11+ et vous souhaitez utiliser JavaFX ??
    Pour éviter des soucis, vous devez régénérer le jdk avec les modules JavaFX intégrés. Pour faire cela, vous devez avoir les fichiers jmods de JavaFX disponible sur le site officiel de JavaFX et bien sûr un JDK 11 ou plus.
    Dès que vous avez ces deux éléments, procédez de la manière suivante :
    1. Extraire le fichier au format .zip contenant les fichiers .jmod à l’endroit voulu.


    2. Copier tous ces fichiers dans le dossier jmods de votre jdk


    3. Définissez la variable d’environnement du dossier « bin » et « jmods » de votre jdk selon l’emplacement de ce dernier. Dans mon cas « d:\jdk12\bin » et « d:\jdk12\jmods ».


    4. Ouvrez l’invite de commande et tapez cette commande : « jlink –add-modules ALL-MODULE-PATH –output monJdk » puis valider par la touche entrer.

    5. Pour finir, vous devez copier le dossier « jmods » du jdk original dans votre jdk personnalisé.
    Merci de laisser vos commentaires!

  2. #2
    Rédacteur/Modérateur

    Bien vu mais je précise juste qu'il faut télécharger les jmods pour la bonne plateforme
    Merci de penser au tag quand une réponse a été apportée à votre question. Aucune réponse ne sera donnée à des messages privés portant sur des questions d'ordre technique. Les forums sont là pour que vous y postiez publiquement vos problèmes.

    suivez mon blog sur Développez.

    Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to produce bigger and better idiots. So far, the universe is winning. ~ Rich Cook

###raw>template_hook.ano_emploi###