Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre à l'essai
    Inscrit en
    mai 2009
    Messages
    16
    Détails du profil
    Informations forums :
    Inscription : mai 2009
    Messages : 16
    Points : 14
    Points
    14

    Par défaut Utilisation Corine Land Cover 2018 en WMTS avec Leaflet

    Bonjour,

    J’utilise les données du Géoportail dans une page Web utilisant Leaflet 1.5.1.
    Je n’ai aucune difficulté avec le plan IGN (GEOGRAPHICALGRIDSYSTEMS.PLANIGN), l’altimétrie (ELEVATION.SLOPES) ou les orthophotos (ORTHOIMAGERY.ORTHOPHOTOS), en revanche, impossible d’utiliser Corine Land Cover 2018 ou 2012 (erreur 403 Forbidden). Les ressources correspondantes sont pourtant bien dans mon contrat.
    Voici mon code :

    Code JavaScript : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
      var clcign = L.tileLayer(
                    'https://wxs.ign.fr/xxxxx/geoportail/wmts?service=WMTS&request=GetTile&version=1.0.0&tilematrixset=PM&tilematrix={z}&tilecol={x}&tilerow={y}&layer=LANDCOVER.CLC18_FR&format=image/png&style=normal',
                    {
                            minZoom:0,
                            maxZoom:18,
                            tileSize:256,
                            opacity:0.4
                    });

    En revanche, pas de soucis pour visualiser le flux sur QGIS.
    Faut-il adapter ce code pour appeler Corine Land Cover ?
    D'avance merci,

    Emilie

  2. #2
    Membre expérimenté
    Profil pro
    Inscrit en
    mai 2009
    Messages
    1 982
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2009
    Messages : 1 982
    Points : 1 661
    Points
    1 661

    Par défaut

    Bonjour,
    Pour ce genre d'utilisation j'adapte l'url de geoportail.gouv.fr
    https://wxs.ign.fr/an7nvfzojv5wa96ds...16&TileRow=713
    le style est different, cela justifie un 403 ?
    Avec style=normal dans la console de Firefox, j'ai un code 400 qui est plus normal.
    Marc

  3. #3
    Membre à l'essai
    Inscrit en
    mai 2009
    Messages
    16
    Détails du profil
    Informations forums :
    Inscription : mai 2009
    Messages : 16
    Points : 14
    Points
    14

    Par défaut

    Bonjour,

    impeccable, c'était bien cela. Merci beaucoup, mon problème est résolu !

    Emilie

  4. #4
    Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mars 2019
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Service public

    Informations forums :
    Inscription : mars 2019
    Messages : 2
    Points : 3
    Points
    3

    Par défaut

    Citation Envoyé par EmilieDB Voir le message
    Bonjour,

    impeccable, c'était bien cela. Merci beaucoup, mon problème est résolu !

    Emilie
    Bonjour,
    Pourriez-vous expliquer ce que vous avez modifié dans votre code pour que finalement ça fonctionne ?
    Je rencontre en effet le même problème.
    Cordialement.
    Didier.

  5. #5
    Membre à l'essai
    Inscrit en
    mai 2009
    Messages
    16
    Détails du profil
    Informations forums :
    Inscription : mai 2009
    Messages : 16
    Points : 14
    Points
    14

    Par défaut

    Bonjour,

    le code qui fonctionne chez moi est le suivant :
    Code JavaScript : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    L.tileLayer(
                    'https://wxs.ign.fr/xxxxx/geoportail/wmts?layer=LANDCOVER.CLC18_FR&style=CORINE%20Land%20Cover%20-%20France%20m%C3%A9tropolitaine&tilematrixset=PM&Service=WMTS&Request=GetTile&Version=1.0.0&Format=image%2Fpng&tilematrixset=PM&tilematrix={z}&tilecol={x}&tilerow={y}',
                    {
                            minZoom:0,
                            maxZoom:18,
                            tileSize:256,
                            opacity:0.4
                    });

    J'ai changé le style.

    Emilie

  6. #6
    Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    mars 2019
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Service public

    Informations forums :
    Inscription : mars 2019
    Messages : 2
    Points : 3
    Points
    3

    Par défaut

    Vous êtes géniale !
    Ca fonctionne.
    Mille mercis.
    Didier

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 4
    Dernier message: 11/05/2006, 16h57
  2. Réponses: 1
    Dernier message: 04/04/2006, 14h28
  3. [EJB]Utilisation d'EJB entité CMP 2.x avec Websphere 6
    Par majenior dans le forum Websphere
    Réponses: 3
    Dernier message: 09/09/2005, 16h32
  4. Réponses: 5
    Dernier message: 06/09/2005, 02h50
  5. Utilisation de la classe List de STL avec wxWidgets
    Par aoyou dans le forum wxWidgets
    Réponses: 7
    Dernier message: 10/03/2005, 17h41

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo