IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

IGN API Géoportail Discussion :

Probleme flux WMS et clé sécurisation sur QGIS


Sujet :

IGN API Géoportail

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Urbaniste
    Inscrit en
    mai 2019
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Tarn (Midi Pyrénées)

    Informations professionnelles :
    Activité : Urbaniste

    Informations forums :
    Inscription : mai 2019
    Messages : 6
    Points : 1
    Points
    1
    Par défaut Probleme flux WMS et clé sécurisation sur QGIS
    Bonjour. L'équipe Geoservices m'a invité à utilser ce forum pour répondre à un problème non résolu pour moi depuis plusieurs semaines. Afin d'afficher sur QGIS version 2.18 (Mac) des fonds SCAN (flux WMS), j'ai obtenu une clé Geoportail. Depuis, malgré des tentatives en http ou https, avec login/pass ou sécurisation avec mon adresse IP, toutes mes tentatives se soldent par "Connection closed". La liste des couches disponibles dans mon contrat apparait bien dans QGIS mais après demande de connexion, rien n'apparait dans ma fenêtre carte. Il semble que le souci soit lié à la sécurisation de la clé. Comment "pratiquement" faire sur QGIS lorsque cette clé est liée à mon IP (correcte dans les paramètres de mon contrat) ? Faut-il modifier le lien fourni (de type "https://wxs.ign.fr/MA_CLE/geoportail/r/wms?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities" ? Ou bien intervenir sur d'autres paramètres dans QGIS (j'ai d'abord tenté avec une authentification login/pass, ça ne marchait pas non plus...). Je précise que je n'utilise pas de proxy, un seul poste (mon IP).
    Grand merci pour votre aide !

  2. #2
    Membre régulier
    Homme Profil pro
    Webmaster
    Inscrit en
    mai 2014
    Messages
    108
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Webmaster

    Informations forums :
    Inscription : mai 2014
    Messages : 108
    Points : 92
    Points
    92
    Par défaut
    Bonjour,

    Je viens d'essayer avec ma clef dans un navigateur web : pas de soucis.

    Il faut essayer de la même façon : le message d'erreur sera plus clair.

    Cordialement,

    Eric

    Nom : test_wms_ign.jpg
Affichages : 799
Taille : 236,0 Ko

  3. #3
    Nouveau Candidat au Club
    Homme Profil pro
    Urbaniste
    Inscrit en
    mai 2019
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Tarn (Midi Pyrénées)

    Informations professionnelles :
    Activité : Urbaniste

    Informations forums :
    Inscription : mai 2019
    Messages : 6
    Points : 1
    Points
    1
    Par défaut
    Bonjour Eric
    sur navigateur web et ma clé, je ne repère pas de message d'erreur non plus...Ce qui confirme mes doutes : le problème est sur QGIS...
    Le message exact est : "Echec du téléchargement des possibilités de cette couche : Connection closed"
    Eric
    Images attachées Images attachées  

  4. #4
    Membre régulier
    Homme Profil pro
    Webmaster
    Inscrit en
    mai 2014
    Messages
    108
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Webmaster

    Informations forums :
    Inscription : mai 2014
    Messages : 108
    Points : 92
    Points
    92
    Par défaut
    Peut-être utile de vérifier ici - si cela n'est pas déjà fait?

    https://geoservices.ign.fr/documenta..._SIG/QGIS.html

  5. #5
    Nouveau Candidat au Club
    Homme Profil pro
    Urbaniste
    Inscrit en
    mai 2019
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Tarn (Midi Pyrénées)

    Informations professionnelles :
    Activité : Urbaniste

    Informations forums :
    Inscription : mai 2019
    Messages : 6
    Points : 1
    Points
    1
    Par défaut
    C'est en effet la première chose faite il y a plusieurs semaines. Les éléments de ce manuel sont trop génériques. "Echec des possibilités" est-ce lié à ma version de QGIS ? Le fait que je sois sur Mac ? Pas de réponses à ces questions sur le guide ...J'utilise d'autres flux WMS (hors IGN) sans souci...

  6. #6
    Candidat au Club
    Femme Profil pro
    Ecologue
    Inscrit en
    septembre 2020
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Corse (Corse)

    Informations professionnelles :
    Activité : Ecologue

    Informations forums :
    Inscription : septembre 2020
    Messages : 3
    Points : 4
    Points
    4
    Par défaut même problème!!
    Citation Envoyé par EricSupparo Voir le message
    C'est en effet la première chose faite il y a plusieurs semaines. Les éléments de ce manuel sont trop génériques. "Echec des possibilités" est-ce lié à ma version de QGIS ? Le fait que je sois sur Mac ? Pas de réponses à ces questions sur le guide ...J'utilise d'autres flux WMS (hors IGN) sans souci...
    Bonjour!
    Avez vous résolu votre problème?...car je rencontre exactement le même!!!
    Merci de votre aide!!

    Cécile

  7. #7
    Nouveau Candidat au Club
    Homme Profil pro
    Urbaniste
    Inscrit en
    mai 2019
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Tarn (Midi Pyrénées)

    Informations professionnelles :
    Activité : Urbaniste

    Informations forums :
    Inscription : mai 2019
    Messages : 6
    Points : 1
    Points
    1
    Par défaut
    Citation Envoyé par CecileBillard Voir le message
    Bonjour!
    Avez vous résolu votre problème?...car je rencontre exactement le même!!!
    Merci de votre aide!!

    Cécile
    Bonjour,
    problème non résolu, désolé ! Depuis, je suis passé "à autre chose", vu le blocage... Mais je suis à peu près certain que le souci vient de la version de QGIS et la gestion du flux IGN sur Mac.

  8. #8
    Candidat au Club
    Femme Profil pro
    Ecologue
    Inscrit en
    septembre 2020
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Corse (Corse)

    Informations professionnelles :
    Activité : Ecologue

    Informations forums :
    Inscription : septembre 2020
    Messages : 3
    Points : 4
    Points
    4
    Par défaut Merci beaucoup!
    Merci beaucoup Eric pour votre réponse si rapide!!
    Je pensais mettre à jour ma version de QGIS, je suis en 2.18.15 et toujours sur mac...mais cela ne solutionnera certainement pas le problème!

    Merci encore et bonne journée!
    Cécile

  9. #9
    Nouveau Candidat au Club
    Homme Profil pro
    Urbaniste
    Inscrit en
    mai 2019
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Tarn (Midi Pyrénées)

    Informations professionnelles :
    Activité : Urbaniste

    Informations forums :
    Inscription : mai 2019
    Messages : 6
    Points : 1
    Points
    1
    Par défaut
    Citation Envoyé par CecileBillard Voir le message
    Merci beaucoup Eric pour votre réponse si rapide!!
    Je pensais mettre à jour ma version de QGIS, je suis en 2.18.15 et toujours sur mac...mais cela ne solutionnera certainement pas le problème!

    Merci encore et bonne journée!
    Cécile
    Bonjour Cécile, mettre à jour QGIS est sans doute la seule solution potentielle... Quelle version de Mac OS X avez-vous ?

  10. #10
    Candidat au Club
    Femme Profil pro
    Ecologue
    Inscrit en
    septembre 2020
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Corse (Corse)

    Informations professionnelles :
    Activité : Ecologue

    Informations forums :
    Inscription : septembre 2020
    Messages : 3
    Points : 4
    Points
    4
    Par défaut ;-)
    Bonne question! Je viens de vérifier: MacOS High Sierra!

  11. #11
    Nouveau Candidat au Club
    Homme Profil pro
    Urbaniste
    Inscrit en
    mai 2019
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Tarn (Midi Pyrénées)

    Informations professionnelles :
    Activité : Urbaniste

    Informations forums :
    Inscription : mai 2019
    Messages : 6
    Points : 1
    Points
    1
    Par défaut
    Citation Envoyé par CecileBillard Voir le message
    Bonne question! Je viens de vérifier: MacOS High Sierra!
    Vous avez donc tout intérêt à mettre à jour QGIS. Merci de me tenir informé si la manip vous permet d'activer ce flux IGN ! Bonne journée.

Discussions similaires

  1. accès au flux wms sur autocad map
    Par MickaelSuire dans le forum IGN API Géoportail
    Réponses: 13
    Dernier message: 23/05/2019, 10h57
  2. affichage flux WMS/WMTS du Geoportail dans Qgis
    Par cecilr dans le forum IGN API Géoportail
    Réponses: 1
    Dernier message: 15/02/2019, 21h55
  3. Mauvaise qualité du flux WMS sous QGis du Scan Dep
    Par AGo21 dans le forum IGN API Géoportail
    Réponses: 2
    Dernier message: 17/10/2018, 11h11
  4. Probleme identification flux wms arcgis/geoportail
    Par r.fagot dans le forum IGN API Géoportail
    Réponses: 6
    Dernier message: 13/07/2018, 21h06
  5. Charger WFS de l´IGN sur QGIS - sécurisation
    Par gaskue dans le forum IGN API Géoportail
    Réponses: 8
    Dernier message: 14/02/2018, 11h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo