Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2014
    Messages
    357
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : novembre 2014
    Messages : 357
    Points : 44
    Points
    44

    Par défaut Cherche driver linux : TNT5004

    Bonsoir,

    Je cherche un driver linux (debian) pour une carte PCI-GPIB numéro de série 188513E-01L.

    D'après ce que j'ai pu lire, le driver serait TNT5004 plutôt que TNT4882.

    La norme est le GPIB.

    Je me suis déjà servis du projet suivant : https://linux-gpib.sourceforge.io/

    J'ai compilé et installé linux-kernel-gpib et linux-user-gpib.

    J'ai essayé de me servir des modules tnt4882 et agilent sans succès de détection avec lspci et ibtest.

    Si vous-avez eu une expérience avec des cartes propriétaire NAtional Instrument sous Linux, n'hésitez pas.

    Je cherche le driver TNT5004.

    Merci d'avance.

  2. #2
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2014
    Messages
    357
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : novembre 2014
    Messages : 357
    Points : 44
    Points
    44

    Par défaut

    J'ai continué à chercher.

    Un projet NI-488.2 existe pour linux mais à adapter à Debian, est-ce que c'est possible ?

    http://www.ni.com/download/ni-488.2---linux/6902/en/

    Pourriez-vous jeter un coup d'oeil ?

    Merci d'avance

  3. #3
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2014
    Messages
    357
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : novembre 2014
    Messages : 357
    Points : 44
    Points
    44

    Par défaut

    A priori elle n'est pas reconnu.

    Il faut compiler le driver et le charger avec modprobe.

    A priori dedans, il y a un binaire qui permet de recompiler les drivers en fonction du noyau que tu possède.

    Une fois le fichier .iso monté, tu executes " ./INSTALL --nodeps "

    Ensuite, executer " sudo ./updateNIDrivers ". Ici je suis coincé car l'executable ne voit pas les kernel sources. Je ne vois pas comment avancer sur ce point !

    https://framadrop.org/r/i7CdsxGMVo#5...1KGU1O552CtDU=

    As root, run "/usr/local/bin/updateNIDrivers". By default, the
    updateNIDrivers utility rebuilds the driver for the currently
    running kernel using the kernel sources and copies it to the
    appropriate location.

  4. #4
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2014
    Messages
    357
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : novembre 2014
    Messages : 357
    Points : 44
    Points
    44

    Par défaut

    J'ai avancé.

    J'ai pu lancer l'installer de mon fichier .iso.

    Mon souci est qu'au moment de recompiler les drivers avec la commande updateNIdriver, je suis coincé sur la partie programme suivante :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    # This is needed for the ./configure script, when it gets run
    if ! withVersioning nikalGetRequestedKernelSourcesDir; then
       error "Error locating kernel sources for the requested kernel version (${kernelVersion})."
       if [ "${promptUser}" = "0" ]; then
          echoUsage
       fi
       exit 1
    fi
    Le programme ci-dessus se trouve ligne 134 du fichier updateNIdriver : https://debian-facile.org/paste-BABC841E70

    Fait appel à la fonction nikalGetRequestedKernelSourcesDir() du fichier installerUtility.sh : https://debian-facile.org/paste-9CAA1DEBCB

    J'ai toujours mon erreur alors que j'ai configuré mes 3 variables d'environnements.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
    export INSTALL_MOD_PATH=""
    export KERNELTARGET=4.19.0-0.bpo.2-amd64
    export KERNELHEADERS=$KERNELHEADERS:$INSTALL_MOD_PATH/lib/modules/$KERNELTARGET/...

  5. #5
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2014
    Messages
    357
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : novembre 2014
    Messages : 357
    Points : 44
    Points
    44

    Par défaut

    J'ai encore avancé mais cette fois pas sur que je trouve la solution.

    zcat /boot/symvers-4.19.0-0.bpo.2-amd64.gz > Module.symvers

    Pas de trace en /boot du fichier symvers-4.19.0-0.bpo.2-amd64.gz sous debian stretch

  6. #6
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    novembre 2014
    Messages
    357
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : novembre 2014
    Messages : 357
    Points : 44
    Points
    44

    Par défaut

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    /usr/src/linux-headers-4.19.0-0.bpo.2-amd64# make cloneconfig
    /usr/src/linux-headers-4.19.0-0.bpo.2-common/scripts/Makefile.build:45: /usr/src/linux-headers-4.19.0-0.bpo.2-common/scripts/basic/Makefile: Aucun fichier ou dossier de ce type
    make[3]: *** Aucune règle pour fabriquer la cible « /usr/src/linux-headers-4.19.0-0.bpo.2-common/scripts/basic/Makefile ». Arrêt.
    make[2]: *** [/usr/src/linux-headers-4.19.0-0.bpo.2-common/Makefile:465: scripts_basic] Error 2
    make[1]: *** [Makefile:146: sub-make] Error 2
    make: *** [Makefile:8: all] Error 2

Discussions similaires

  1. cherche driver linux pour carte graphique
    Par blue dans le forum Matériel
    Réponses: 8
    Dernier message: 15/12/2006, 15h50
  2. Cherche driver carte graphique ati radeon igp 320m
    Par piogo113 dans le forum Composants
    Réponses: 5
    Dernier message: 11/12/2006, 23h59
  3. [outil] cherche outil linux pour xml/xsl avec pretty print
    Par Merfolk dans le forum XML/XSL et SOAP
    Réponses: 4
    Dernier message: 26/07/2006, 17h48
  4. Cherche Driver JDBC pour MySQL 5.0
    Par mosstu126 dans le forum SQL Procédural
    Réponses: 3
    Dernier message: 14/02/2006, 00h36
  5. Cherche cours Linux pour débutant
    Par Le Pharaon dans le forum Applications et environnements graphiques
    Réponses: 11
    Dernier message: 24/11/2005, 09h52

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo