Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2017
    Messages
    62
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 19
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Arts - Culture

    Informations forums :
    Inscription : mars 2017
    Messages : 62
    Points : 41
    Points
    41

    Par défaut Impossible de se connecter avec SSH

    Bonjour à tous,

    J'ai une Raspberry 3 model B avec Raspbian 9 Stretch installé et j'essaye de me connecter à SSH avec un windows 10 (Putty) et un Ubuntu 18.04 LTS.

    J'ai bien suivi les tutoriels d'installation du client ssh sur la Pi (autoriser la connexion ssh, sudo apt-get install openssh-server/client).
    Le processus ssh fonctionne bien car j'ai :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    pi@josephh_raspberrypi:~ $ sudo service ssh status
    ...
    Active: active (running)
    ...
    Je peux me connecter à ma Pi depuis la Pi avec : Et ça marche !

    Puis sur windows, une requette ping à l'adresse IP de la PI arrive bien à destination.
    Ensuite, j'ai la même erreur sur Putty et sur Linux lorsque je me connecte avec ssh sur le port 22 : "Network error, connection timed out"

    J'ai regardé sur pas mal de forums sur internet et je n'ai pas trouvé ma solution, je ne sais plus quoi essayer.

    Merci pour votre aide

  2. #2
    Rédacteur


    Homme Profil pro
    Instituteur retraité
    Inscrit en
    novembre 2015
    Messages
    703
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Instituteur retraité
    Secteur : Enseignement

    Informations forums :
    Inscription : novembre 2015
    Messages : 703
    Points : 3 508
    Points
    3 508
    Billets dans le blog
    1

    Par défaut

    Bonjour,

    Il y a normalement un serveur ssh installé par défaut dans Raspbian Strectch, donc rien à installer en plus. Certains tutos sont anciens et datent de Jessie ou avant.

    En revanche il faut activer l'interface ssh dans la configuration de la Pi.

    Ligne "Interfacing options", puis cliquer sur la ligne SSH pour activer/désactiver
    Plus on apprend, plus on découvre que ce que l'on sait est insignifiant face à tout ce que l'on ne sait pas.
    Retrouvez la liste de mes articles et tutoriels sur la sauvegarde-restauration, les distributions éducatives, le système Linux et la Raspberry pi en cliquant sur ce lien.

  3. #3
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2017
    Messages
    62
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 19
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Arts - Culture

    Informations forums :
    Inscription : mars 2017
    Messages : 62
    Points : 41
    Points
    41

    Par défaut

    Bonjour,

    J'ai bien activé le service ssh avec raspi-config.

    J'ai :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    ● ssh.service - OpenBSD Secure Shell server
    Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
    Active: active (running) since Sun 2018-11-11 00:55:56 CET; 18h ago
    Process: 520 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
    Main PID: 553 (sshd)
     CGroup: /system.slice/ssh.service
           └─553 /usr/sbin/sshd -D
    
    nov. 11 00:55:55 josephh_raspberrypi systemd[1]: Starting OpenBSD Secure Shell server...
    nov. 11 00:55:56 josephh_raspberrypi sshd[553]: Server listening on 0.0.0.0 port 5555.
    nov. 11 00:55:56 josephh_raspberrypi sshd[553]: Server listening on :: port 5555.
    nov. 11 00:55:56 josephh_raspberrypi systemd[1]: Started OpenBSD Secure Shell server.
    nov. 11 00:55:56 josephh_raspberrypi sshd[553]: Server listening on 0.0.0.0 port 80.
    nov. 11 00:55:56 josephh_raspberrypi sshd[553]: Server listening on :: port 80.
    nov. 11 00:55:56 josephh_raspberrypi sshd[553]: Server listening on 0.0.0.0 port 22.
    nov. 11 00:55:56 josephh_raspberrypi sshd[553]: Server listening on :: port 22.

  4. #4
    Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2017
    Messages
    62
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 19
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Arts - Culture

    Informations forums :
    Inscription : mars 2017
    Messages : 62
    Points : 41
    Points
    41

    Par défaut

    Bonjour, j'ai résolu mon problème sur un autre forum :

    https://forum.raspbian-france.fr/t/r...-avec-ssh/6853

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Impossible de se connecter en SSH
    Par SimoX1 dans le forum Administration système
    Réponses: 6
    Dernier message: 14/06/2010, 11h46
  2. Impossible de se connecter avec Wifi
    Par khongo agon dans le forum Windows XP
    Réponses: 10
    Dernier message: 13/01/2009, 13h12
  3. Réponses: 0
    Dernier message: 15/08/2007, 17h36
  4. impossible de se connecter avec nouveau modem routeur
    Par vins25 dans le forum Dépannage et Assistance
    Réponses: 3
    Dernier message: 03/03/2006, 01h41
  5. Impossible de se connecter avec aMSN
    Par Blowih dans le forum Applications et environnements graphiques
    Réponses: 5
    Dernier message: 29/07/2004, 15h51

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo