Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre à l'essai
    Homme Profil pro
    Enseignant Chercheur
    Inscrit en
    mars 2017
    Messages
    47
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Enseignant Chercheur

    Informations forums :
    Inscription : mars 2017
    Messages : 47
    Points : 14
    Points
    14

    Par défaut Problème d'accès partagé (résolu)

    Bonjour

    J'ai récemment créé une "application" avec Access pour renseigner des bases et créer des rapports et requêtes. L'application est formée de :
    • Une base "commune" qui comporte des tables qui sont liées dans les ...
    • ... 10 autres bases, qui utilisent les données des tables de la base commune (ces tables communes apparaissent dans chaque base avec une petite flèche)

    J'ai testé l'utilisation (formulaires, requêtes, synthèses) lorsque tous ces fichiers étaient sur mon disque dur : ça fonctionnait. J'ai Access dans Office Pro Plus 2016.
    J'ai ensuite copié ces fichiers sur un répertoire réseau partagé, afin qu'ils soient accessibles aux utilisateurs. J'ai testé avec mon PC, ça fonctionnait.

    Mais lorsque les utilisateurs veulent utiliser leurs bases, il semble qu'ils n'ont pas accès au fichier "commun" ce qui fait planter l'utilisation. Par exemple, un ensemble de valeurs doit s'afficher dans une liste de choix d'un formulaire et ces valeurs sont dans une table du fichier commun : chez moi, la liste de choix se crée bien, chez eux elle reste vide et n'est pas utilisable. Le formulaire plante puisqu'il n'y a aucun choix sélectionné.

    Ils ont la même version d'Office que moi, donc le problème ne vient pas de là.

    Avez-vous une idée de ce qui ne va pas ?
    Merci de votre aide.

  2. #2
    Membre habitué
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    février 2013
    Messages
    95
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Haut Rhin (Alsace)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Industrie

    Informations forums :
    Inscription : février 2013
    Messages : 95
    Points : 135
    Points
    135

    Par défaut

    Salut.
    sur les postes clients les tables attachées sont t elles biens routées au bon endroit ?
    A +

  3. #3
    Membre à l'essai
    Homme Profil pro
    Enseignant Chercheur
    Inscrit en
    mars 2017
    Messages
    47
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Enseignant Chercheur

    Informations forums :
    Inscription : mars 2017
    Messages : 47
    Points : 14
    Points
    14

    Par défaut

    Je ne comprends pas la question : comment puis-je vérifier ça ?

  4. #4
    Membre habitué
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    février 2013
    Messages
    95
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Haut Rhin (Alsace)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Industrie

    Informations forums :
    Inscription : février 2013
    Messages : 95
    Points : 135
    Points
    135

    Par défaut

    Alors...
    tu vas sur un poste client.
    Tu ouvres le frontal en appuyant sur le touche shift et en double cliquant en même temps sur le frontal.
    ensuite... ( sous A2010 ) onglet "données externe".... "Gestionnaire des tables liées".... "selectionner tout" mettre la coche "toujours demander un nouvel emplacement" ...
    ensuite tu root vers la dorsale ( BDD Réseau)...
    tu fermes tout et tu relances le frontal sur le poste client.
    Voila
    ++

  5. #5
    Membre à l'essai
    Homme Profil pro
    Enseignant Chercheur
    Inscrit en
    mars 2017
    Messages
    47
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Enseignant Chercheur

    Informations forums :
    Inscription : mars 2017
    Messages : 47
    Points : 14
    Points
    14

    Par défaut

    Citation Envoyé par james68 Voir le message
    Alors...
    tu vas sur un poste client.
    Tu ouvres le frontal en appuyant sur le touche shift et en double cliquant en même temps sur le frontal.
    ensuite... ( sous A2010 ) onglet "données externe".... "Gestionnaire des tables liées".... "selectionner tout" mettre la coche "toujours demander un nouvel emplacement" ...
    ensuite tu root vers la dorsale ( BDD Réseau)...
    tu fermes tout et tu relances le frontal sur le poste client.
    Voila
    ++
    Alors... Merci. Mais j'ai du mal...

    "Tu ouvres le frontal en appuyant sur le touche shift et en double cliquant en même temps sur le frontal."
    Le frontal : c'est la requête ? une table ? laquelle ? Si tu parles de la base de l'utilisateur, lorsque je double clique dessus avec shift enfoncée, ça ne l'ouvre pas : ça sélectionne les fichiers au dessus dans le gestionnaire de fichiers.

    Ensuite, j'ai vu les menus dont tu parles, mais ... "tu root vers la dorsale ( BDD Réseau)" : je ne comprends pas ce que c'est.

    Pour info, je suis sous Windows 10.

  6. #6
    Membre habitué
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    février 2013
    Messages
    95
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Haut Rhin (Alsace)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Industrie

    Informations forums :
    Inscription : février 2013
    Messages : 95
    Points : 135
    Points
    135

    Par défaut

    dans le fichier .accdb ( non compilé) ou .accde (compilé), là ou tu as tout tes formulaire, requetes etc...
    il faut que tu fasses la jonction par rapport a ta base de données ( là ou se trouvent les données ) .
    Tu devrais arriver sur ce type de fenêtre.
    Nom : Sans titre.png
Affichages : 35
Taille : 242,8 Ko
    ensuite tu cliques sur OK et tu lui donnes le chemin d'acces au fichier ou se trouvent les données.
    ok ?

  7. #7
    Membre à l'essai
    Homme Profil pro
    Enseignant Chercheur
    Inscrit en
    mars 2017
    Messages
    47
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Enseignant Chercheur

    Informations forums :
    Inscription : mars 2017
    Messages : 47
    Points : 14
    Points
    14

    Par défaut

    OK, ça fonctionne, merci

    J'ai d'abord testé en faisant ces modifs depuis mon poste. Mais un autre testeur avait toujours le problème.
    J'ai ensuite demandé à chacun de faire la modif sur son fichier et là ça marche.

    Du coup je me pose la question de comprendre pourquoi il faut que ce soit l'utilisateur lui-même qui fasse cette configuration. C'est une config locale à l'utilisateur et pas au fichier ? Si un autre utilisateur doit utiliser un fichier (pour lequel un premier utilisateur a fait la manip), devra-t-il aussi faire cette manip ? Et est-ce que ça écrasera celle du précédent utilisateur?

    Désolé pour toutes ces questions, mais je dois m'assurer du confort d'utilisation de mes collègues...

  8. #8
    Membre habitué
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    février 2013
    Messages
    95
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Haut Rhin (Alsace)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Industrie

    Informations forums :
    Inscription : février 2013
    Messages : 95
    Points : 135
    Points
    135

    Par défaut

    Dans ton frontal de developpement ( from,requete ) avant de le transmettre au utilisateurs il faut que tu fasses cette manipulation.
    ensuite seullment tu déploies la nouvelle version sur les postes clients.
    elle sera automatiquement intégrée et les utilisateurs n'auront rien a faire.
    D'autre part je te conseille de travailler en local sur ton poste sur ton fichier .accdb...
    A la fin de ton développement ( qd tout est OK ) tu fais ton root réseau vers la base de données ( cf.au dessus) , ensuite tu compiles en .accde
    et tu déploies sur les postes client le nouveau fichier .accde ( il n'auront pas acces a ton code et ne pourront pas modifier les forms , les etats etc )

    En espérant avoir été clair , sinon tu reviens ... lol...

    D'autre part il est préférable de créer une macro nommée "AUTOEXEC" , ou sur la première ligne tu lui demandes d'ouvrir un formulaire MENU.
    voila voila...
    PS : ne pas oublier de mettre en Résolu si ok pour toi..... merci

  9. #9
    Membre à l'essai
    Homme Profil pro
    Enseignant Chercheur
    Inscrit en
    mars 2017
    Messages
    47
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Enseignant Chercheur

    Informations forums :
    Inscription : mars 2017
    Messages : 47
    Points : 14
    Points
    14

    Par défaut

    Merci de ton aide !
    Si j'ai d'autres problèmes, je créerai une autre discussion.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Problème d'accès partage
    Par menardb dans le forum Windows 8
    Réponses: 1
    Dernier message: 10/10/2014, 16h06
  2. Réponses: 3
    Dernier message: 28/10/2008, 13h20
  3. Probléme d'accé à un répertoire partagé
    Par koKoTis dans le forum Windows XP
    Réponses: 3
    Dernier message: 09/09/2006, 19h25
  4. Problème d'accès à un dossier partagé / accès poste
    Par TicTacToe dans le forum Administration
    Réponses: 1
    Dernier message: 08/08/2006, 14h13
  5. problème d'accés sur des fichiers partagés
    Par prefna dans le forum Windows Serveur
    Réponses: 1
    Dernier message: 06/08/2006, 16h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo