Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    Homme Profil pro
    Webdesigner
    Inscrit en
    décembre 2017
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 79
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Webdesigner
    Secteur : Enseignement

    Informations forums :
    Inscription : décembre 2017
    Messages : 1
    Points : 2
    Points
    2

    Par défaut Décrochage du programme gérant 2 moteurs avec IRremote et L293D

    Bonjour a tous.

    Nouveau sur ce forum je m'adresse à vous pour vos exposer mon problème.

    Je viens de réaliser un petit robot araignée (mécanisme de Klann) utilisant 2 moteurs (3/5V) pilotés par un "L293D" et "IRremote.h". Jusqu'ici tout fonctionne à merveille.
    J'ai joint une routine switch/case pour appeler de fonctions faisant avancer, reculer, etc... l'araignée.
    L'alimentation est assurée par une alimentation externe (9V).
    Ça fonctionne... de temps à autre les commandes ne répondent plus et l'engin se plante.
    Avec la sortie série on voit les codes HEX envoyés et subitement un décrochage, sortie de la boucle loop()... plantage.
    J'ai inclus un filtre résistance/capacité sur l'alim 5V de la diode IR.
    Si je déconnecte les moteurs les codes HEX s'affichent dans le monteurs sans planter!

    Aurait quelqu'un par mi les membres de ce forum une idée de ce qui peur se passer.

    Mille merci pour toute suggestion et aide !

  2. #2
    Nouveau Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    février 2014
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 61
    Localisation : France, Charente Maritime (Poitou Charente)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Santé

    Informations forums :
    Inscription : février 2014
    Messages : 1
    Points : 1
    Points
    1

    Par défaut IRremote

    Il semblerait qu'il y un probléme de compatibiliyé entre les librairies de robot et irremote pour la lecture des codes IR...
    Je suis dans le cas de la lecture des codes IR et je cherche des solutions

Discussions similaires

  1. Réponses: 2
    Dernier message: 06/05/2015, 09h45
  2. Réponses: 5
    Dernier message: 24/04/2015, 10h00
  3. Gérer un moteur avec un 6809
    Par copro dans le forum Autres architectures
    Réponses: 5
    Dernier message: 05/04/2004, 15h23
  4. Réponses: 2
    Dernier message: 14/01/2004, 17h21

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo