1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    juillet 2017
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Distribution

    Informations forums :
    Inscription : juillet 2017
    Messages : 1
    Points : 1
    Points
    1

    Par défaut Un processus inconnus sature le CPU de mon serveur web

    Bonjour.

    J'administre un serveur web qui depuis peu utilise beaucoup trop de ressource CPU, ce qui est bien évidemment anormal sur cette machine.
    Je constate qu'un utilisateur "www-data" (donc pour moi les sites internet de cette machine) utilise une commande "dev", ce qui ne me parle absolument pas. Cela pourrait très bien s'apparenter à une attaque, je constate qu'en stoppant apache le processus n'existe plus non plus. Néamoins je n'en ai en fait aucune idée de ce qui est en train de se produire.

    Nom : top.png
Affichages : 35
Taille : 2,6 Ko

    Quelqu'un connais t-il cette commande "dev"? Quel serait selon vous la meilleure solution pour empecher ce scénario de perdurer?
    Merci d'avance pour vos réponses.

  2. #2
    Membre confirmé Avatar de Inazo
    Profil pro
    Gérant - société de développement web
    Inscrit en
    avril 2007
    Messages
    400
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Gérant - société de développement web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : avril 2007
    Messages : 400
    Points : 559
    Points
    559

    Par défaut

    Bonjour,

    Alors si tu stoppes Apache et que la commande disparaît c'est normal je dirais car elle est lancé avec l'utilisateur d'apache.

    Par contre la commande dev en effet je ne voie pas non plus car contre tu peux faire deux choses :

    1 - : si tu as plusieurs site web désactive les vhost 1 à 1 pour voir quel vhost serait responsable
    2 - : regarde si il n'y a pas un alias à la commande "dev" (https://doc.ubuntu-fr.org/alias)

    Tu peux aussi tenter un "man dev" en console pour voir si il répond quelque chose.

    @+

Discussions similaires

  1. Réponses: 4
    Dernier message: 02/02/2011, 19h38
  2. Comment savoir si quelqu'un utilise mon serveur web
    Par Djo00 dans le forum Administration système
    Réponses: 5
    Dernier message: 24/04/2007, 11h36
  3. L'intégrité des fichiers de mon serveur web
    Par emiplegie dans le forum Sécurité
    Réponses: 5
    Dernier message: 23/01/2007, 15h38
  4. Accéder à mon serveur web depuis l'extérieur
    Par wisstr dans le forum Hardware
    Réponses: 2
    Dernier message: 22/10/2006, 05h50
  5. Réponses: 7
    Dernier message: 03/12/2004, 12h26

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo