Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre régulier
    Homme Profil pro
    test
    Inscrit en
    mai 2016
    Messages
    251
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : Algérie

    Informations professionnelles :
    Activité : test
    Secteur : Boutique - Magasin

    Informations forums :
    Inscription : mai 2016
    Messages : 251
    Points : 109
    Points
    109

    Par défaut Installation Postgres9.6 centos

    Bonjour

    je viens d'installer pour la première fois postgresql sur un système centos6-8

    la version installer est 9.6

    En connectant a travers PSQL je viens d'avoir cette alerte (voir imprime écran) en disant qu'il existe une deuxième version ancienne c'est le 8.4

    donc est ce que je doit désinstaller cette version pour que le système soit fonctionnelle et qu'elle serai l'impact si j'aurai deux version postgres sur la même système

    merci de vos aides
    Images attachées Images attachées  

  2. #2
    Futur Membre du Club
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    mai 2017
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2017
    Messages : 8
    Points : 8
    Points
    8

    Par défaut

    Comment avez-vous installé PostgreSQL ? Notamment, est-ce bien via les dépôts de la communauté (yum.postgresql.org) ?

    L'outil client psql est en version 8.4 (totalement périmée), et le serveur PostgreSQL lui-même en 9.6. psql avertit ici qu'il ne garantit pas la compatibilité (dans l'autre sens ça marcherait).

    J'imagine que le client 8.4.20 provient de l'installation standard de CentOS 6, et le serveur est issu du dépôt PGDG. Si c'est bien cela il devrait suffire de mettre à jour le client :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    sudo yum remove postgresql.x86_64 
    sudo yum install postgresql96

Discussions similaires

  1. installation maarch sur centos
    Par Paula15 dans le forum GED
    Réponses: 0
    Dernier message: 12/08/2011, 19h43
  2. installation phpmyadmin sur centos
    Par minette28 dans le forum phpMyAdmin
    Réponses: 0
    Dernier message: 30/05/2011, 11h25
  3. installer Texmaker sous Centos
    Par jane40 dans le forum Autres
    Réponses: 14
    Dernier message: 29/04/2011, 17h05
  4. installation proftpd sur CentOS 5
    Par jocqfd dans le forum RedHat / CentOS / Fedora
    Réponses: 2
    Dernier message: 31/01/2010, 23h12
  5. installer red5 sur CentOS
    Par kiamaru dans le forum Applications et environnements graphiques
    Réponses: 0
    Dernier message: 01/11/2008, 06h57

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo