Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

HyperFileSQL Discussion :

Récupération du contenu d'un champ table en windev


Sujet :

HyperFileSQL

  1. #1
    Nouveau membre du Club
    Récupération du contenu d'un champ table en windev
    salut les amis

    Je cherche à récuperer le contenu de mon champ table est l'enregistrer dans un fichier Hyperfile. Mais ce que je constate est que mon boucle n'arrive pas à se positionner à la ligne suivante de ma table. L'enregistrement ne récupère que la première ligne de la table. Voici à mon niveau ce que j'ai mis comme instruction:

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    i est un entier=0
     
    TANTQUE i<=TableOccurrence(Table_Etudiant)
    	Etudiant.ageetud=COL_Age
            Etudiant.Codp=COL_Promotion
    	Etudiant.matr=COL_Matricule
    	Etudiant.nom=COL_Nom
    	Etudiant.postn=COL_Post_nom
    	Etudiant.sexe=COL_Sexe
    	HAjoute(Etudiant)
    	i++
    FIN


    s'il y a une façons de faire, je besoin de vos interventions

  2. #2
    Membre expérimenté
    TableSelectPlus

  3. #3
    Expert éminent
    J'aurais plutôt dit tableselect.
    Ou l'utilisation de [i].
    Commencez toujours appuyer sur la touche F1 et puis n'hésitez à passer par un moteur de recherche...
    Le forum est fait pour répondre aux questions : pas la peine de me les envoyer par MP. Merci.

    Make it real not fantasy.

  4. #4
    Nouveau membre du Club
    votre réponse
    c'est vraiment intéressent cette instruction "TableSelectPlus" mais apparement le boucle est toujours bloqué sur la première ligne, si y a mayen de me fournir un exemple

  5. #5
    Membre expérimenté
    Il y a un exemple dans l'aide ...

  6. #6
    Membre éprouvé
    Bonsoir
    Je ferrais plutôt :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    i est un entier=0
    
    TANTQUE i<=TableOccurrence(Table_Etudiant)
    i++
    Etudiant.ageetud=COL_Age[i]
    
    ......
    
    
    HAjoute(Etudiant)
    FIN
    

  7. #7
    Membre expert
    Bonjour,

    Une autre façon de faire :

    Citation Envoyé par samson Voir le message

    POUR TOUT iIndice DE Table_Etudiant
    Etudiant.ageetud=COL_Age[iIndice]
    ...
    HAjoute(Etudiant)
    FIN

  8. #8
    Nouveau membre du Club
    Confirmation
    Merci Yusef, j'ai apprécie votre code, je l'ai essayé et ça passé, mes remerciement encore à toi.

  9. #9
    Membre éprouvé
    Je suis content de vous avoir aidé.
    Je n'ai fais que rectifier un peu votre code.
    Les autres réponses des participants au sujet sont aussi valables.
    Et surtout, que vous soyez revenu le dire, c'est appréciable.
    Bon dev.

###raw>template_hook.ano_emploi###