IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre averti Avatar de GyZmoO
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    février 2006
    Messages
    428
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : février 2006
    Messages : 428
    Points : 301
    Points
    301
    Par défaut [DEBUTANT][Probleme]java lang UnsupportedClassVersionError
    Salut a tous !

    J'ai encore un problème tout est dans le titre, j'obtiens cette erreur quand j'essaye de lancer mon programme composé de deux classes

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
     
    import java.awt.*;
    import javax.swing.*;
     
     
    public class GuiPrincipale extends JFrame {
     
        JFrame frame;
        JButton recherche;
        JPanel pane;
     
        public GuiPrincipale(){
     
            this.frame = new JFrame("test");
            this.recherche = new JButton("rechercher");
            this.pane = new JPanel();
     
            pane.setLayout(new GridLayout(1,1));
            pane.add(recherche);
     
            frame.getContentPane().setLayout(new GridLayout(1,1));
            frame.getContentPane().add(pane);
     
            frame.setVisible(true);
     
     
        }
     
     
     
    }
    et ma classe de test
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
     
    public class Go {
     
        public static void main(String[] args) {
     
     
            GuiPrincipale plop = new GuiPrincipale();
     
     
        }
     
    }
    je précise que je bosse sous eclipse et donc qd j'essaye de run le programme ---->

    java.lang.UnsupportedClassVersionError: Go (Unsupported major.minor version 49.0)
    at java.lang.ClassLoader.defineClass0(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    Exception in thread "main"
    Si quelqu'un peut m'expliquer, ça serait sympa.

    PS : j'ai cherché dans le forum pour voir si le sujet n'avait pas été traité, et en fait soit je sais pas chercher (ce qui est fort possible) soit le sujet n'a pas encore été traité

    Merci d'avance !
    define: Programmeur : Celui qui résout un problème que vous n'aviez pas, d'une façon que vous ne comprenez pas.

  2. #2
    Expert éminent

    Profil pro
    Fabricant et casseur d'avions
    Inscrit en
    avril 2004
    Messages
    3 731
    Détails du profil
    Informations personnelles :
    Localisation : France, Tarn (Midi Pyrénées)

    Informations professionnelles :
    Activité : Fabricant et casseur d'avions
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : avril 2004
    Messages : 3 731
    Points : 7 247
    Points
    7 247
    Par défaut
    Salut,

    Si je me souviens bien, ça veut dire "compilé en 1.5, exécuté en 1.4".

    Donc pour résoudre le problème, soit tu recompiles en 1.4 (soit en compilant avec un JDK 1.4, soit en compilant avec le 1.5 mais en spécifiant un -target 1.4 dans les paramètres de compilation), soit tu lances avec ta JRE 1.5...

    Avec Java, tu ne peux pas exécuter sur un JRE un code compilé avec une version supérieure à ce JRE... (à moins d'avoir mis le flag -target 1.x à la compilation)
    "Errare humanum est, sed perseverare diabolicum"

    Ma page sur DVP.com

  3. #3
    Expert éminent sénior
    Avatar de sinok
    Profil pro
    Inscrit en
    août 2004
    Messages
    8 765
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : août 2004
    Messages : 8 765
    Points : 12 925
    Points
    12 925
    Par défaut
    Sous eclipse clic droit sur ton projet, properties, java compiler et tu cherches la dedans pour faire passer la JDK compliance de 5.0 vers 1.4
    Hey, this is mine. That's mine. All this is mine. I'm claiming all this as mine. Except that bit. I don't want that bit. But all the rest of this is mine. Hey, this has been a really good day. I've eaten five times, I've slept six times, and I've made a lot of things mine. Tomorrow, I'm gonna see if I can't have sex with something.

  4. #4
    Membre averti Avatar de GyZmoO
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    février 2006
    Messages
    428
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : février 2006
    Messages : 428
    Points : 301
    Points
    301
    Par défaut
    Parfait ça marche merci beaucoup !
    define: Programmeur : Celui qui résout un problème que vous n'aviez pas, d'une façon que vous ne comprenez pas.

  5. #5
    Membre confirmé
    Homme Profil pro
    Technophile Web
    Inscrit en
    mai 2007
    Messages
    930
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Technophile Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : mai 2007
    Messages : 930
    Points : 467
    Points
    467
    Par défaut
    salut @ tous,

    j'ai la même erreure que GyZmoO

    j'ai donc esssayé de compiler avec la versionb antérieur de la JVM

    mais je suis confronté à des erreures
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    Unrecognized option: -target=1.4
    Could not create the Java virtual machine.
    j'ai fait un Run AS
    et dans Arguments j'ai ajouté
    PS : je reste sur la JVM 1.5 pour développer puisque j'ai des classe
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Exemples extends ArrayList<UneClasse>
    http://aldorande.miniville.fr/ind
    Fedora 8, eclipse 3.3 sur x86_64
    --------------
    Colorer votre code php

  6. #6
    Membre régulier
    Profil pro
    Inscrit en
    avril 2009
    Messages
    158
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2009
    Messages : 158
    Points : 80
    Points
    80
    Par défaut
    Bonjour,

    j'ai eu le meme problème.
    Donc pour remedier ce problème, comment je peux ajouter avec eclipse l'argument : Merci.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 2
    Dernier message: 18/04/2008, 17h08
  2. Réponses: 9
    Dernier message: 23/11/2007, 13h56
  3. [ASE 12.5.4]probleme : java.lang.OutOfMemoryError
    Par kei-kun dans le forum Adaptive Server Enterprise
    Réponses: 2
    Dernier message: 05/04/2007, 15h59
  4. [FOP] probleme java.lang.OutOfMemoryError
    Par Méta dans le forum Format d'échange (XML, JSON...)
    Réponses: 4
    Dernier message: 27/11/2006, 15h59
  5. [Exception]Probleme : Java.lang.Exception
    Par Nico66 dans le forum Général Java
    Réponses: 6
    Dernier message: 09/05/2005, 12h06

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo