IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Installation .NET Discussion :

Erreur passage SP2 Sharepoint Server 2010 [Débutant]


Sujet :

Installation .NET

  1. #1
    Membre actif
    Profil pro
    Inscrit en
    juillet 2013
    Messages
    352
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2013
    Messages : 352
    Points : 234
    Points
    234
    Par défaut Erreur passage SP2 Sharepoint Server 2010
    Bonjour
    Nous avons une erreur lorsque nous lançons le wizard suite au passage du SP2.

    The list 'Import' at URL '/toto/tata/maListe' has a schema that is incompatible with future versions of SharePoint.

    J'ai fait quelques recherches, et une erreur possible serait que ma liste contienne trop de colonnes. J'ai regardé, elle en a 278, réparties de la sorte :
    • choix : 58
    • nombre : 11
    • oui/non : 11
    • Personne ou groupe : 3
    • Une seule ligne de texte : 147
    • Valeur calculée (calcul basé sur d'autres colonnes) : 48

    j'ai trouvé cet article : http://technet.microsoft.com/fr-fr/l...29.aspx#Column

    il est dit que "La somme de toutes les colonnes dans une liste SharePoint ne peut pas dépasser 8 000 octets". Or si je calcule bien (c'est pas sur), j'arrive à 7283 octets. donc normalement je suis bon.

    après il est dit qu'on "autorise un maximum de 48 colonnes de type Calculé par liste SharePoint". j'en ai 48 donc normalement je suis bon....

    Est-ce que quelqu'un aurait déjà eu ce genre de problème ? Auriez-vous une idée pour contourner ce problème si c'est bien ca mon problème ?
    Sinon, comment pourrais-je procéder pour savoir ce qui ne va pas ?
    Merci pour votre aide.
    Christophe

  2. #2
    Membre actif
    Profil pro
    Inscrit en
    juillet 2013
    Messages
    352
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2013
    Messages : 352
    Points : 234
    Points
    234
    Par défaut
    j'ai lancé la commande Test-SPContentDatabase afin de tester ma base de contenu, voici le résultat :

    PS C:\Users\toto> Test-SPContentDatabase -name WSS_Content_XXXX -webapplication http://XXX.fr


    Category : WideListSchema
    Error : True
    UpgradeBlocking : True
    Message : Le schéma de la liste «*maListe*» sur l'URL «*/truc/Lists/maListe*» n'est pas compatible avec les versions futures de SharePoint.
    Remedy : Supprimez certains champs de la liste «*maListe*».
    euh je fais comment si toutes les colonnes sont utilisées ?

  3. #3
    Expert confirmé Avatar de Lapinpanda
    Homme Profil pro
    Développeur .NET
    Inscrit en
    juin 2009
    Messages
    3 230
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : juin 2009
    Messages : 3 230
    Points : 5 221
    Points
    5 221
    Par défaut
    Bonjour,

    Il s'agit d'une mauvaise conception de votre liste...il n'est pas normal de posséder autant de colonnes. Vous ne pourrais pas outrepasser les contraintes sharepoint, il va falloir réfléchir à une meilleur organisation de vos données, avec l'utilisation de plusieurs listes si nécessaires.
    Merci d'utiliser en cas de résolution de votre problème

    N'oubliez pas non plus le petit pouce vert pour récompenser celui que vous a aidé

  4. #4
    Membre actif
    Profil pro
    Inscrit en
    juillet 2013
    Messages
    352
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2013
    Messages : 352
    Points : 234
    Points
    234
    Par défaut
    bonjour
    je suis bien d'accord, j'ai récupéré tout ca et j'en découvre tous les jours.
    mon souci, c'est que nos admins ne peuvent pas passer le SP2 à cause de cette appli, et qu'ils me demandent des comptes.
    ce que je ne comprends pas non plus, c'est que ca fonctionne en SP1, pourquoi cela bloque-t-il en SP2 ?
    ou alors, c'est juste l'upgrade qui coince .... j'ai vu des articles disant qu'il fallait sauvegarder la liste, la supprimer, faire l'upgrade, et restaurer la liste ... c'était pour un passage de 2010 à 2013
    You can see that you have issues that you must resolve manually in your content database, mainly:

    The list 'AllEFormDepositary' at URL '/HR/PerformanceAppraisal/AllEFormDepositary' has a schema that is incompatible with this version of SharePoint.
    The list 'ArchiveForReports' has more than the limit of 262 fields of type 'Single line of text', 'Choice', or 'Hyperlink or Picture'.

    You must resolve these by backing them up, deleting them, doing the upgrade, and then putting them back afterwards.
    Pensez-vous que je puisse procéder ainsi sans que cela pose de souci à mon appli ? comme ca, les admins seront contents, ils pourront passer leur SP2, et j'aurai le temps de discuter avec le chef du dev pour revoir la conception de cette liste ....

    merci pour votre aide

  5. #5
    Expert confirmé
    Avatar de ludojojo
    Homme Profil pro
    Développeur SharePoint
    Inscrit en
    avril 2008
    Messages
    2 967
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France

    Informations professionnelles :
    Activité : Développeur SharePoint
    Secteur : Conseil

    Informations forums :
    Inscription : avril 2008
    Messages : 2 967
    Points : 5 371
    Points
    5 371
    Billets dans le blog
    5
    Par défaut
    arf, c'est un peu compliqué ta situation, par ce qu'il est possible que certains items de la liste soit utilisé comme référence (type lookup) depuis d'autres listes...
    Je te conseillerais de faire un backup complet de ta liste en powershell afin de t'assurer de récupérer toutes les méta-données et de pouvoir les recréer avec les bons ids...

    Est-ce qu'il existe un site de backup avec lequel tu puisses travailler ? Au pire essaye de faire le test avec une custom list simple. Sauvegarde -> Suppression -> Import. Le meilleur moyen de savoir, c'est de tester !
    Aide les autres...
    Et les autres t'aideront....
    Mon site DVP
    N'oubliez pas de consulter les FAQ SharePoint et les cours et tutoriels SharePoint

    N'oubliez pas de voter pour les messages dont la réponse est pertinente

  6. #6
    Expert confirmé Avatar de Lapinpanda
    Homme Profil pro
    Développeur .NET
    Inscrit en
    juin 2009
    Messages
    3 230
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : juin 2009
    Messages : 3 230
    Points : 5 221
    Points
    5 221
    Par défaut
    bonjour,

    ce que je ne comprends pas non plus, c'est que ca fonctionne en SP1, pourquoi cela bloque-t-il en SP2 ?
    Une des raisons possible : passage du SP1 OK -> ajout des N colonnes par des utilisateurs (250) -> SP2 KO

    Ce que tu pourrais faire, c'est faire un export Excel de ta liste, avec toutes les données, supprimer la liste , voir juste quelques colonnes, passer le SP2, recréer tes colonnes manquantes et réalimenter les valeurs en te basant sur le fichier excel
    Merci d'utiliser en cas de résolution de votre problème

    N'oubliez pas non plus le petit pouce vert pour récompenser celui que vous a aidé

  7. #7
    Membre actif
    Profil pro
    Inscrit en
    juillet 2013
    Messages
    352
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2013
    Messages : 352
    Points : 234
    Points
    234
    Par défaut
    merci pour vos réponses.
    ne serait-il pas plus simple de faire un backup complet du site, de passer le sp2, et de remonter le site après ?

  8. #8
    Expert confirmé Avatar de Lapinpanda
    Homme Profil pro
    Développeur .NET
    Inscrit en
    juin 2009
    Messages
    3 230
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : juin 2009
    Messages : 3 230
    Points : 5 221
    Points
    5 221
    Par défaut
    Bonjour,

    le backup va pour moi foirer car il va justement vérifier les mêmes validations que pour le passage du SP2
    Merci d'utiliser en cas de résolution de votre problème

    N'oubliez pas non plus le petit pouce vert pour récompenser celui que vous a aidé

  9. #9
    Membre actif
    Profil pro
    Inscrit en
    juillet 2013
    Messages
    352
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2013
    Messages : 352
    Points : 234
    Points
    234
    Par défaut
    bonjour
    j'ai fait un backup de ma webapp, je l'ai restaurée sur un autre serveur (de dev) en SP2.
    a première vue, il n'y a pas de problème. j'ai demandé au responsable de l'application de vérifier s'il n'y a pas de souci.
    on verra ce qu'il en dit ....

  10. #10
    Membre actif
    Profil pro
    Inscrit en
    juillet 2013
    Messages
    352
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2013
    Messages : 352
    Points : 234
    Points
    234
    Par défaut
    Bonjour
    A priori, tout est ok.
    Merci pour votre aide.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 2
    Dernier message: 17/02/2012, 22h08
  2. [MSSQL 2008] Erreur installation SP2 SQL Server 2008
    Par johndoe08 dans le forum Administration
    Réponses: 12
    Dernier message: 21/10/2010, 11h52
  3. Téléchargez Microsoft Sharepoint Server 2010 Beta en français gratuitement
    Par Community Management dans le forum SharePoint
    Réponses: 17
    Dernier message: 31/08/2010, 09h05
  4. [Exchange 2010] Problème de Cohabitation avec SharePoint Server 2010
    Par Jean-Claude Dusse dans le forum Exchange Server
    Réponses: 10
    Dernier message: 08/06/2010, 17h41
  5. Venez découvrir SharePoint Server 2010 ! a Geneve
    Par gexertier dans le forum Actualités
    Réponses: 0
    Dernier message: 26/02/2010, 14h31

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo