IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

jQuery Discussion :

jQuery 2.0.0 est disponible


Sujet :

jQuery

  1. #1
    Rédacteur
    Avatar de danielhagnoul
    Homme Profil pro
    Étudiant perpétuel
    Inscrit en
    février 2009
    Messages
    6 384
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 70
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant perpétuel
    Secteur : Enseignement

    Informations forums :
    Inscription : février 2009
    Messages : 6 384
    Points : 23 113
    Points
    23 113
    Billets dans le blog
    111
    Par défaut jQuery 2.0.0 est disponible
    jQuery 2.0.0 est disponible
    Plus rapide et 12 % moins "lourde" que la version 1.9.1

    Cette version abandonne les versions obsolètes d'Internet Explorer (IE 6, 7 et 8), elle est plus rapide et moins lourde.

    L'équipe de développement travaille déjà sur le futur de la branche compatible IE : la branche 1.10 sortira rapidement.

    Dans le futur les deux branches évolueront en parallèle :

    • 1.10.0 et 2.0.0
    • 1.11.0 et 2.1.0
    • etc.


    Rappelez-vous que les sites web de production doivent toujours demander une version précise de jQuery, utiliser une version indéterminée d'une branche ou jquery-latest.js est fortement déconseillé pour la performance et la maintenance de votre site web.

    La version 2.0.0 sera disponible sur tous les serveurs de code dans quelques jours, elle est déjà disponible sur le serveur de code de jQuery : <script src="http://code.jquery.com/jquery-2.0.0.min.js"></script>.

    Si vous mettez à jour depuis une version antérieure à la 1.9, nous vous recommandons d'utiliser le plugin jQuery Migrate et de lire le Guide de mise à niveau jQuery 1.9, car il ya eu beaucoup de changements. Il est facile d'utiliser le plugin Migrate, il suffit de l'inclure après jQuery et d'ouvrir votre console navigateur pour voir les messages qu'il génère:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    <script src="http://code.jquery.com/jquery-2.0.0.min.js"></script>
    <script src="http://code.jquery.com/jquery-migrate-1.1.1.min.js"></script>
    Seul l'usage de la branche 2.0 de jQuery est recommandé pour les utilisations "modernes", par exemple :

    • Google Chrome add-ons
    • Mozilla XUL apps and Firefox extensions
    • Firefox OS apps
    • Chrome OS apps
    • Windows 8 Store (“Modern/Metro UI”) apps
    • BlackBerry 10 WebWorks apps
    • PhoneGap/Cordova apps
    • Apple UIWebView class
    • Microsoft WebBrowser control
    • node.js (combined with jsdom or similar)


    Liste complète des modifications et source

  2. #2
    Futur Membre du Club
    Profil pro
    Développeur Web
    Inscrit en
    avril 2010
    Messages
    7
    Détails du profil
    Informations personnelles :
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2010
    Messages : 7
    Points : 9
    Points
    9
    Par défaut Compatibilité jQuery 2.0 et UI < 1.10
    La version 2 est elle compatible avec les anciennes versions des UI?

  3. #3
    Rédacteur
    Avatar de danielhagnoul
    Homme Profil pro
    Étudiant perpétuel
    Inscrit en
    février 2009
    Messages
    6 384
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 70
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant perpétuel
    Secteur : Enseignement

    Informations forums :
    Inscription : février 2009
    Messages : 6 384
    Points : 23 113
    Points
    23 113
    Billets dans le blog
    111
    Par défaut
    Il y a eu plusieurs ruptures de rétro compatibilité lors de l'évolution du code de jQuery (1.8 vers 1.9) et de jQuery UI (1.9 vers 1.10).

    En conséquence, je ne pense pas que la branche 2 de jQuery soit totalement compatible avec jQuery UI en dessous de la version 1.10.0.

Discussions similaires

  1. jQuery 1.6 RC1 est disponible pour tests
    Par danielhagnoul dans le forum jQuery
    Réponses: 3
    Dernier message: 02/05/2011, 10h10
  2. jQuery 1.5.2 est disponible
    Par danielhagnoul dans le forum jQuery
    Réponses: 3
    Dernier message: 01/04/2011, 23h24
  3. jQuery 1.4.4 est disponible
    Par danielhagnoul dans le forum jQuery
    Réponses: 8
    Dernier message: 12/11/2010, 11h05
  4. jQuery UI 1.8rc3 est disponible
    Par danielhagnoul dans le forum jQuery
    Réponses: 4
    Dernier message: 19/03/2010, 18h53
  5. jQuery 1.4.2 est disponible
    Par danielhagnoul dans le forum jQuery
    Réponses: 9
    Dernier message: 27/02/2010, 22h32

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo