IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI, CMS, Outils, Scripts et API PHP Discussion :

login et mdp par defaut phpMyAdmin [phpMyAdmin]


Sujet :

EDI, CMS, Outils, Scripts et API PHP

  1. #1
    Membre averti Avatar de mapmip
    Profil pro
    ulla
    Inscrit en
    juillet 2006
    Messages
    1 269
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : ulla

    Informations forums :
    Inscription : juillet 2006
    Messages : 1 269
    Points : 341
    Points
    341
    Par défaut login et mdp par defaut phpMyAdmin
    bonjour,

    j'ai installé mysql et phymyadmin pour la premiere fois,
    je vais sur http://localhost/phpmyadmin/ ,
    j'ai la boite de dialogue d'apache :

    Code html : Sélectionner tout - Visualiser dans une fenêtre à part
    Le site <a href="http://localhost" target="_blank">http://localhost</a> demande un nom d'utilisateur et un mot de passe. Le site indique : « phpMyAdmin localhost »



    Quel est le login et mot de passe par défaut?

    J'ai essayé "root" sans mot de passe mais ca veut pas...


    merci d'avance

  2. #2
    ced
    ced est actuellement connecté
    Rédacteur/Modérateur

    Avatar de ced
    Homme Profil pro
    Gestion de bases de données techniques
    Inscrit en
    avril 2002
    Messages
    5 953
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Loiret (Centre)

    Informations professionnelles :
    Activité : Gestion de bases de données techniques
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : avril 2002
    Messages : 5 953
    Points : 23 548
    Points
    23 548
    Par défaut
    Bonjour,

    Normalement, l'installation par défaut de MySQL crée un compte root sans mot de passe.
    Essayez déjà de vous connecter par une console MySQL (sans passer par phpMyAdmin), histoire de voir si le problème vient de MySQL, ou de phpMyAdmin.
    Rédacteur / Modérateur SGBD et R
    Mes tutoriels et la FAQ MySQL

    ----------------------------------------------------
    Pensez aux balises code et au tag
    Une réponse vous a plu ? N'hésitez pas à y mettre un
    Je ne réponds pas aux questions techniques par message privé, les forums sont là pour ça

  3. #3
    Membre averti Avatar de mapmip
    Profil pro
    ulla
    Inscrit en
    juillet 2006
    Messages
    1 269
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : ulla

    Informations forums :
    Inscription : juillet 2006
    Messages : 1 269
    Points : 341
    Points
    341
    Par défaut
    Ça marche en ligne de commande mysql.

  4. #4
    ced
    ced est actuellement connecté
    Rédacteur/Modérateur

    Avatar de ced
    Homme Profil pro
    Gestion de bases de données techniques
    Inscrit en
    avril 2002
    Messages
    5 953
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Loiret (Centre)

    Informations professionnelles :
    Activité : Gestion de bases de données techniques
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : avril 2002
    Messages : 5 953
    Points : 23 548
    Points
    23 548
    Par défaut
    OK, donc le problème se situe bien du côté de phpMyAdmin.
    Sans doute un problème de paramétrage de la connexion.
    Rédacteur / Modérateur SGBD et R
    Mes tutoriels et la FAQ MySQL

    ----------------------------------------------------
    Pensez aux balises code et au tag
    Une réponse vous a plu ? N'hésitez pas à y mettre un
    Je ne réponds pas aux questions techniques par message privé, les forums sont là pour ça

  5. #5
    Modérateur
    Avatar de sabotage
    Homme Profil pro
    Inscrit en
    juillet 2005
    Messages
    29 208
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2005
    Messages : 29 208
    Points : 43 408
    Points
    43 408
    Par défaut
    Quand tu dis que ça fonctionne en ligne de commande tu fais quoi exactement ?
    Est-ce que tu arrives à te connecter en PHP (en dehors de PHPmyadmin) ?
    Est-ce que ton compte à un mot de passe ?
    N'oubliez pas de consulter les FAQ PHP et les cours et tutoriels PHP

  6. #6
    Membre averti Avatar de mapmip
    Profil pro
    ulla
    Inscrit en
    juillet 2006
    Messages
    1 269
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : ulla

    Informations forums :
    Inscription : juillet 2006
    Messages : 1 269
    Points : 341
    Points
    341
    Par défaut
    quand je me connecte en ligne de commande sur ma console ca marche:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    mysql -h localhost -u root -p
    Je n'ai jamais modifié la base de données ni changé quoi que ce soit aux users?

    pour info je suis sur centos 6.3 et voila comment j'ai installé mysql:

    http://dev.mysql.com/doc/refman/5.1/...on-native.html

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    yum install mysql mysql-server mysql-libs mysql-server
    service mysqld start
    chkconfig --levels 235 mysqld on

    Quant à phpmyadmin 3.5.7, je l'ai installé grâce à un rpm déjà présent sur mon pc depuis le Gestionnaire de paquet pour GNOME




    Voici la boite de dialogue d'apache:
    Nom : Capture-Authentification requise.png
Affichages : 75467
Taille : 18,4 Ko

  7. #7
    ced
    ced est actuellement connecté
    Rédacteur/Modérateur

    Avatar de ced
    Homme Profil pro
    Gestion de bases de données techniques
    Inscrit en
    avril 2002
    Messages
    5 953
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Loiret (Centre)

    Informations professionnelles :
    Activité : Gestion de bases de données techniques
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : avril 2002
    Messages : 5 953
    Points : 23 548
    Points
    23 548
    Par défaut
    Sans être un spécialiste de la question, j'ai plutôt l'impression que c'est un problème de configuration au niveau d'Apache, pas de MySQL ni de phpMyAdmin.
    Rédacteur / Modérateur SGBD et R
    Mes tutoriels et la FAQ MySQL

    ----------------------------------------------------
    Pensez aux balises code et au tag
    Une réponse vous a plu ? N'hésitez pas à y mettre un
    Je ne réponds pas aux questions techniques par message privé, les forums sont là pour ça

  8. #8
    Modérateur
    Avatar de sabotage
    Homme Profil pro
    Inscrit en
    juillet 2005
    Messages
    29 208
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2005
    Messages : 29 208
    Points : 43 408
    Points
    43 408
    Par défaut
    Tu peux toujours essayer un autre mode de connexion mais je n'ai jamais croisé un problème de ce genre.
    Dans ton config.inc.php :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    $cfg['Servers'][$i]['auth_type'] = 'config';
    $cfg['Servers'][$i]['user'] = 'root';
    $cfg['Servers'][$i]['password'] = 'xxxxxxx';
    N'oubliez pas de consulter les FAQ PHP et les cours et tutoriels PHP

  9. #9
    Membre averti Avatar de mapmip
    Profil pro
    ulla
    Inscrit en
    juillet 2006
    Messages
    1 269
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : ulla

    Informations forums :
    Inscription : juillet 2006
    Messages : 1 269
    Points : 341
    Points
    341
    Par défaut
    non ca me renvoie le message:
    #1045 - Access denied for user 'root'@'localhost' (using password: YES)


    quand je recharge http://localhost/phpmyadmin

  10. #10
    Membre averti Avatar de mapmip
    Profil pro
    ulla
    Inscrit en
    juillet 2006
    Messages
    1 269
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : ulla

    Informations forums :
    Inscription : juillet 2006
    Messages : 1 269
    Points : 341
    Points
    341
    Par défaut
    j'ai trouvé une solution sur une autre site :

    utiliser la commande mysql puis:

    mysql> SET PASSWORD FOR root@localhost=PASSWORD('monmotdepasse');
    
    mysql> GRANT ALL PRIVILEGES ON *.* TO root@localhost  IDENTIFIED BY 'monmotdepasse' WITH GRANT OPTION;
    dans le fichier config.inc.php , mettre:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    $cfg['Servers'][$i]['host']= 'config';
    $cfg['Servers'][$i]['user'] = 'root';
    $cfg['Servers'][$i]['password']= 'monmotdepasse';
    recharger http://localhost/phpmyadmin, et mettre root en login et monmotdepasse

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. authentification squid par login et mdp
    Par berok37 dans le forum Réseau
    Réponses: 0
    Dernier message: 18/03/2011, 21h44
  2. login par defaut de database engine sql server 2008
    Par hatemelmoncer dans le forum Administration
    Réponses: 2
    Dernier message: 02/08/2009, 23h38
  3. [Wamp] login mot de passe ftp par defaut
    Par yann123456 dans le forum EDI, CMS, Outils, Scripts et API
    Réponses: 8
    Dernier message: 25/05/2009, 16h52
  4. Réponses: 10
    Dernier message: 26/07/2006, 07h52
  5. Accéder à une page web sans passer par login et mdp
    Par benthebest dans le forum Général JavaScript
    Réponses: 9
    Dernier message: 21/07/2006, 01h04

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo