IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Linux Discussion :

Changer de version de gcc sous Linux


Sujet :

Linux

  1. #1
    Nouveau membre du Club
    Homme Profil pro
    Consultant informatique
    Inscrit en
    novembre 2011
    Messages
    33
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Communication - Médias

    Informations forums :
    Inscription : novembre 2011
    Messages : 33
    Points : 28
    Points
    28
    Par défaut Changer de version de gcc sous Linux
    Bonjours à tous,

    j'essaie d'installer une application (VMware server) sur mon serveur CentOS de version 2.6.37.3-1ikl. j'ai pu installer le serveur VMware. Lorsque je lance la commande /usr/bin/vmware-config.pl il me met ce message:


    None of the pre-built vmmon modules for VMware Server is suitable for your
    running kernel. Do you want this program to try to build the vmmon module for
    your system (you need to have a C compiler installed on your system)? [yes]


    Using compiler "/usr/bin/gcc". Use environment variable CC to override.


    Your kernel was built with "gcc" version "4.3.2", while you are trying to use
    "/usr/bin/gcc" version "4.1.2". This configuration is not recommended and
    VMware Server may crash if you'll continue. Please try to use exactly same
    compiler as one used for building your kernel. Do you want to go with compiler
    "/usr/bin/gcc" version "4.1.2" anyway? [no]
    je veux donc permettre qu'il compile avec la version 4.3.2, mais je ni arrive pas. toutes les commandes que j'ai eu à taper ne m'ont donné aucun résultat. j'ai même utilisé la commande gcc -V 4.3.2 pour forcer l'utilisation de la version de mon kernel (4.3.2) mais rien. Que dois-je faire?
    Si quelqu'un à la solution qu'il m'aide.

  2. #2
    Invité
    Invité(e)
    Par défaut
    Citation Envoyé par jeankim Voir le message
    Bonjours à tous,

    j'essaie d'installer une application (VMware server) sur mon serveur CentOS de version 2.6.37.3-1ikl. j'ai pu installer le serveur VMware. Lorsque je lance la commande /usr/bin/vmware-config.pl il me met ce message:




    je veux donc permettre qu'il compile avec la version 4.3.2, mais je ni arrive pas. toutes les commandes que j'ai eu à taper ne m'ont donné aucun résultat. j'ai même utilisé la commande gcc -V 4.3.2 pour forcer l'utilisation de la version de mon kernel (4.3.2) mais rien. Que dois-je faire?
    Si quelqu'un à la solution qu'il m'aide.
    Je pense que ça n'a rien à voir, mais j'ai eu un problème sous ubuntu ou il m'était impossible de compiler les entête de WMware (cause vraiment obscure). Après quelques temps de recherche, je me suis aperçu qu'il existait une version spécifique de WMware à utiliser pour ma distribution. Creuse par là, je pense que tu devrais trouver.

    Autrement je tenterais d'installer gcc manuellement dans un autre répertoire en plus de ta version actuelle.

    C'est quand même bizarre d'avoir un noyau compilé avec un gcc plus récent que celui fournit sur ta machine. Tu ne peux pas faire la mise à jour ?

Discussions similaires

  1. [FEDORA] Changer ma version de gcc
    Par Jérémy Lefevre dans le forum RedHat / CentOS / Fedora
    Réponses: 1
    Dernier message: 10/11/2006, 15h24
  2. Changer la version de gcc fedora c5
    Par Jérémy Lefevre dans le forum Administration système
    Réponses: 1
    Dernier message: 10/11/2006, 15h06
  3. Version de Gcc pour Linux RH2.1
    Par Troll dans le forum Applications et environnements graphiques
    Réponses: 2
    Dernier message: 14/08/2006, 17h58
  4. [débutant]compiler avec gcc sous linux
    Par Ickou dans le forum Autres éditeurs
    Réponses: 4
    Dernier message: 10/03/2006, 18h27

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo