Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 5 sur 5
  1. #1
    Membre éclairé
    Avatar de onet
    Inscrit en
    décembre 2002
    Messages
    365
    Détails du profil
    Informations personnelles :
    Âge : 33

    Informations forums :
    Inscription : décembre 2002
    Messages : 365
    Points : 300
    Points
    300

    Par défaut Version 2.5 en stable?

    Hello,

    je viens vers vous, pour une petite question... Je début avec Firebird, car une partie de notre équipe de développement ne jure que par Firebird, et donc j'ai accepté de les suivres, dans le cadre d'un projet sensible.

    Cependant, je viens de remarquer qu'ils m'ont demandé d'installer la version 2.5, et que celle-ci est en... RC2! et ca, ca me pose un sérieux problème! Car il est hors de question que le projet soit en partie en RC, du a la sensibilité de celui-ci! (intégration d'un serveur database dans des machine industrielles, produites à plusieurs centaines d'exemplaires par année, sans accès internet pour mise à jour, et qui seront eparpillée dans le monde...).

    Est-ce que parmis vous certains ont des informations quand à la date de passage en stable de Firebird superserver 2.5 ? Pensez-vous que ce soit judicieux, vis à vis des cycles de développement de Firebird, de se lancer sur cette version, ou faut-il assurer le coup en restant en 2.1 ?

    Je ne suis pas contre faire du dev sur RC, dés le moment ou je connais les cycles, et que je sais que les versions stables arrivent a une date donnée, et sont réellement stable (on développe sous Debian Squeeze, qui va passer en stable d'ici quelques mois, et je sais que je pourrais compter dessus, par exemple).

    Bref, si vous avez un retour sur cet avis, c'est avec plaisir

    Onet
    ---
    Retrouvez tout mes tutos et mes articles: http://www.olivierlange.com

  2. #2
    Expert Confirmé

    Homme Profil pro Philippe Makowski
    Consultant spécialité Firebird
    Inscrit en
    mai 2002
    Messages
    2 312
    Détails du profil
    Informations personnelles :
    Nom : Homme Philippe Makowski
    Âge : 51
    Localisation : France

    Informations professionnelles :
    Activité : Consultant spécialité Firebird
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2002
    Messages : 2 312
    Points : 3 559
    Points
    3 559

    Par défaut

    Citation Envoyé par onet Voir le message
    (on développe sous Debian Squeeze, qui va passer en stable d'ici quelques mois, et je sais que je pourrais compter dessus, par exemple)
    ça tombe bien, Firebird 2.5 est exactement dans le même cas que Debian Squeeze
    La RC3 arrive et elle sera déclarée stable comme une Debian, quand elle sera prête

    J'ajoute même que Firebird 2.5 est dans Squeeze :
    http://packages.debian.org/source/squeeze/firebird2.5
    Philippe Makowski
    IBPhoenix - Firebird
    Membre de l'April

  3. #3
    Membre éclairé
    Avatar de onet
    Inscrit en
    décembre 2002
    Messages
    365
    Détails du profil
    Informations personnelles :
    Âge : 33

    Informations forums :
    Inscription : décembre 2002
    Messages : 365
    Points : 300
    Points
    300

    Par défaut

    Oups, je n'avais pas recu d'informations concernant ton message

    Alors, oui, Firebird 2.5 est dans squeeze, mais n'est pas ens table. Et d'ou as-tu les sources concernant le passage ens table de Firebird 2.5, je n'ai aucunes informations la dessus.

    le problème, c'est que je maitrise Debian (enfin, ce qu'il faut pour notre projet, lol!). Mais pas Firebird. Donc je ne me sens pas prêt à faire des hypothèses dessus, n'ayant pas suffisament de recul. Contrairement A debian, ou je connais l'historique...

    Donc bon, vais quand meme attendre le passage en stable, je crois, d'autant que sur la 2.5 qu'on a tester une aprtie de l'équipe n'arrivait pas a se connecter depuis windows sur les dbs, alors qu'en 2.1, aucuns problèmes...

    Onet
    ---
    Retrouvez tout mes tutos et mes articles: http://www.olivierlange.com

  4. #4
    Expert Confirmé

    Homme Profil pro Philippe Makowski
    Consultant spécialité Firebird
    Inscrit en
    mai 2002
    Messages
    2 312
    Détails du profil
    Informations personnelles :
    Nom : Homme Philippe Makowski
    Âge : 51
    Localisation : France

    Informations professionnelles :
    Activité : Consultant spécialité Firebird
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2002
    Messages : 2 312
    Points : 3 559
    Points
    3 559

    Par défaut

    Citation Envoyé par onet Voir le message
    le problème, c'est que je maitrise Debian (enfin, ce qu'il faut pour notre projet, lol!). Mais pas Firebird. Donc je ne me sens pas prêt à faire des hypothèses dessus, n'ayant pas suffisament de recul. Contrairement A debian, ou je connais l'historique...
    tu peux faire exactement les mêmes hypothèses pour Firebird que pour Debian
    Pour prendre l'analogie avec Debian, la 2.5 est actuellement dans l'état « frozen »

    Une RC3 ne vas pas tarder : http://www.firebirdsql.org/index.php...roadmap&nosb=1


    sur la 2.5 qu'on a tester une aprtie de l'équipe n'arrivait pas a se connecter depuis windows sur les dbs
    ???, il n'y aucune bonne raison à cela
    Philippe Makowski
    IBPhoenix - Firebird
    Membre de l'April

  5. #5
    Membre éclairé
    Avatar de onet
    Inscrit en
    décembre 2002
    Messages
    365
    Détails du profil
    Informations personnelles :
    Âge : 33

    Informations forums :
    Inscription : décembre 2002
    Messages : 365
    Points : 300
    Points
    300

    Par défaut

    Salut,

    Merci pour tes réponses. Je vais voir ce qu'il en est!

    Pour le souci de connexion, je suis a 100% d'accord avec toi. le problème, c'est que je ne bosse pas sous Windows. C'est une boite externe qui dois s'y connecter (ce sont eux qui connaissent le mieux Firebird, pour l'avoir déja utilisé sur d'anciens programme en C#), et ils n'y arrivent pas.

    Et bien entendu, la seule chose qu'ils savent me dire c'est: "c'est de la faute a Linux si on arrive pas a se connecter, demerdez vous". Bref, c'est un climat de dev assez... compliquer. J'ai donc laissé tombé pour le moment, et on est partit sur la 2.1 pour commencer (a priori, on a pas besoin de fonctions disponibles uniquement en 2.5). Et dés qu'elle passera en stable, go sur la 2.5!

    Olivier
    ---
    Retrouvez tout mes tutos et mes articles: http://www.olivierlange.com

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •