p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Invité régulier
    Inscrit en
    mars 2012
    Messages
    67
    Détails du profil
    Informations forums :
    Inscription : mars 2012
    Messages : 67
    Points : 7
    Points
    7

    Par défaut Impossible de récupérer un id

    Salut à tous,

    Je code mon blog de A à Z et un problème se pose...Avant de mettre une "fonctionnalité sur mon blog" je la teste sur un site qui me sert à ça.

    J'ai donc voulu ajouté un système de commentaires, pas de problèmes il fonctionne sur le site de test. Mais après avoir fait une pagination sur mon blog, j'ai essayé de mettre les commentaires et impossible de récupérer l'id de l'article sur lequel le commentaire doit être posté.
    J'ai testé et cela vient bien du fait que mon id n'est pas récupéré. Voici le code :

    Il se peut que l'erreur soit simple mais je ne la vois pas. Pour info, j'ai vérifié si le soucis venait de la pagination et non, et j'ai vérifié si le problème venait du chemin menant au blog (blog?page=1 (j'utilise un htaccess pour ne pas mettre les .php) et non.

    Merci et bonne soirée

  2. #2
    Membre Expert
    Homme Profil pro
    Étudiant
    Inscrit en
    avril 2012
    Messages
    771
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : avril 2012
    Messages : 771
    Points : 1 430
    Points
    1 430

    Par défaut

    Bonsoir,

    le action de ton formulaire contient t'il la l'id de ta page ?

  3. #3
    Invité régulier
    Inscrit en
    mars 2012
    Messages
    67
    Détails du profil
    Informations forums :
    Inscription : mars 2012
    Messages : 67
    Points : 7
    Points
    7

    Par défaut

    !!!!!!!!!!!!!!!!!!><

    Désolé pour ça...j'ai passé plus de trois heures et j'ai juste zappé le fait de mettre l'id dans le action --' Merci beaucoup...Le pire c'est que je l'avais déjà fait...Oublie idiot

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [QuickForm] Impossible de récupérer les valeurs du formulaire
    Par Mainman dans le forum HTML_quickform
    Réponses: 2
    Dernier message: 29/05/2007, 12h15
  2. [Outlook] Impossible de récupérer mes messages ...
    Par Rumeurs dans le forum Outlook
    Réponses: 4
    Dernier message: 13/04/2006, 19h05
  3. XMLHttpRequest : Impossible de récupérer les données
    Par laurent_ifips dans le forum JavaScript
    Réponses: 10
    Dernier message: 22/11/2005, 13h28
  4. [HTML][PHP] Formulaire impossible de récupérer les variables
    Par Pfeffer dans le forum Balisage (X)HTML et validation W3C
    Réponses: 1
    Dernier message: 11/11/2005, 16h08
  5. Réponses: 1
    Dernier message: 05/07/2005, 10h47

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo