Bonjour,

J'ai un petit souci,

j'utilise un serveur Kimsufi sous ubuntu 9.04 comme serveur de backup distant avec Rsync.

j'ai des postes en Windows XP et 2000, sur ces postes j'ai installé Deltacopy (petit client rsync)

j'ai déjà testé cette solution sur un serveur en local et ça fonctionne correctement, j'exécute deltacopy il arrive à communiquer avec le serveur local.

Par contre, lorsque j'exécute deltacopy pour qu'il communique avec le serveur distant, il n'y arrive pas.


** Configuration de mon serveur distant Rsync **

dans
/etc/default/rsync
j'ai mis
RSYNC_ENABLE=true
dans
/etc/rsyncd.conf
j'ai rajouté :

uid = rsync
gid = rsync

log file = /var/log/rsync.log

[share_rsync]
path = /srv/intern
comment = Synchro fichiers internes
read only = false
ensuite je crée mon utilisateur et son password et un group rsync

j'attribue les droits aux répertoires

sudo chown -R rsync:rsync /srv/intern
sudo chmod -R 777 /srv/intern
et je lance Rsync

sudo /etc/init.d/rsync start

** Configuration de mon client deltacopy **

ip : xx.xx.xx.xx
user : rsync
mdp : *****
module de sauvegarde : share_rsync
** Message d'erreur de Deltacopy **

uable to fetch direcory name. rsync: failed to connecto ksxxxxx.kimsufi.com: connection timed out (116)
** iptables serveur **

Je pense que je dois ouvrir les ports RSYNC de mon serveur (le 873 je crois)

je ne sais pas trop comment faire peut être comme ça:

iptables -A OUTPUT -o eth0 -m state --state NEW,ESTABLISHED -p tcp --dport 873 -j ACCEPT
iptables -A INPUT -i eth0 -m state --state ESTABLISHED -p tcp --sport 873 -j ACCEPT

iptables -L

Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT udp -- anywhere anywhere state NEW,ESTABLISHED udp spt:rsync
ACCEPT tcp -- anywhere anywhere state NEW,ESTABLISHED tcp spt:rsync

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
ACCEPT udp -- anywhere anywhere state NEW,ESTABLISHED udp dpt:rsync
ACCEPT tcp -- anywhere anywhere state NEW,ESTABLISHED tcp dpt:rsync
et là je ne sais pas si je dois faire une connexion via ssh? ou autres choses, car ce n'est plus un serveur local, mais un serveur distant :o

est-ce qu'il y a une configuration particulière à faire sur le serveur?

Merci d'avance.