IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Administration système Discussion :

Déplacement des disques dur sur un autre serveur : Kernel Panic


Sujet :

Administration système

  1. #1
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    3
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2007
    Messages : 3
    Points : 1
    Points
    1
    Par défaut Déplacement des disques dur sur un autre serveur : Kernel Panic
    Bonjour,

    Je sollicite vos compètences pour m'aider à comprendre et résoudre le problème suivant :


    Un de nos serveur est tombé en rade dans la journée ( plus aucune réaction malgré une alimentation qui fonctionne correctement une fois placé sur un autre serveur ) , ce serveur dispose de deux disques durs et tourne sur une Red Hat professionnel ( 4 il me semble ).



    Nous avons donc décidé de récupérer les disques durs, et les monter sur un autre serveur.

    Une fois cette manipulation réalisée, le nouveau serveur démarre, lance grub qui a son tour lance la procédure de démarrage du système d'exploitation.

    Sauf que trés rapidement, le message d'erreur suivant apparait :
    mkrootdev : label / not found , puis apparait le message bloquant " kernel panic".


    Face à ce problème nous avons deux options :
    1.la meilleure : trouver une solution pour que le boot sur le nouveau serveur fonctionne convenablement.
    2.La solution de secours : réussir à accèder au contenu des disques pour sauvegarder certaines données.


    Nous avons donc utilisé un LiveCd pour accèder aux 2 disques dur :
    Les disques utilisant LVM, nous avons lancé la commande pvscan qui nous retourne :
    2 disques dur de 60 Giga , l'un sur /dev/sda3 l'autre sur /dev/sdb3.

    Ce qui nous semble tout à fait normal, dans le fichier fstab nous avons X partitions connectées à /dev/vg01 ( ou quelque chose dans le genre ).

    Confiant, je lance la commande : mount -t ext3 /dev/sda3 /mnt.

    Il me répond " le point de montage existe déjà ou mnt est en cours d'utilisation .

    Aprés une commande "mount" je constate que /mnt n'est pas monté et que /dev/sda3 n'est pas mappé sur une partition active.

    Je tente donc d'autre noms ( sda1, sda2 , sdb1 .... ) au niveau de la commande mount, et miracle : mount -t ext3 /dev/sdb1 /mnt fonctionne !

    Ce qui pour moi contredit un peu le résultat de la commande pvscan ...

    Toujours est-il qu'aprés le montage /mnt j'accède à mon disque mais beaucoup de répertoire sont vides, j'imagine qu'ils sont stockés sur le deuxième groupe ( il semblerait, mais je ne suis pas expert que les deux disques partagent des volume groupes commun ).


    Du coup je n'arrive :
    Ni à démarrer avec ces deux disques
    Ni à récupérer l'ensemble du contenu de ces disques.

    J'éspère vivement que vous pourrez m'aider !

    Merci d'avance

  2. #2
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    3
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2007
    Messages : 3
    Points : 1
    Points
    1
    Par défaut
    Je viens de lire X posts sur d'autres forums ,

    En ce qui concerne la récupération des fichiers, je ne devrai pas monter le /dev/sda... mais plutot le volume group non ?


    Si je comprends bien,en montant le /dev/sdb1, je récupère les données qui sont sur le système de fichier /dev/sdb1 qui correspond physiquement à l'un de mes deux disques.

    En faisant un mount du volume logique ( en récupérant son nom en executant la commande "mount" ) , si celui ci correspond physiquement à une partie de chaque disque, je n'aurai aucun problème pour accèder aux données, et ce quelque soit le disque ?

    Dans tous les cas, ca n'explique pas pourquoi je ne peux pas booter sur mes disques comme auparavant ...

  3. #3
    Membre chevronné Avatar de jeanbi
    Profil pro
    Inscrit en
    avril 2003
    Messages
    1 703
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2003
    Messages : 1 703
    Points : 2 248
    Points
    2 248
    Par défaut
    bonjour
    sur le nouveau serveur il n'y a que les 2 disques de l'ancien ?
    si oui procure toi un cd live de f11 et tu pourra en mode graphique voir le lvm etc..
    et je pense monter facilement les différentes partitions du dd
    a+

  4. #4
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    décembre 2007
    Messages
    3
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2007
    Messages : 3
    Points : 1
    Points
    1
    Par défaut
    Malheuresement l'interface graphique du live cd plante systèmatiquement, je suis donc obligé de travailler en console ( par plante, j'entends l'affichage qui freeze )

Discussions similaires

  1. [Spip] transférer des sites Spip sur 1 autre disque dur
    Par timoun dans le forum EDI, CMS, Outils, Scripts et API
    Réponses: 4
    Dernier message: 06/05/2013, 11h03
  2. Réception des données sur un autre serveur
    Par u115rcu dans le forum Langage
    Réponses: 5
    Dernier message: 20/01/2007, 15h20
  3. comment connaitre la liste des disque dur sur un pc?
    Par Jayceblaster dans le forum Delphi
    Réponses: 2
    Dernier message: 22/10/2006, 13h20
  4. Réponses: 4
    Dernier message: 30/11/2005, 20h13

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo