IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI, CMS, Outils, Scripts et API PHP Discussion :

Quelle version de mysql nécessite ma version de joomla ?


Sujet :

EDI, CMS, Outils, Scripts et API PHP

  1. #1
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    juin 2008
    Messages
    4
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2008
    Messages : 4
    Points : 1
    Points
    1
    Par défaut Quelle version de mysql nécessite ma version de joomla ?
    bonjour,

    j'ai toujours le problème (A database error occurred when running query
    CREATE TABLE `jos_banner` ( `bid` int(11) , (...) ENGINE=MyISAM DEFAULT CHARSET=latin1 ;(...)
    The error was:
    You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ,... etc etc)
    voir mon précédent message plus bas dans la page du forum

    mon hébergeur me demande : Quelle version de mysql nécessite votre version de joomla ? 4.1 ou 5.0 ?

    bonne question

    j'utilise : VirtueMart_1.1.0-COMPLETE_PACKAGE.j15
    quelqu'un peut il m'aider?

    merci d'avance

  2. #2
    Membre averti
    Avatar de opware2000
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    243
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2006
    Messages : 243
    Points : 367
    Points
    367
    Par défaut
    joomla utilise les version 4 et 5 de mysql , peux tu coller le vrai message d'erreur ?

  3. #3
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    juin 2008
    Messages
    4
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2008
    Messages : 4
    Points : 1
    Points
    1
    Par défaut
    merci, enfin une réponse!

    donc voici le message d'erreur :

    A database error occurred when running query

    CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(10) NOT NULL default 'banner', `name` varchar(50) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`) ) ENGINE=MyISAM DEFAULT CHARSET=latin1 ;
    The error was:
    You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'DEFAULT CHARSET=latin1\' at line 1 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default \'0\', `type` varchar(10) NOT NULL default \'banner\', `name` varchar(50) NOT NULL default \'\', `imptotal` int(11) NOT NULL default \'0\', `impmade` int(11) NOT NULL default \'0\', `clicks` int(11) NOT NULL default \'0\', `imageurl` varchar(100) NOT NULL default \'\', `clickurl` varchar(200) NOT NULL default \'\', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default \'0\', `checked_out` tinyint(1) NOT NULL default \'0\', `checked_out_time` datetime NOT NULL default \'0000-00-00 00:00:00\', `editor` varchar(50) default NULL, `custombannercode` text, PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`) ) ENGINE=MyISAM DEFAULT CHARSET=latin1 ;

  4. #4
    Membre averti
    Avatar de opware2000
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    243
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2006
    Messages : 243
    Points : 367
    Points
    367
    Par défaut
    soit il n'aime pas l'espace entre latin1 et le ;
    soit il y a un probleme avec l'encodage de ta base, elle doit etre en utf8 au lieu d'iso8859_1

  5. #5
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    juin 2008
    Messages
    4
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2008
    Messages : 4
    Points : 1
    Points
    1
    Par défaut
    merci encore pour cette réponse rapide

    et que dois-je faire pour remédier au problème?

    précision sur mon ordi j'utilise :
    ##### ApacheFriends XAMPPlite (default package) Version 1.6.6 ######

    + Apache 2.2.8
    + MySQL 5.0.51a
    + PHP 5.2.5
    + XAMPPlite Control Version 2.5 from www.nat32.com
    + XAMPPlite Security 1.0
    + SQLite 2.8.15
    + OpenSSL 0.9.8g
    + phpMyAdmin 2.11.4
    + Webalizer 2.01-10
    + Zend Optimizer 3.3.0
    + eAccelerator 0.9.5.2 for PHP 5.2.5 (comment in php.ini)

    et les infos trouvé sur mon hébergeur (un peu en vrac!):
    MySQL - 4.0.24_Debian-10-log
    Version du protocole: 10
    Serveur: mysql4-1 via TCP/IP

    phpMyAdmin - 2.8.2-Debian-0.2
    Version du client MySQL: 5.0.24a
    Extensions PHP utilisées: mysql
    Language : Français - French (iso-8859-1)

    encore merci

  6. #6
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    juin 2008
    Messages
    4
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2008
    Messages : 4
    Points : 1
    Points
    1
    Par défaut
    précision, je suis allé dans joomla.sql où j'ai modifié ENGINE=MyISAM DEFAULT CHARSET=latin1

    mais j'ai toujours le message d'erreur

    A database error occurred when running query

    CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(10) NOT NULL default 'banner', `name` varchar(50) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`) ) ENGINE=MyISAM DEFAULT CHARSET=latin1;
    The error was:
    You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'DEFAULT CHARSET=latin1\' at line 1 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default \'0\', `type` varchar(10) NOT NULL default \'banner\', `name` varchar(50) NOT NULL default \'\', `imptotal` int(11) NOT NULL default \'0\', `impmade` int(11) NOT NULL default \'0\', `clicks` int(11) NOT NULL default \'0\', `imageurl` varchar(100) NOT NULL default \'\', `clickurl` varchar(200) NOT NULL default \'\', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default \'0\', `checked_out` tinyint(1) NOT NULL default \'0\', `checked_out_time` datetime NOT NULL default \'0000-00-00 00:00:00\', `editor` varchar(50) default NULL, `custombannercode` text, PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`) ) ENGINE=MyISAM DEFAULT CHARSET=latin1;

Discussions similaires

  1. [Joomla!] Quelle version de Joomla choisir ?
    Par birdy85 dans le forum EDI, CMS, Outils, Scripts et API
    Réponses: 3
    Dernier message: 15/01/2008, 21h56
  2. Quel éditeur, quelle version de MySQL ?
    Par amazircool dans le forum EDI, CMS, Outils, Scripts et API
    Réponses: 7
    Dernier message: 07/09/2006, 16h59
  3. Réponses: 1
    Dernier message: 07/05/2006, 01h26
  4. Réponses: 1
    Dernier message: 05/05/2006, 23h34
  5. [Wamp] Quelles versions php/mysql/apache XP?
    Par Jean_Benoit dans le forum EDI, CMS, Outils, Scripts et API
    Réponses: 4
    Dernier message: 27/09/2005, 20h41

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo